Nouveau SSD : impossible d'installer OS X ?!

nayals

Membre junior
8 Août 2010
95
5
Bonjour à tous,

Je viens de recevoir un SSD 256 Go Ultra Plus de SanDisk pour le mettre dans un MacBook Pro 13" Mid-2010. J'ai donc créé une clé de restauration d'OS X 10.9.1 avec l'utilitaire sur le site d'Apple, puis ouvert le Mac pour remplacer l'ancien disque dur par le nouveau SSD. Je démarre ensuite sur la clé, formate le SSD, puis j'essaye de lancer l'installation d'OS X. L'ordi explique qu'il va vérifier l'admissibilité de la configuration auprès d'Apple, puis m'affiche le message suivant : Erreur lors de la préparation de l'installation.

Voilà, c'est tout le problème. J'ai essayé de vérifier le disque (tout est OK), et même de démarrer non pas sur la clé mais sur "Internet Recovery" (qui télécharge une partition de restauration). Le problème persiste. J'ai cherché sur Internet des cas similaires, il y en avait, mais je n'ai pas trouvé de solution.

J'en appelle donc, un peu désespéré, à votre aide ! Merci d'avance à tous :)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
51 145
9 645
Nancy___
Bonjour,

Avec Utilitaire de disque, il faut vérifier que le schéma de table de partition soit GUID. S'il ne l'est pas, tu sélectionnes ton SSD / onglet Partition / Option / 1 partition -> choisir GUID.

Ensuite, formatage en Mac OS étendu journalisé.
 

just_pierre

Membre junior
25 Février 2012
10
0
Moselle (57)
www.chezpierre.fr.nf
Bonsoir.

J'ai installé exactement le même SSD sur mon McBook 13' Late 2008 il y a 2 jours. Pour réinstaller OS X, j'ai créer une clé USB Bootable à partir de l'installateur de 10.9 téléchargé sur le MacApp Store. J'ai suivi ce tuto.

Puis j'ai installé le SSD et j'ai botté sur la clé (en appuyant sur ALT au démarrage du Mac). J'ai formaté en HFS+ journalisé et sensible à la casse avec une table de partition GUID grâce à l'utilitaire de disque. Enfin, j'ai lancé le programme d'installation depuis l'écran d'accueil. Pour info, il est au moins resté 20 minutes sur "Temps restant : 1 seconde" avant de redémarrer et de commencer à proprement parlé l'installation.

Voilà j'espère que ça va t'aider.
 

nayals

Membre junior
8 Août 2010
95
5
Merci de ta réponse détaillé :)
Mais non, ça ne m'aide pas vraiment : ma méthode est censée être tout aussi valable, et il y a de très fortes chances pour que je sois confronté au même problème en appliquant ta méthode (et je n'ai pas de clé de 8 Go).
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
51 145
9 645
Nancy___
Cette erreur :
Erreur lors de la préparation de l'installation.
est peut être due à ta clef de restauration, pas à ton SSD.
Il faudrait peut être la refaire. Et si le tuto cité dit de prendre une clef de 8 Go, peut être faut-il vraiment le faire ?
 

nayals

Membre junior
8 Août 2010
95
5
Non, ça ne peut pas être lié à la clé, vu que j'ai essayé de faire sans et rencontré le même problème : comme dit plus haut "j'ai essayé de démarrer non pas sur la clé mais sur "Internet Recovery" (qui télécharge une partition de restauration)"

Et je me suis mal exprimé : ce n'est pas une clé contenant Mac OS X (comme proposé par le tuto, donc pour laquelle 8 Go sont nécessaires) mais simplement une clé contenant une copie de la partition de restauration de l'ancien disque (1 seul Go nécessaire). Elle est réalisée par un utilitaire d'Apple, et permet de télécharger et installer OS X : OS*X*: à propos de l?assistant Disque de récupération

Donc avoir 8 Go ne devrait probablement rien changer.

Merci beaucoup pour votre aide à tous les deux en tout cas, et continuez, les idées sont toujours bonnes à écouter :)

---------- Nouveau message ajouté à 19h58 ---------- Le message précédent a été envoyé à 19h24 ----------

J'ai trouvé la solution grâce à une recherche sur les forums d'Apple; et d'ailleurs, ça a été aussi la solution pour un beau paquet de gens visiblement. En fait, c'est simplement que la date de l'ordinateur était décalée de 4 jours avec la réalité. Il faut donc le remettre à la bonne heure avec le Terminal, sinon Apple refuse de mettre à jour.

L'opération est très simple et expliquée ici : OS X Install fails without a descriptive error - YouTube

Merci à tous pour votre aide en tout cas ! :)
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 848
5 251

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 848
5 251

Ah je savais bien, qu'il y avait une page officielle, mais je ne la retrouvais pas. Allez zou dans mes signets. Merci. ;)

Edit : je l'avais déjà dans mes signets en 2 exemplaires, pfffttttt, faut toujours vérifier.
 

nayals

Membre junior
8 Août 2010
95
5
Vraiment curieux ce problème. Au moins, ce serait sympa si le message d'erreur pouvait afficher un truc du genre : vérifiez la date et l'heure de l'ordinateur... Quelqu'un a une idée quant à pourquoi ça engendre une erreur non expliquée ?

En tout cas, merci pour le lien François, je ne risquai pas de tomber dessus vu que c'est un autre message d'erreur !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 848
5 251
Vraiment curieux ce problème. Au moins, ce serait sympa si le message d'erreur pouvait afficher un truc du genre : vérifiez la date et l'heure de l'ordinateur... Quelqu'un a une idée quant à pourquoi ça engendre une erreur non expliquée ?

En tout cas, merci pour le lien François, je ne risquai pas de tomber dessus vu que c'est un autre message d'erreur !

Curieux en effet. Mais a priori, si la date du Mac est mal réglée, les serveurs Apple considèrent le Mac comme un intrus. Ce qui pour moi paraitrait logique avec la non correspondance de la date d'achat, date et heure.
 

nayals

Membre junior
8 Août 2010
95
5
a priori, si la date du Mac est mal réglée, les serveurs Apple considèrent le Mac comme un intrus. Ce qui pour moi paraitrait logique avec la non correspondance de la date d'achat, date et heure.

À la fois je pense que tu as raison, en même temps il y a un truc que je ne saisis pas : qu'est-ce que les serveurs d'Apple en ont à faire de la date et de l'heure du Mac ? S'il veulent être sûr d'avoir une date et heure valides, il leur suffit de mettre ceux des serveurs non ?

En fait, je ne vois pas dans quelles circonstances cette erreur empêche une installation frauduleuse ou un truc comme ça.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 134
627
À côté (de ma plaque)
Ce qui est tout aussi curieux est qu'on pouvait avoir ce message d'erreur avant Mavericks en cherchant à installer le Lion sur un RAID.
De la même façon, il n'y avait pas d'explication, et on devait se contenter de la mention de l'erreur lors de la préparation de l'installation.

Bref, c'est une erreur générique : l'installeur se contente de notifier que toutes les conditions indispensables à une installation saine ne sont pas réunies. Et il faut se débrouiller avec… :rolleyes:


En pensant qu'un reset de PRAM donne le gag de nayals, j'imagine que l'installeur vérifie la RAM, et que, s'il n'y trouve pas mention d'une heure valide, il renâcle. :siffle:
 

mval

Nouveau membre
11 Août 2007
3
0
Bonjour nayals,

je poursuis la discussion au sujet du SSD 256 Go Ultra Plus de SanDisk dans un MacBook Pro 13" Mid-2010 :

maintenant que tu as réussi à booter sur ton SSD, est ce que le disque fonctionne bien en mode sata II à 3gb/s donc ?
Je pose cette question car je souhaite installer ce modèle sur mon MPB 13" mi-2010 et il semble que certains ssd ne se connectent qu'en sata I à 1,5 gb/s (quand ils sont reconnus...), il y aurait un bug du contrôleur NVidia MCP89 équipant ces machines qui ne fonctionne pas bien avec les ssd sata III...

merci de me répondre j'aimerais être sur que ça marche avant de le commander.
 

nayals

Membre junior
8 Août 2010
95
5
En tout cas je n'ai eu aucun problème depuis que j'ai réussi l'installation. Effectivement, on reste sur du SATA II, mais ça marche très bien et on sent quand même vraiment la différence : temps de démarrage divisé par 3, Logic Pro X qui démarre en 2 secondes...

Et pour te dire, il y a 4 mois, j'ai déjà installé exactement le même modèle de SSD dans un iMac et pas de problème non plus. Vu les commentaires clients très positifs sur Internet, ce SSD a l'air de convenir à tout le monde.

Après, de toute manière, tu peux acheter le disque sur Amazon, voir si ça marche, et s'il y a un problème, retour chez Amazon et remboursement intégral (le délai de retour est assez long chez Amazon de mémoire, c'est pour ça que j'en parle, mais de toute manière pour n'importe quel achat en ligne sur n'importe quel site, il y a le délai de rétractation de 7 jours).
 

mval

Nouveau membre
11 Août 2007
3
0
merci pour ta réponse rapide,

sans vouloir abuser de ton temps pourrais tu regarder dans infos système quel chipstet équipe ton modèle, le mien est un NVidia MCP89,
il y a t il écrit vitesse négociée à 3gb/s ?
Le problème chez certains est une vitesse négociée en 1,5gb/s (SATA I) alors qu'elle devrait être à 3gb/s (SATA II)
Voici ce qui est indiqué dans mon infos système pour mon hdd d'origine actuel.

NVidia MCP89 AHCI:

Fournisseur: NVidia
Produit: MCP89 AHCI
Vitesse de la liaison: 3 Gigabits
Vitesse de liaison négociée: 1,5 Gigabit
Interconnexion physique: SATA
Description: AHCI Version 1.30 Supported

ST9250315ASG:

Capacité: 250,06 Go (250*059*350*016 octets)
Modèle: ST9250315ASG


Merci d'avance pour ta réponse.