Nouveau SSD - nouvelle installation Windows 10 Critical Process died

Marko8313

Nouveau membre
17 Avril 2020
3
0
38
Bonjour,
Après énormément de lecture sur ce forum et sur le net, je me vois dans l'obligation de demander de l'aide sur ce forum sérieux. J'espère que je suis dans la bonne section.

Le sujet a été abordé mais non résolu, sur une machine légèrement différente. (Nouveau SSD dans Macbook Air 13" mid 2013)

J'expose mon problème :
Ayant un Macbook pro RETINA 2013 (A1502)
MACOS : 10.15.4
BOOTCAMP : Win10
j'ai choisi d'augmenter mon stockage interne pour diverse raison.
J'ai donc choisi l'option SSD Crucial P1 CT1000P1SSD8 ( Crucial P1 CT1000P1SSD8 SSD Interne 1To (3D NAND, NVMe, PCIe, M.2) ) + adaptateur M2 PCIe ( KALEA INFORMATIQUE © - Adaptateur M2 PCIe vers Mac 2013 2014 2015 2016 2017 avec SSD en 12+16 Points - Compatible NVMe pour Les Mac Produits après 2 - NOTA: ceci n'est pas une pub ;). C'est ma config actuelle.

J'ai donc sauvegarder ma machine avec Time machine, fais une installation propre de catalina via clé USB bootable, puis réinstallation de mes données. Jusque là tout va bien car MacOS fonctionne parfaitement (hormis un drainage de batterie légèrement supérieur - mais ça reste minime) - il se peut que cela ait son importance.

Où cela se corse, c'est à l'installation de bootcamp.
En effet, en utilisant l'utilitaire Botcamp, en utilisant l'ISO Win10_1909_French_x64 (téléchargé depuis le site de microsoft)- je suis donc allé jusqu'au bout de l'installation Windows ou du moins jusqu'au premier redémarrage. Et à ce moment j'ai obtenu une erreur du type : "L'ordinateur a redémarré de manière inatendue ou a rencontré une erreur inattendue. L'installation de windows ne peut pas continuer. Pour installer Windows, cliquez sur Ok pour redémarrer l'ordinateur, puis redémarrez l'installation".

J'ai essayé plusieurs reboot, parvenir à obtenir les console de récupérer, mais en vain.

Je me suis alors dit que j'avais, peut-être, une fausse manip. alors j'ai désinstallé Bootcamp via l'utilitaire BOOTCAMP et recommencé. mais toujours en vain.J'ai alors tenté de tout reformater et tenter une instal via MOJAVE. (pourquoi pas?) mais le résultat est le même.

J'ai investigué pas mal de piste :
  • Le module de conversion (j'en ai commandé un nouveau d'une autre marque - celui cité précédemment) - résultat identique
  • Tenter d'accéder aux paramètres avancé de l'installation de Win10 - idem
  • Réinstaller Win10 sur un MacOS vierge et différent.

Note qui je pense à son importance :

J'ai remarqué que la partition bootcamp (au moment de l'installation) n'était seulement visible simplement lorsque le câble d'alimentation est branché. De plus, si, après installation, je débranche de câble, le message d'erreur devient un écran bleu (BSOD) avec le message "Critical Process Died". Grâce à cette remarque, je soupçonne un "défaut" d'alimentation. Mais je ne pense pas être expert.

Je me tourne vers une communauté d'experts.

Je vous joint le diskutil pour avancer un peu plus.
Bloc de code:
marcmicciche@MacBook-Pro-de-Marc ~ % diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         779.0 GB   disk0s2
   3:       Microsoft Basic Data BOOTCAMP                221.0 GB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +779.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD - Données  284.9 GB   disk1s1
   2:                APFS Volume Preboot                 81.9 MB    disk1s2
   3:                APFS Volume Recovery                525.0 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
   5:                APFS Volume Macintosh HD            11.0 GB    disk1s5
Merci par avance

Note de la modération : les résultats du Terminal c'est mieux entre des balises </> Bloc de code et pas en Table.
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 701
4 303
Tout paraît normal et en ordre, en théorie, mais pas en pratique. Juste par curiosité, si tu réinstalles ton ancienne barrette SSD, que tu installes une version de macOS sans installer le moindre autre logiciel, par défaut tu peux donc installer une version de Windows. Si tout se passe bien, j'ai le sentiment que c'est ton adaptateur le problème. J'ai déjà lu quelques messages de membres ayant rencontré non pas un problème similaire, mais une mauvaise reconnaissance de leur adaptateur. A voir.
 

Marko8313

Nouveau membre
17 Avril 2020
3
0
38
Salut Locke,

Merci pour ta réponse.
Je testerai cela quand le temps me le permettra. (Teletravail oblige.)
Il est vrai que la piste de l adaptateur est la plus probable.
Peut être quelqu’un peut me conseiller un adaptateur adéquat?

Je ferai un retour quand j aurai testé.
A+
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 701
4 303
Pour l'adaptateur, c'est une hypothèse, mais un écran bleu (écran de la mort) sous Windows est généralement un problème de mauvaise reconnaissance par des fichiers système d'une partie des matériels.
 

Marko8313

Nouveau membre
17 Avril 2020
3
0
38
Bonjour,

je n'ai pas fait la manip que tu as proposé car j'ai trouvé une solution à mon problème.

En effet quelques manip dans la base de registre....


Voir la solution en bas du poste 1.

"Here are the two recommendations to Install BootComp with success on a MacBook Air / Pro with a NVMe SSD :
  • leave the MagSafe charger plugged in during the whole installation process (don't run on battery)
  • When you see the error pop-up, "The Computer restarted unexpectedly....", please do the following :
1. Press Shift + F10 keys.
2. Launch "regedit".
3. Find this directory, "HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\ChildCompletion"
4. Once you can see "setup.exe" in the right section, double-click it and modify the value to 3.
5. Close the regedit.
6. Reboot"


Par contre par la suite, une fois que Windows s'est installé (AVEC LE CHARGEUR!!!!), une instabilité d'alimentation persiste.
J'ai encore farfouillé et trouvé une seconde solution à ce problème.

Le lien est en espagnol mais facilement reproductible en français en suivant les étapes.

Pour finir, j'ai un dernier soucis qui ne me gène pas sur l'utilisation de Windows et bootcamp.
En effet los du boot avec la touche ALT pour choisir l'OS, j'ai le choix entre 2 disques EFI boot et 1 MACINTOSH HD, le 2ème étant BOOTCAMP, et le 1er aucune idée (écran noir au lancement).

IMG_8127.jpg


J'aimerai clarifier ce point afin d'avoir une machine propre. ;)

Par avance merci.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 701
4 303
J'aimerai clarifier ce point afin d'avoir une machine propre. ;)
Clarifier la situation, non ! Le lien que tu cites est un pis-aller et s'il faut retirer l'adaptateur secteur en ayant bidouillé les paramètres d'économie d'énergie dans Windows, ce n'est pas une solution pérenne. Pour les 2 EFI boot, il faudrait que notre ami macomaniac fasse un petit passage par ici, car il faut faire des modifications dans le EFI boot de macOS.