Numbers : calcul moyenne consommation journalière...

Vinc26

Membre junior
9 Janvier 2003
97
4
Bonjour !

Je retourne le problème depuis pas mal de temps, mais impossible de trouver la formules magique dans number qui permette de rentrer les nombres en rouge (mes relevés de compteurs), pour obtenir les nombre en bleu (la moyenne de consommation par jour depuis le dernier relever : voir pièce jointe. Là, je l'ai fait à la main. Y'a-t-il une formule magique selon vous ?

:)

Capture d’écran 2017-09-02 à 14.54.28.png
 

zeltron54

Membre d’élite
29 Mars 2008
2 188
341
Lorraine
Bonjour,

Si j'ai bien compris ça paraît tout simple.
Tu veux toutes les saisies de la colonne B en rouge et celles de la colonne C en bleu.

Donc tu sélectionnes toute la colonne B en cliquant sur B en haut de la colonne, A droite tu sélectionne format --> Texte et dans Police tu choisi la couleur rouge. Là tu auras toute la colonne en écriture rouge, il te restera à sélectionner les 2 cellules titres B1 et B2 pour les remettre en noir.

Même démarche pour la colonne C avec la couleur bleue.
 

Vinc26

Membre junior
9 Janvier 2003
97
4
Merci, mais non, rien à voir avec les couleurs. Ce sont les nombres (bleu) que je souhaite obtenir à partir des nombres (rouges) :)
 

zeltron54

Membre d’élite
29 Mars 2008
2 188
341
Lorraine
Ah! Pas compris du tout avec ton message.

Donc le 28 /2 /2017 tu entres 98637 puis le 4/3/2017 tu entres 98720 et à ce moment là tu veux que ce remplissent automatiquement les cellules C3 à C6 Avec la valeur calculée qui est égale à la différence que divise le nombre de jour ?

Si c'est bien ce que tu veux (à confirmer), je vais me pencher sur le problème dés que j'aurais 5 minutes.
 

zeltron54

Membre d’élite
29 Mars 2008
2 188
341
Lorraine
Je n'ai pas trouver de solution simple! mais pour résoudre ton problème, j'ai commencé par ajouter 2 colonnes (que je masque à la fin si tu ne veux pas perturber ta vision) ce sont des colonnes en E et F.

En E3 une formule à tirer vres le bas: =SI(ESTVIDE(B3);E2;B3)
En F3 une formule à tirer vres le bas: =SI(ESTVIDE(B3);F2;$A3)
En C3 une formule à tirer vers le bas: =SI(E3≠E2;(E3−E2)÷(F3−F2);C4)

Lors de la saisie d'un index , les cellules au dessus se remplissent et en dessous elles restent à 0

L'ajout de 2 colonnes permet de ne pas avoir une formule à rallonge dans la cellule C ...

Chez moi cela fonctionne ! Dis moi si problème !
 

Vinc26

Membre junior
9 Janvier 2003
97
4
Super !!! Ca marche impec ! Je vais rajouter une gestion d'erreur. Et tu pense que tout faire en une formule est possible ? Juste par curiosité, parce que là, tout mon tableau fonctionne et je ne vais pas le changer.

C'est ton métier ?
 

luc1en

Membre émérite
19 Août 2011
790
76
Ici et là, j'aime bien changer
Bonjour,

quelle est l'usage des cellules où il n'y a ni date, ni relevé ?
La consommation journalière est répétée sans que cela apporte une information nouvelle.

Donc, sauf si on relève sa consommation journalière, c'est-à-dire en dehors des relevés pour le fournisseur d'électricité, cela alourdit le tableau sans bénéfice.

À mon avis, il suffit de mettre les quelques dates où la consommation est relevée. La gestion d'erreur pourrait alors vérifier qu'on ne saisit que des dates en colonne A et que des nombres entiers en colonne B.
La colonne C devrait aussi être protégée contre l'écriture après que toutes les formules ont été insérées.

La formule "à rallonge" est assez courte. Sur la ligne du 4 mars par exemple, saisir =(B3-B2)/(A3-A2)
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 095
1 000
Toulouse.cong
faq.office.macintosh.free.fr
Et tu penses que tout faire en une formule est possible ? Juste par curiosité, parce que là, tout mon tableau fonctionne et je ne vais pas le changer.
Oui. Mais c'est effectivement un peu moins simple. o_O Voilà comment je procède dans Excel.
En se basant sur ton exemple il faut mettre dans la cellule C3 la formule suivante :
=SI(B4="";C4;(B4-RECHERCHE(B4;B$3:B3))/(A4-RECHERCHE(B4;B$3:B3;A$3:A3)))
Il reste à recopier vers le bas et hop !

Capture d’écran.png

Après, reste à voir ce que peut faire Numbers. ;)
 
Dernière édition:

Vinc26

Membre junior
9 Janvier 2003
97
4
Ah, là, ça ne fonctionne pas trop sur Number apparement. Tu l'as fait dans quoi toi ?
 

Fichiers joints

  • Capture d’écran 2017-09-03 à 12.15.52.png
    Capture d’écran 2017-09-03 à 12.15.52.png
    92,2 KB · Affichages: 90