Numbers : formules de totalisation

Jacquemain

Membre junior
28 Mars 2020
11
0
65
Bonjour à tous j’aimerais introduire des données le matin et le soir jour après jour et avoir le résultat en fin de page avec un rappel en haut de page les premières données fonctionnent mais le résultat en plus ou en moins ne donne pas la bonne réponse je pense que je devrais mettre une formule (comme si) mais vu que je ne suis plus actif (pensionné) je ne me rappelle plus comment faire j’espère qu’une personne bienveillante pourra me venir en aide.

Je joins le fichier pour une meilleure compréhension de mon problème.
Je ne suis pas parvenu à joindre le fichier c’est pourquoi j’ai joint une capture d’écran :

342FF63B-284A-4060-8418-AEC190932D7F.jpeg

BIEN MERCI À TOUTES PERSONNES QUI POURRAIENT ME VENIR EN AIDE
 
Dernière édition par un modérateur:

baron

Membre d’élite
22 Avril 2008
1 252
279
LLN
Bonjour,

Euh… Je ne comprends pas en quoi réside ton problème.
Je présume qu'il faut le déduire de ceci :
[…] les premières données fonctionnent mais le résultat en plus ou en moins ne donne pas la bonne réponse
mais dans la copie d'écran, tout a l'air correct…?


Les calculs sont bons et la somme en bas est recopiée en haut.
92 - 91 = 1​
90,80 - 91,04 = -0,24 (le négatif est indiqué en rouge, tu peux changer ça dans le format de cellule)​
1 + (-0,24) = 0,76​


N.B. L'usage de majuscules et de ponctuation peut rendre ton texte plus compréhensible…
 
  • J’aime
Réactions: Aliboron
D

Deleted member 1108206

Invité
Bonjour,
Je ne sais pas si j'ai bien tout compris :bored: mais comme ton poids de référence est le matin, il faut soustraire le poids du soir par le matin et non matin - soir
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 738
5 677
Nancy___
Début 92 quand l’ont déduit cela fonctionne,mais quand le poids augmente il ne donne plus le poids exacte
C'est parce que tu n'as pas intégré la perte de poids entre le soir du 20 aout (91Kg) et le matin du 21 aout (90,8 Kg).
C'est pour ça que ton résultat final (Résultats !) est faux (0,76 au lieu de 0,96).
 
  • J’aime
Réactions: baron

Jacquemain

Membre junior
28 Mars 2020
11
0
65
Bonjour,
Je ne sais pas si j'ai bien tout compris :bored: mais comme ton poids de référence est le matin, il faut soustraire le poids du soir par le matin et non matin - soir
C'est parce que tu n'as pas intégré la perte de poids entre le soir du 20 aout (91Kg) et le matin du 21 aout (90,8 Kg).
C'est pour ça que ton résultat final (Résultats !) est faux (0,76 au lieu de 0,96).
je ne peux pas mettre le fichier car l'extension n'est pas accepté si j'ai une adresse mail je pourrais faire parvenir le fichier pour une meilleur compréhension du problème. Merci à toutes les personnes qui me viennent en aide
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 738
5 677
Nancy___
je ne peux pas mettre le fichier car l'extension n'est pas accepté si j'ai une adresse mail je pourrais faire parvenir le fichier pour une meilleur compréhension du problème. Merci à toutes les personnes qui me viennent en aide
L'idée du forum est de partager les questions et les réponses sur le forum ;)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 738
5 677
Nancy___
Après, si tu expliques clairement le problème que tu as, avec les chiffres du document que tu nous as présentés post#1, on devrait pouvoir agir. Est-ce que ton souci correspond à ce que j'ai tenté d'expliquer post#5 ?
 

Jacquemain

Membre junior
28 Mars 2020
11
0
65
Après, si tu expliques clairement le problème que tu as, avec les chiffres du document que tu nous as présentés post#1, on devrait pouvoir agir. Est-ce que ton souci correspond à ce que j'ai tenté d'expliquer post#5 ?
je desire qu'a partir de la pesé du premier jour au matin et le dernier jour de la colonne la différence en poids perdu ou pris s'inscrit dans le bas de la page comme dans le haut de la page a gauche pour avoir un resultat réel de perte ou de prise de poids
entre ce tte donnée de départ
date matin soir différence
1585490405003.png

et la fin de la colonne
date matin soir différence
1585490326131.png

j'aimerais retrouver un résultat précis ici et en haut de la page à gauche
 
Dernière édition par un modérateur:

Jacquemain

Membre junior
28 Mars 2020
11
0
65
Cela est plus compréhensible comme ceci ???

937FDDC0-13A3-4D3D-A323-D6E1A5B04056.jpeg

Merci à toute personnes qui me vient en aide
 
Dernière édition par un modérateur:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 738
5 677
Nancy___
Le pourquoi de ton erreur, je te l'ai donné post#5
Il faut maintenant que tu trouves une "astuce" pour intégrer le changement de perte de poids dû à la nuit.

Ou bien tu changes ta formule de la journée :
au lieu de faire poids (soir - matin)
tu fais poids (soir de la veille - soir du jour).
 

zeltron54

Membre d’élite
29 Mars 2008
1 752
262
Lorraine
Bonjour,

En complément de ce que t'a dis @Sly54 tu modifies les formules comme suit:
tu ne touches pas à E7
dans E8 tu écris : =SI(D8=0;0;D7−D8)
et tu recopies cette formule en la "tirant" sur toute la colonne E
 

Jacquemain

Membre junior
28 Mars 2020
11
0
65
En complément de ce que t'a dis @Sly54 tu modifies les formules comme suit:
tu ne touches pas à E7
dans E8 tu écris : =SI(D8=0;0;D7−D8)
et tu recopies cette formule en la "tirant" sur toute la colonne E
Super merci Cela fonctionne sauf dans le résultat en haut à gauche c’est déjà vraiment super

C9FEC4C3-4FFD-4293-ABB4-9750C689430C.jpeg
 
Dernière édition par un modérateur:

zeltron54

Membre d’élite
29 Mars 2008
1 752
262
Lorraine
Ton résultat est bien dans la cellule E157 ?
Dans le cellule en haut à gauche (B2) la formule est bien : =E157
c'est juste une recopie du résultat !
 

Jacquemain

Membre junior
28 Mars 2020
11
0
65
Je pense bien mais je joins une copie écran :

9DBBB747-EF2C-4451-82B8-DD5369BB8EA9.png

Regarde si j’ai fait une erreur ???
 
Dernière édition par un modérateur:

zeltron54

Membre d’élite
29 Mars 2008
1 752
262
Lorraine
Tu dois recopier ta formule en "tirant" jusqu'a la cellule E155 pas plus bas !
et dans la cellule E157 tu doit avoir = somme (E7:E155)
dans la cellule B2 tu dois avoir =E157