Numbers : résultat différent suivant les valeurs

dada063

Nouveau membre
28 Février 2014
9
1
Bonjour à tous,

Je bloque un peu sur une formule qui m'aiderait beaucoup.

Dans un tableau (que je vais appeler tableau X), j'ai plusieurs rangs. Chaque rang possède une case à cocher devant un texte.
Suivant le nombre de cases cochées, j'ai ma formule (NB.SI(A1:A9; "=VRAI")) qui me donne le total.

En partant de ce total, dans un autre tableau à côté (tableau Y), j'ai besoin d'une formule qui me dirait :
  • Si aucune case n'est cochée = 1
  • Si 1 case est cochée = 0,8
  • Si plus d'1 case cochée = 0,7

Ces chiffres (1, 0,8 et 0,7) sont des coefficients que je pourrai utiliser dans un troisième tableau (tableau Z) pour calculer une norme

Par avance merci pour votre aide (en espérant que mes explications sont claires)

Très bonne journée à tous

Damien
 

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Bonjour,

En supposant que ta formule =NB.SI(A1:A9; "=VRAI") soit dans la case A10 du tableau 1 , la formule dans le tableau 2 sera :
=SI(Tableau 1::$A10=0;1;SI(Tableau 1::$A10=1;0,8;0,7))
 
  • J’aime
Réactions: dada063

dada063

Nouveau membre
28 Février 2014
9
1
Bonjour @zeltron54

Génial, merci énormément !

Si je peux encore obtenir ton aide, est ce que je peux adapter cette même formule pour une plage de nombre

Par exemple, j'ai un tableau avec en abscisse une longueur et en ordonnées, une hauteur.
  • mon abscisse est découpée comme ceci : 250, 300, 400, ...
  • l'ordonnée : 250, 500, 750, 930, ...
avec des valeurs correspondantes (tableau en exemple)

Si je rentre une valeur abscisse (exemple : 430), et une valeur ordonnée (820) est ce qu'une formule pour me donner la valeur au croisement de ces deux valeurs rentrées ? Par exemple, 430 est compris entre 400 et 500 et 820 est compris entre 750 et 930 donc ça doit me sortir la case 6,4 kg.

Ou si impossible, me colorer les rangs, ligne corresponds pour que je trouve la valeurs indiquées ?

Encore merci pour la première réponse

Damien
 

Fichiers joints

  • Capture d’écran 2021-02-18 à 13.35.06.png
    Capture d’écran 2021-02-18 à 13.35.06.png
    696,2 KB · Affichages: 36

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Pour regarder ton besoin de plus près il faudrait que tu mettes un copie d'écran de ton tableau avec les numéro de ligne et de colonne...
 

dada063

Nouveau membre
28 Février 2014
9
1
Ok super, je te fais ça, merci :)
------------------------------------------------------------
Alors voilà le tableau

Donc dans le tableau 6 je rentre ma hauteur et ma profondeur. La formule serait dans mon tableau 7 et irait chercher la valeur dans le tableau 5

Avec mon exemple, il devrait faire remonter la case E5 renseignant 6,4 kg

Merci @zeltron54
 

Fichiers joints

  • Capture d’écran 2021-02-18 à 14.09.53.png
    Capture d’écran 2021-02-18 à 14.09.53.png
    198,9 KB · Affichages: 27
Dernière édition par un modérateur:

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
OK! mais il me manque les numéros des cellules (ligne et colonne) du tableau 6 pour les cellules avec 820 et 430 ?
 

dada063

Nouveau membre
28 Février 2014
9
1
OK! mais il me manque les numéros des cellules (ligne et colonne) du tableau 6 pour les cellules avec 820 et 430 ?
Oups désolé, voila mon erreur corrigée

Donc dans le tableau 6, les cellules B1 et B2 sont vierges puis complétées avec les valeurs mesurées

Merci @zeltron54
 

Fichiers joints

  • Capture d’écran 2021-02-18 à 14.41.52.png
    Capture d’écran 2021-02-18 à 14.41.52.png
    159,9 KB · Affichages: 33

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Donc dans le tableau 7 la cellule devant avoir la masse contiendra la formule:
Attention elle est longue !

Bloc de code:
INDIRECT(CONCATENER("tableau 5::";ADRESSE((LIGNE(RECHERCHEV(Tableau 6::B$1;Tableau 5::$A2:$A9;1;1))+1);(COLONNE(RECHERCHEH(Tableau 6::B2;Tableau 5::B$1:F$1;1;1))+1))))
 
Dernière édition:
  • J’aime
Réactions: dada063

dada063

Nouveau membre
28 Février 2014
9
1
Elle est longue en effet !

J'ai une erreur de syntaxe qui remonte ... est ce que tu sais me dire quel est le problème ?

Pour info j'ai essayé de copier coller ta formule : erreur de syntaxe
De recopier ta formule : erreur de syntaxe

En tout cas merci beaucoup, il manque rien pour que ça fonctionne :)
 

Fichiers joints

  • Capture d’écran 2021-02-18 à 15.22.56.png
    Capture d’écran 2021-02-18 à 15.22.56.png
    336,5 KB · Affichages: 26

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Il te manque des parenthèses vers la fin : Tableau 5::B$1:F$1;1;1))+1))))

Ou refait un copier coller , de mon post ci-dessus, il à été modifié.
 
  • J’aime
Réactions: dada063

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Content pour toi !
bonne journée.
 

dada063

Nouveau membre
28 Février 2014
9
1
Bonjour,

Je relance ce sujet car j'ai essayé de transposer ma formule dans Excel mais bien sur, ça ne fonctionne pas.

Pouvez vous m'indiquer la formule à mettre en C7 permettant de donner la valeur croisant les données entrées en C3 et C4
Capture d’écran 2021-04-13 à 13.52.05.png

Par exemple, en C3 (la hauteur), je rentre 749 mm et en C4 (la profondeur) je rentre 249 mm

Grâce au tableau de droite, je sais que avec une hauteur de 749 mm et une profondeur de 249 mm, ma masse (en C7) doit renvoyer 6kg

Si ma hauteur est de 767 mm et ma profondeur de 285 mm, la masse sera de 10,6 kg

Merci pour votre retour

Bonne journée à vous

Damien
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 008
968
Toulouse.cong
faq.office.macintosh.free.fr
D'après la disposition du tableau en exemple, tu peux saisir en C7 la formule suivante :

Bloc de code:
=INDIRECT("L" & EQUIV(RECHERCHEV(C3;F3:F11;1;VRAI);F3:F11)+3 & "C" & EQUIV(RECHERCHEH(C4;F3:K3;1;VRAI);F3:K3)+6;FAUX)
Logiquement, ça devrait coller...
 
  • J’aime
Réactions: Sly54 et dada063

zeltron54

Membre d’élite
29 Mars 2008
2 067
327
Lorraine
Bonsoir,

J'arrive un peu tard je voir que @Aliboron t'a donnée une solution. sur excel j' aurais mis ça .


Bloc de code:
=INDEX(F3:K11;EQUIV(C3;F3:F11;1)+1;EQUIV(C4;F3:K3;1)+1)

Enfin une ou l'autre du moment que ça fonctionne
 
Dernière édition:
  • J’aime
Réactions: Aliboron et dada063