Paramètres exportation vidéo perso dans iPhoto 9.5

Pahra

Membre confirmé
29 Juillet 2008
80
0
Hello tout le monde.

Depuis mon passage à Mavericks je ne trouve plus le moyen de modifier en profondeur les paramètres d'encodage d'un export vidéo d'un diaporama. Je ne peux choisir entre trois définitions (420p, 720p ou 1080p) et c'est un peu tout. Je suis peut être fatigué mais j'ai beau brasser les menus, je trouve pas.

Merci à vous!
 

Pahra

Membre confirmé
29 Juillet 2008
80
0
Bon, j'ai trouvé un semblant de solution à 70 boules. Il est possible de synchroniser sa bibliothèque iPhoto avec Aperture. Qui dispose aussi d'outils pour créer des diaporamas dont les options me permettent d'éditer des fichiers vidéo personnalisés.

Si jamais quelqu'un pouvait tout de même m'éclairer, je dirai pas non.

N'empêche, merci Apple :up:
 
A

Anonyme

Invité
Bonjour,

Tu peux exporter tes vidéos vers /tonNom/Vidéos/Séquences et utiliser iMovie qui en mesure de les gérer.
 

Pahra

Membre confirmé
29 Juillet 2008
80
0
Merci pour ton retour.

Pour ce qui est de gérer mes vidéos exportées depuis iPhoto, j'ai tout ce qui faut.

Ce dont j'ai besoin c'est pouvoir paramétrer les réglages d'exportation de vidéo sous iPhoto. Actuellement sur Mavericks je ne peux qu'exporter au mieux en 1080p, sans pouvoir toucher à l'IPS, au débit... Alors que dans la version d'iPhoto dont je disposais sur ML, je pouvais vraiment tout gérer de fond en comble.

Même s'il s'agit que de clichés fixes avec un fondu enchainé entre, on voit clairement sur la vidéo que ça manque de kb/s, et ce même si c'est exporté en 1080p. Une vidéo en 1080p de 05 minutes, avec bande sonore, qui pèse 11 mégas, même s'il s'agit du meilleurs codec vidéo du monde, j'ose même pas imaginer les paramètres de base qu'Apple nous oblige à utiliser!

Aperture plante dès le moment où je clique sur "exporter". J'ai formaté ma machine pour repartir sur une base saine, mais l'erreur est toujours présente. J'ai beau refaire une bibliothèque à frais, Aperture veut rien entendre. Alors qu'iPhoto m'exporte sans râler mes vidéos. Dans une qualité de merde.

Je suis donc totalement bloqué pour le moment. Help...
 

JLB21

Membre expert
Club MacG
22 Novembre 2007
5 858
601
Merci pour ton retour.

Pour ce qui est de gérer mes vidéos exportées depuis iPhoto, j'ai tout ce qui faut.

Ce dont j'ai besoin c'est pouvoir paramétrer les réglages d'exportation de vidéo sous iPhoto. Actuellement sur Mavericks je ne peux qu'exporter au mieux en 1080p, sans pouvoir toucher à l'IPS, au débit... Alors que dans la version d'iPhoto dont je disposais sur ML, je pouvais vraiment tout gérer de fond en comble.

Même s'il s'agit que de clichés fixes avec un fondu enchainé entre, on voit clairement sur la vidéo que ça manque de kb/s, et ce même si c'est exporté en 1080p. Une vidéo en 1080p de 05 minutes, avec bande sonore, qui pèse 11 mégas, même s'il s'agit du meilleurs codec vidéo du monde, j'ose même pas imaginer les paramètres de base qu'Apple nous oblige à utiliser!

Aperture plante dès le moment où je clique sur "exporter". J'ai formaté ma machine pour repartir sur une base saine, mais l'erreur est toujours présente. J'ai beau refaire une bibliothèque à frais, Aperture veut rien entendre. Alors qu'iPhoto m'exporte sans râler mes vidéos. Dans une qualité de merde.

Je suis donc totalement bloqué pour le moment. Help...
Avec le dernier iPhoto (9.5), effectivement, il n'y plus aucune possibilité d'accéder à des réglages personnels d'exportation…
Mais la qualité est excellente chez moi en 1080x1920. L'édition se fait par défaut en .m4v (H.264/AAC) en 30 images/s avec un débit de 5 Mbps.
On pourrait espérer un débit un peu supérieur, mais il n'y a rien à dire au point de vue qualité.

Peux-tu nous dire quelle est la définition de tes photos et avec quel appareil ont-elles été prises ?

Si tu obtiens une qualité 'de merde', c'est peut-être que tu as un problème sur ta machine… Pourrais-tu mettre au téléchargement un bref exemple ?

Car si je te donnais à comparer les deux mêmes diaporamas, l'un fait dans iPhoto et l'autre fait dans Aperture, je te défie de me dire lequel a été fait avec iPhoto ou Aperture…

Il est également anormal que tu ne puisses pas exporter avec Aperture. Ce logiciel ne permet pas de régler le débit, seulement la définition, la fréquence d'images et le codec.
Il propose en sus quatre niveaux de qualité.
Ainsi, un 1080x1920 en 50p, H.264, a un débit de 5 Mbps, donc très faible pour du 50p. Mais là aussi, la qualité est excellente.

En conclusion, je soupçonne des problèmes sur ton ordinateur. Quelle est ta version d'Aperture ?
Dans un premier temps, tu peux faire un essai d'export à partir d'un autre compte. Tu peux aussi essayer de renouveler les préférences de ce logiciel.
 

Pahra

Membre confirmé
29 Juillet 2008
80
0
Ah, merci pour ton retour.

C'est un peu minable de la part d'Apple de retirer des fonctionnalités pourtant évidentes sur son logiciel sans en informer ses utilisateurs. Mais bon passons.

Les clichés ont été réalisés avec deux boitiers, un 5D Mark je sais plus combien et un 1D MarkIV. C'est donc du plutôt bon matos.

Pour éviter tout problème de machine j'ai exprès formaté encore hier soir pour partir sur une base seine, vu qu'Aperture plantait (la dernière version en date, je l'ai téléchargé hier soir sur le store).

Je suis parvenu à faire rouler Aperture, c'était ma bibliothèque qui était vérolée. J'ai tout exporté puis réimporté proprement dans une bibliothèque neuve. Donc maintenant je peux exporter mes diaporamas via Aperture en choisissant le bitrate et tout et tout à ma guise. Mais ça m'aurait quand même mieux arrangé de tout faire via iPhoto, je ne maitrise pas du tout Aperture et j'ai besoin d'être rapide et efficace.

Si tu me dit effectivement que dans la dernière version d'iPhoto il n'est plus possible de faire ce qu'on veut, bah je pense qu'on peut clore le sujet.

Merci pour ton aide!
 

Pahra

Membre confirmé
29 Juillet 2008
80
0
Je tenais juste à revenir sur le point de la différence de qualité entre une export iPhoto classique et une export personnalisée sous Aperture. J'ai bien pris le temps de comparer les deux sorties vidéos obtenues des deux logiciels, je confirme, l'image rendue avec iPhoto est tout simplement dégueulasse. Pour une prémaquette, quelque chose de non définitif pour tester, ça peut aller. Mais en rendu final c'est abominable. On voit clairement que le bitrate est pas suffisant.
 

JLB21

Membre expert
Club MacG
22 Novembre 2007
5 858
601
Je tenais juste à revenir sur le point de la différence de qualité entre une export iPhoto classique et une export personnalisée sous Aperture. J'ai bien pris le temps de comparer les deux sorties vidéos obtenues des deux logiciels, je confirme, l'image rendue avec iPhoto est tout simplement dégueulasse. Pour une prémaquette, quelque chose de non définitif pour tester, ça peut aller. Mais en rendu final c'est abominable. On voit clairement que le bitrate est pas suffisant.
C'est bizarre, parce que je n'observe pas de différence significative entre les deux. Un débit de 5 Mbps en 30 i/s, pour des images fixes, ce n'est quand même pas mal.
Et quelle différence de débit constates-tu entre les deux pour expliquer cette différence de qualité ?

L'idéal serait de réduire tes photos destinées à un diaporama en 1080 x 1920 pixels (comme on le fait lors d'incorporation de photos dans un montage vidéo). Tu diminuerais considérablement la durée de l'encodage, et peut-être même y gagnerais tu en qualité.
Car la HD, c'est 2 millions de pixels, pas un de plus…

De toutes manières, lorsqu'on a des appareils photo ''top' comme les tiens (et j'imagine des objectifs à la mesure), on est dans le monde professionnel, et il est un peu minable de s'appuyer sur un logiciel comme iPhoto…
Et tu as mille fois intérêt à n'utiliser qu'Aperture (ou Lightroom).

Personnellement j'ai près de 14 années de photos numériques, et il y a bien longtemps que j'ai abandonné iPhoto…;)
 

Pahra

Membre confirmé
29 Juillet 2008
80
0
Oui je concède qu'iphoto est un peu minable vu ce que je lui fais manger. Le montage que je fais, ça fait dix ans que je le fais chaque année et je me dis à chaque fois "il serait temps que je trouve une alternative un peu plus pro", mais à chaque fois je m'y prends trop tard et je me vois dans l'obligation de tout rusher sur iPhoto... Si jamais tu as quelque chose à proposer... Pas Première, 3000 photos à enchaîner 😷

La résolution qu'iPhoto propose est suffisante, c'est bien le débit qui n'est pas assez soutenu. Je ne saurai dire quel est le débit de mon clip, toujours est-il que je vois apparaître des glissements de carreaux de couleurs à chaque fondu enchaîné. Je pense que le plouc de base ne remarquera rien, mais c'est pas une raison pour m'en contenter, je veux faire quelque chose de propre.

Avec Aperture je sors en 8000kbs en débit constant et c'est perfect!

Merci en tout cas pour ton aide et ton avis.