10.11 El Capitan Partage de connexion USB iPhone 6 -> MBA

Al Sah Fhyr

Membre confirmé
9 Juin 2015
109
6
29
Bonjour

Je m'explique je peu me connecté via WIFI ou BLUETOOTH de mon iPhone 6 a mon macbook air sous el captain. Par contre impossible de partager la connexion en mode USB. J'ai fais quelque recherche sur google, qui disais de supprimé puis re-installer iTunes, chose faite mais sans résultat.

J'ai pu lire sur le forum sur des sujets datant de 200X qu'il fallait supprimé "AppleUSBEthernetHost.kext" malheureusement ayant tenté de le supprimé de façon "normal" puis via le terminal impossible celui ci serait "Ni supprimé, Ni modifié car OS X le requiert"

Du coup je suis coincé :wtf:

Des solutions ?

Merci d'avance
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 940
3 178
En admettant qu'il faille supprimer cette extension, tu ne pourras le faire qu'après avoir désactivé le contrôle de sécurité SIP.

Mais j'y réfléchirais à deux fois avant de le faire (et surtout conserverais l'extension quelque part, au cas où et ferais une sauvegarde au préalable).
 

Al Sah Fhyr

Membre confirmé
9 Juin 2015
109
6
29
Bas je suis pas sur de la solution, j'ai juste vue quelque topic qui en parlé.
Du coup y'aurai pas une solution pour ca ?
Je tiens a préciser que meme le logo de l'iphone sur les paramètre réseau ne s'affiche pas.

1459329906-capture-d-ecran-2016-03-30-a-11-24-27.png


Alors que normalement je devrais voir ceci :

1459329975-capture-d-ecran-2016-03-30-a-11-25-57.png
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 940
3 178
J'ai fait un test avec mon iPhone 5S sous iOS 9.3 et mon MBA sous 10.11.3 et tout fonctionne très bien, sans avoir besoin de tripoter quoi que ce soit.
L'iPhone n'est apparu dans les réseaux disponibles qu'une fois le hotspot activé dans sa configuration.

Quelle est la version d'iOS de ton iPhone 6 ?
 

Al Sah Fhyr

Membre confirmé
9 Juin 2015
109
6
29
La dernière à jour je pense 9.3

Juste pour préciser que sous OSX je suis sur la 10.11.4

Désolé du double poste mais le bouton "éditer" semble avoir disparu lol.

--------
Problème traité ! ;-)
 
Dernière édition par un modérateur:

Al Sah Fhyr

Membre confirmé
9 Juin 2015
109
6
29
Merci pour l'édition !
Je voulais simplement revenir au nouvelle au cas ou une solution miracle me soit proposé :banghead:
J'ai désactiver la sécurité SIP, puis j'ai supprimer le fichier AppleUSBEthernethosts.kext puis ré-installer iTunes mais toujours rien... Le fichier kext se recrée mais mon iPhone n'est pas detecter en USB pour la partage de connexion mais iTunes le trouve normalement.

Je suis cependant parti dans les informations et même dans l'USB mon iPhone n'apparait pas :bored:

1459417512-capture-d-ecran-2016-03-31-a-11-44-49.png
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 940
3 178
As-tu essayé les manipulations simples préconisées par Apple ? (ici)
 

Al Sah Fhyr

Membre confirmé
9 Juin 2015
109
6
29
Alors BINGO ! Après toutes les tentatives aucune n'a marcher. Je suis même parti fouiller sur le forum anglais d'iPhone bref, j'ai enfin trouver une solution :

Desinstaller iTunes avec le terminal
Supprimer le fichier AppleUSBEthernethosts.kext
Redemarer le MBA
Re-installer le une version iTunes 10.6.3
Supprimer le fichier iTunes Library.ilb
-> A ce moment le terminal USB iPHONE reviens directement sur "réseau" au branchement de l'iphone
Redémarrer le MBA
Re-installer une version d'iTunes a jours (12.3.3)
Et magie le terminal fonctionne enfin


1459421504-capture-d-ecran-2016-03-31-a-12-46-40.png
 

Omby.Rakoto

Membre confirmé
5 Janvier 2010
308
18
Paris
Bonjour,
Pour évite de rouvrir un topic, je m'inscris sur le tien.
J'ai le même souci, mais tout simplement avec un téléphone qui fonctionne sous-android.
Evidemment tout fonctionnait parfaitement aurapavant sur d'autres mouture qu'El Capitan.

Là sous cet OS, je n'ai rien de rien (je ne regrette rien ...).

En attendant de faire peut être une meilleure recherche sur le forum, je tate ... et j'avoue ne pas comprendre pourquoi un simple truc comme ça ne fonctionne pas sur cette mouture ?!
 

Omby.Rakoto

Membre confirmé
5 Janvier 2010
308
18
Paris
Bon, n'aimant pas laisser des sujets sans que j'aie eu ma réponse, je me permets de répondre.
Je ne peux plus éditer mon message donc je suis obligé d'écrire.

J'ai simplement télécharger la bonne version de Hordnis (en tout cas la dernière moi).
Puis redémarrage et je peux enfin accéder à ce partage via USB.

Pour information, ma problématique venait du fait que j'utilise mon imprimante en wifi et l'ordinateur ne peut se connecter via l'adresse wifi qu'à un élément matériel à chaque fois, je devais donc déconnecter mon wifi de l'internet pour passer sur l'imprimante.

Voilà, voilà.
Sujet clos ?
Mille excuses si j'avais mal cherché, cela est possible ... :merci:
 
Dernière édition par un modérateur:
  • J’aime
Réactions: Sly54

Omby.Rakoto

Membre confirmé
5 Janvier 2010
308
18
Paris
Et à nouveau une petite Maj, très étrange.
Lorsque la charge de mon téléphone arrive à son max, je perds régulièrement la connexion USB.
C'est très étrange.
Je devrais ouvrir un topic pour paramétrer le mode Debugage des androids, j'avoue ne pas comprendre non plus.
Sinon, voilà les choix en mode debugage android (ou developper options).
  • Charging
  • MTP
  • PTP
  • RNDIS (USB Ethernet)
  • Audio Sources
  • Midi
Evidemment, il faudrait cocher la case RNDIS, mais bon...

--------------------------------
Note du modérateur de service (ici Aliboron) :

Quel est précisément le rapport avec macOS ? :eek:
 
Dernière édition par un modérateur: