Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Partage de fichiers bidirectionnel qui ne marche que dans un sens !

Discussion dans 'FAI et réseau Mac' créé par Lothar, 15 Juillet 2003.

Modérateurs: Nephou
  1. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Voila mon problème : il y a du réseau, de l'Airport, du mac OS X, mais aussi du 9.2.2, et je pense que le pb vient de là, alors je suis ici. Parce que sinon, vu le message de Roro, je serais ailleurs [​IMG]

    L'existant :
    -----------
    J'ai deux macs. Un eMac OS X.2, et un iMac G3 que je viens d'upgrader de 9.0 en 9.2.2. Ils sont reliés tous les deux à un hub ethernet qui est également un routeur ADSL (connecté à un modeme ADSL), point d'accès WiFi et Firewall.

    Le mac OS X.2 est connecté au Hub avec un cable Ethernet, et l'iMac avec une carte Airport.

    Il y a plusieurs comptes sur l'eMac, et la fonction "Utilisateurs Multiples" est activée sur l'iMac

    Ce qui marche :
    ----------------
    -> Tout ce petit monde peut accéder à internet. [​IMG]
    -> le possesseur de l'iMac (OS 9) a un compte sur l'eMac (OS X) auquel il peut accéder à l'aide du partage de fichier. [​IMG]

    Ce qui ne marche pas :
    -----------------------
    -> L'eMac n'arrive pas à se connecter au partage de fichier de l'iMac, alors que les autorisations adéquates ont été créées.
    -> De même, un simple accès au partage Web personnel de l'iMac est impossible.
    -> Et tout ça n'est pas étonnant, puisqu'un simple ping de l'@IP de l'iMac (que je vois simulténament sur le journal de sécurité de mon routeur et dans les réglages du partage de fichier de l'iMac) ne marche pas (host is down !!!) [​IMG] C'est dingue, puisque c'est le serveur DHCP du routeur qui lui a donné son @IP !

    Une dernière info : ça marchait en 9.0 avec une connexion Ethernet au lieu de l'Airport (mais pour ce dernier élément, je suis quasi certain que cela n'a rien à voir) [​IMG]

    VOILA VOILA VOILA

    [​IMG] Je manque un peu d'idée, présentement ... [​IMG] Toutes les vôtres seront les bienvenues.
     
  2. ficelle

    ficelle Vénérable sage
    Club MacG

    Inscrit:
    21 Avril 2000
    Messages:
    10 744
    J'aime reçus:
    815
    sur la machine en 10.2, as tu bien activé appletalk via airport ?

    les machines sont elles bien sur la meme plage ip, et le meme masque de sous reseau ?

    quelques trucs de base, quoi [​IMG]
     
  3. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    La machine 10.2 est connectée au réseau par un cable Ethernet, et elle n'a pas à se préoccuper de la façon dont le hub route les paquets (fil / sans fil).

    Pour ce qui est de la partie IP, ouaip, tout le monde est sur le même réseau, plage d'adresse IP, etc ... d'ailleurs, l'iMac cause à l'eMac, c'est donc que ça va bien !

    Pour ce qui est d'activer Appletalk, est ce que c'est nécessaire pour le client (celui qui va se connecter à la machine sur laquelle le partage de fichier est déclaré) ou pour le serveur (là où sont les données partagées) ou pour les deux ?

    Pour moi, la fonction "se connecter à un serveur" du menu "Aller" du Finder prend de toutes façon cet aspect là en charge (en tout cas, "ça marchait avant" [​IMG]).

    Lothar
     
  4. ficelle

    ficelle Vénérable sage
    Club MacG

    Inscrit:
    21 Avril 2000
    Messages:
    10 744
    J'aime reçus:
    815
    excuse moi de le prendre comme ça, mais je trouve tes deux messages assez confus.
    il me semble bien que tu n'as que 2 machines, mais tu arrives a en parler comme si tu en avais 10 [​IMG]
    si tu veux de l'aide, il faut etre plus clair pour decrire ta config... là, c'est le souc ! [​IMG]

    en ce qui concerne appletalk, je l'active sur toute les machines de mon reseau, enfin, celles qui sont censé partager des fichiers, mais aussi se connecter à d'autres.
    a+
     
  5. Onra

    Onra Accro aux Acers
    Club MacG

    Inscrit:
    17 Mai 2002
    Messages:
    3 051
    J'aime reçus:
    47
    Un vrai sac de noeuds quoi... n'est-ce pas ficelle ?

    [​IMG]
     
  6. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    C'est vrai, 'xcusez-moi. Il y a bien 2 machines en tout et pour tout (en fait, plus, mais je n'ai laissé que ces deux là pour régler le pb...).

    Je reprends :

    1 OS X.2 sur un routeur Ethernet/WiFi, en Ethernet ;
    1 OS 9.2.2 en Airport sur le même routeur ;

    L'OS X.2 est accessible en partage de fichier par l'OS 9.2.2, mais l'OS 9.2.2 ne l'est pas par l'OS X.2 ! En fait, tant qu'il est Airport, l'OS 9.2.2 n'est même pas pingable. Je viens de refaire un test en désactivant Airport sur cette machine et en lui collant un cable Ethernet sur le routeur, et là elle est pingable par l'eMac OS X.2 !

    Hallucinant, non ?

    Le pb vien(drai)t donc de la configuration du routeur pour les clients sans fil ... Je suis perplexe. Le routeur est un Belkin F5D6230F3. Y-a-t'il des utilisateurs de configurations identiques sur le Forum ?

    Merci d'avance. [​IMG]
     
  7. ficelle

    ficelle Vénérable sage
    Club MacG

    Inscrit:
    21 Avril 2000
    Messages:
    10 744
    J'aime reçus:
    815

    je crois qu'on a vu plus halucinant ! [​IMG]

    as tu essayé de placer une machine client airport sous os X ?
    par exemple, en plaçant la carte airport de la machine sous 9 dans l'autre ?
    perso, je ne connais pas bien les possibilités de airport sous os 9, et ce n'est pas faute de l'avoir utilisé [​IMG]
    mais c'est possible que ton routeur soit aussi a l'origine de tes soucis [​IMG]


     
  8. Bilbo

    Bilbo Vétéran
    Club MacG

    Inscrit:
    17 Octobre 2001
    Messages:
    7 084
    J'aime reçus:
    721
    Et le partage de fichier sur l'Imac, il est activé ? [​IMG]

    À+
     
  9. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Je n'ai pas essayé de mettre l'OS X en airport et l'OS 9 en ethernet, mais je vais le faire.

    Aujourd'hui :
    - le mac OS 9 peut avec son airport accéder au partage de fichiers du mac OS X ;
    - le mac OS 9 sous airport n'est même pas pingable depuis le mac OS X ;

    si inverser l'airport et ethernet me donne les résultats inverses (l'OS X peut accéder au partage de fichiers de l'OS 9 mais pas la réciproque & l'OS X n'est pas pingable depuis l'OS 9), cela prouverait que le routeur gère bizarrement le flux wifi).
     
  10. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Vi vi vi vi, c'est activé, et même que le routeur est allumé, et l'ordinateur aussi [​IMG]
     
  11. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Je crois avoir mis le doigt sur le problème. Ce n'est pas qu'un pb de routeur. Je vois trois choses (thanx to Intermapper, ze network scanner) ;

    - lorsque l'on fait une manip sur le routeur (du style jouer avec les restrictions adresses MAC), il peut arriver que le point d'accès "perde" le client Airport, mais il finit par le retrouver (évidemment, si je n'autorise pas l"@MAC de la carte Airport à se connecter, je n'appelle pas ça "perdre accidentellement") ;
    - si la connexion Airport n'est pas montée lorsque la session du mac OS 9 démarre, l'association ne se fait pas toujours correctement ;
    - enfin, un ensemble de paramètres du routeur permet de jouer sur les droits des clients FIL / SANS FIL (connexion, association), et il fallait jouer avec ces paramètres pour que "ça marche" ...

    Reste que le WEP n'a pas l'air de vouloir fonctionner ... A creuser.
     
  12. Bilbo

    Bilbo Vétéran
    Club MacG

    Inscrit:
    17 Octobre 2001
    Messages:
    7 084
    J'aime reçus:
    721
    Ben, le reste avait l'air propre. [​IMG] Tu n'imagines pas le nombre de fois où ce genre de post provoquait la réaction : [​IMG] [​IMG] [​IMG]

    [​IMG] [​IMG] [​IMG]

    À+
     
  13. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Si, si, ça m'est arrivé aussi ... [​IMG]
     
  14. Bilbo

    Bilbo Vétéran
    Club MacG

    Inscrit:
    17 Octobre 2001
    Messages:
    7 084
    J'aime reçus:
    721
    Pour en revenir à ton problème, regarde ce que fait ton routeur côté WiFi pour les ports 548 et 427, le 427 en particuler.

    À+
     
  15. Lothar

    Lothar Membre junior

    Inscrit:
    15 Juillet 2003
    Messages:
    36
    J'aime reçus:
    0
    Le routeur est passant sur tous les ports pour les flux sur le réseau interne (sur lequel sont mes deux machines, 1 sans fil, une en Ethernet).

    En revanche, il est TRES restrictif pour les flux échangés avec internet (plus restrictif, en fait, il faudrait qu'il soit éteint ...). Comme je le disais dans un post plus haut, je pense que le problème venait des contrôles d'assciation & de connexion sur @MAC qui fait la différence entre les clients sans-fil et les clients filaires + quelques bizarreries au niveau de l'OS 9 & peut-être des pertes momentannées de client Airport par le routeur (qui n'est pas une borne Airport).

    Lothar
     
Modérateurs: Nephou
Chargement...