Partage d'écran entre SnowLeopard et MountainLion

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 321
59
St Germain en Laye - FRANCE
Depuis que j'ai passé mon MacBook Pro sous MountainLion, mon iMac (sous SnowLeopard) n'arrive plus à s'y connecter via partage d'écran sauf si je désactive le coupe-feu du MacBook Pro (en sens inverse ça fonctionne toujours)

Sur le MacBook Pro j'ai activé le partage d'écran et autorisé l'utilisateur remy

PartageEcranActif.jpg


Tant que le coupe-feu est actif sur le MacbookPro l'Imac ne peut pas accéder au partage d'écran:
(écran de l'iMac qui essaie d'activer partage d'écran, l'accès au disque et au partage de fichiers ne pose pas pb. On voit sur la copie d'écran qu'il est bien connecté au partage de fichiers)

AccesDistanceImpossible.jpg


Pourtant le coupe-feu du MacBookPro affiche bien que Partage d'écran est autorisé en connexions entrantes:

CoupeFeuOK.jpg


J'ai essayé d'autoriser également l'utilisateur remy à la gestion à distance

GestionDistanceOK.jpg



Toujours pas possible d'accéder au partage d'écran de ce MacBook Pro depuis l'iMac



Il suffit que je désactive le coupe-feu sur le MacBook Pro et aussitôt l'iMac peut s'y connecter en Partage d'écran

PartageEcranOKCoupeFeuKO



Une idée pour forcer le coupe-feu de MountainLion à accepter le partage d'écran?

---------- Nouveau message ajouté à 12h17 ---------- Le message précédent a été envoyé à 10h43 ----------

Sur le Mac qui ne veut pas se laisser faire pour Partager son écran (le MacBook Pro dans mon cas):

- Aller dans /bibliothèque/Preferences et supprimer le fichier com.apple.alf.plist (et pour faire bonne mesure le fichier com.apple.alf.plist.lockfile)

- Ensuite redémarrer

- puis dans Preferences Système / Sécurité, réactiver le coupe feu qui devrait aussitôt demander si pour Screensharingd on doit autoriser les connections entrantes (lui répondre OUI bien sûr!! sinon pourquoi aurais-je activé le partage d'écran???)

et c'est résolu.