10.12 Sierra Partage possible sans le compte "Utilisateur invité"

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Bonjour du bout du monde,

Est-il possible de partager le dossier "Vidéos" du répertoire "Utilisateurs" de mon compte administrateur ? En effet, si "Autoriser les invités à se connecter à cet ordinateur" et "Autoriser les utilisateurs invités à se connecter à des dossiers partagés" ne sont pas cochés dans les préférences "Utilisateurs et groupes", le partage est impossible sur ma Google TV reliée à ma TV. Je me retrouve avec une session "Invités" à l'ouverture ou au redémarrage de mon Macbook Pro. Je n'en veux pas. Si je désactive "Invités" le partage ne fonctionne pas. Je n'aimerais garder que ma session Administrateur au démarrage. Je me connecte avec une ouverture de session automatique désactivée. Voilà j'espère avoir été suffisamment clair. Merci pour l'aide.
 

baron

Membre d’élite
22 Avril 2008
1 703
446
LLN
Je n'aimerais garder que ma session Administrateur au démarrage. Je me connecte avec une ouverture de session automatique désactivée.
Tu peux au moins préférer l'option "Ouverture de session" > "par nom et mot de passe", plutôt que > "par liste d'utilisateurs".

Quant à une éventuelle manière de partager un dossier sans autoriser de compte Invités, je n'en sais rien.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Tu peux au moins préférer l'option "Ouverture de session" > "par nom et mot de passe", plutôt que > "par liste d'utilisateurs".

Quant à une éventuelle manière de partager un dossier sans autoriser de compte Invités, je n'en sais rien.

Merci pour ton aide.

C'est une possibilité mais elle n'est pas très satisfaisante. Je dois indiquer mon login en plus du mot de passe alors que par liste d'utilisateurs seul le mot de passe doit être indiqué. A ce moment là, la session Invités est alors visible et accessible à tout vent. Pas très sécurisant.

Il est surprenant qu'il ne soit pas possible de partager un dossier ou un fichier depuis ça session Administrateur.

Voir la pièce jointe 118101
 

Fichiers joints

  • LWScreenShot 2017-12-04 at 17.42.30.png
    LWScreenShot 2017-12-04 at 17.42.30.png
    120,6 KB · Affichages: 45
Dernière édition:
D

Deleted member 1099514

Invité
Salut

Tu peux sans désactiver la session "Invité" la désactiver de l'affichage lors du démarrage :

sudo defaults write /Library/Preferences/com.apple.loginwindow GuestEnabled -bool false

Là ton mot de passe administrateur te sera demandé.

Pour la revalider (au cas où) :
sudo defaults write /Library/Preferences/com.apple.loginwindow GuestEnabled -bool true
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Bonsoir Jeanjd63, ici c'est le matin, soleil et déjà 30 degrés lol.

Merci pour l'aide, cela me parait pas mal, même très bien comme astuce.

Pour moi, l'idéal serait de supprimer complètement cette session Invité. Mais, je suppose que le partage ne serait alors plus possible. Pourtant ma session principale dont je suis le seul utilisateur est en Administrateur. Parfois Apple me surprends par sa complexité.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Oups....... joie de courte durée, après démarrage j'ai toujours la session Invité qui apparaît ainsi que Autre.

Mise à jour

Pour Autre, j'ai désactivé le root dans utilitaires d'annuaire, ça c'est réglé.
Toujours cette session Invité, Firevault est désactivé ainsi que le SIP.
 
Dernière édition:
D

Deleted member 1099514

Invité
Pour Autres, pas besoin de désactiver root.
Tu peux le faire par :
sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool false

Que te renvoie un :
defaults read /Library/Preferences/com.apple.loginwindow
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Plus de session Autre mais toujours Invité à l'affichage.


Bloc de code:
MacBook-Pro:~ Eric$ defaults read /Library/Preferences/com.apple.loginwindow
{
    GuestDisabled = 1;
    GuestEnabled = 0;
    IncludeNetworkUser = true;
    OptimizerLastRunForBuild = 33980800;
    OptimizerLastRunForSystem = 168560128;
    PowerOffDisabled = 0;
    SHOWFULLNAME = 0;
    "SHOWOTHERUSERS_MANAGED" = 0;
    lastLoginPanic = "534189414.024449";
    lastUser = loggedIn;
    lastUserName = Eric;
    showInputMenu = 1;
}
 
Dernière édition:
D

Deleted member 1099514

Invité
Tu vas faire :
sudo defaults delete /Library/Preferences/com.apple.loginwindow GuestDisabled

Puis tu redémarres
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Désolé pour la réponse tardive.

Ca ne change rien. Toujours Invité au démarrage de la session ou redémarrage.

Le fichier com.apple.loginwindow.plist

Bloc de code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>GuestEnabled</key>
    <false/>
    <key>IncludeNetworkUser</key>
    <string>true</string>
    <key>OptimizerLastRunForBuild</key>
    <integer>33980800</integer>
    <key>OptimizerLastRunForSystem</key>
    <integer>168560128</integer>
    <key>PowerOffDisabled</key>
    <false/>
    <key>SHOWFULLNAME</key>
    <false/>
    <key>SHOWOTHERUSERS_MANAGED</key>
    <false/>
    <key>lastUser</key>
    <string>loggedIn</string>
    <key>lastUserName</key>
    <string>Eric</string>
    <key>showInputMenu</key>
    <true/>
</dict>
</plist>
 
D

Deleted member 1099514

Invité
Quand tu vas dans menu /pref Syst/Utili et groupe déverrouille le cadenas puis tu cliques sur invité.
La case du haut "Autoriser ..... a se connecter" est-elle cochée
Et la case "Autoriser.....dossiers partagés" aussi?
Ensuite dans le terminal si tu alternes les commandes :
sudo defaults write /Library/Preferences/com.apple.loginwindow GuestEnabled -bool true
et
sudo defaults write /Library/Preferences/com.apple.loginwindow GuestEnabled -bool false

ça change qq chose à la case du haut? (Il faut passer sur un autre utilisateur et revenir pour voir les changements.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
La case du haut est décochée, cochée c'est pareil. Si je décoche celle du bas ça désactive Invité mais toujours la session Invité au redémarrage ou fermeture session.

J'ai alterné les commandes avec le Terminal, sans résultat.

Capture d’écran 2017-12-05 à 11.38.14.jpg
 
D

Deleted member 1099514

Invité
Peux-tu faire un
sudo mv /Library/Preferences/com.apple.loginwindow.plist Desktop
Puis redémarrer le Mac?
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Pareil, toujours Invité au démarrage.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Firevault non actif.

Les modifs ?
 
D

Deleted member 1099514

Invité
J'ai testé chez moi et ça fonctionne très bien. High Sierra. Mais je pense qu'avec Sierra c'est idem.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Je viens de rentrer les deux commandes séparément en redémarrant à chaque fois et bien toujours pareil. J'ai même désactivé Localisez mon Mac, j'avais vu que cela pouvait régler le problème. Et bien non c'est toujours pareil. La session Invité apparaît.
 

EricM

Membre émérite
28 Juillet 2004
691
29
53
Grimaud Var France
Me revoilà avec de bonnes nouvelles. Enfin j'espère :)

J'ai repassé les commande dans le Terminal.
sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool false

Et je ne sais par quel miracle, après avoir passé la commande que tu m'avais indiqué et bien ça fonctionne. Je teste pour voir et après validation je reviens pour confirmer.

Merci Jeanjd63

Bonne nuit ici c'est la journée et il fait 35° :wtf: