• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Partage Web personnel Urgent !!!!

Airborne

Nouveau membre
27 Septembre 2002
22
0
Visiter le site
J'ai un petit problème avec mon paratge Web personnel je ne suis plus capable de l'activer !!!! Je ne sais plus quoi faire .... Alors comment fait-on pour retrouver les configurations originales du Web server ?? Alors si vous avez la réponse n'hésiter pas à le faire savoir!
Merci à l'avance
 

Airborne

Nouveau membre
27 Septembre 2002
22
0
Visiter le site
Voici ce qui est inscrit dans mes première ligne je ne suis pas sur que celà est correct :

sudo pico /etc/htt##
## httpd.conf -- Apache HTTP server configuration file
##

#
# Based upon the NCSA server configuration files originally by Rob McCool.
#
# This is the main Apache server configuration file. It contains the
# configuration directives that give the server its instructions.
# See <URL:http://www.apache.org/docs/> for detailed information about
# the directives.
 

maousse

Vétéran
Club MacG
20 Avril 2002
7 224
445
39
Paris
orbl.eu
ces lignes sont les premières du fichier de config d'apache. Elles sont toutes inutiles (plutôt inactives) au fonctionnement d'apache, car commentées (un # en début de ligne, qui sert à ce que ces lignes ne soient pas prises en compte par le daemon apache, vu comme des commentaires) Donc, pas de soucis de ce côté là


essaie de redémarrer ton serveur avec le terminal, tape :
Bloc de code:
sudo apachectl graceful
entre ton mot de passe admin quand il t'es demandé, et ça devrait être relancé.

Sinon, si ça ne fonctionne toujours pas, vérifie les autorisations de ton disque (utilitaire de disque, onglet SOS, réparer les autorisations) ça peut aider avec un problème de ce genre.

voilà, on va voir ce que ça donne
 

Airborne

Nouveau membre
27 Septembre 2002
22
0
Visiter le site
J'ai essayé ce que tu m'as dit mais celà n'a pas fonctionné alors j'ai fait mon tes de configuration du serveur avec cette commander : sudo apachectl configtest
et celà me dit ceci : Syntax error on line 1 of /etc/httpd/httpd.conf:
Invalid command 'sudo', perhaps mis-spelled or defined by a module not included in the server configuration

Alors je crois qu'il y a soit de la corruption dans mes lignes de commandes ou soit des lignes de commandes modifiées ??

Alors là j'en ai aucune idée !!
 

maousse

Vétéran
Club MacG
20 Avril 2002
7 224
445
39
Paris
orbl.eu
ah ok


bon, tu as du essayer d'éditer ton fichier de config et te bananer là-dedans. Il faut que ça commence comme ça :
<font class="small">Code:</font><hr /><pre>
##
## httpd.conf -- Apache HTTP server configuration file
##

#
# Based upon the NCSA server configuration files originally by Rob McCool.
#
# This is the main Apache server configuration file. It contains the
# configuration directives that give the server its instructions.
# See &lt;URL:http://w...... </pre><hr />

Donc, pour y accéder, fait un 'sudo pico /etc/httpd/httpd.conf' (sans les guillemets) et rajoute un # devant la ligne (c'est la première ligne) où il y a 'sudo /etc/http#' (ctrl-x, y, et entrée pour enregistrer les modifications et quitter pico une fois que tu as modifié come tu le souhaites.

ensuite, relance ton serveur apache avec un coup de 'sudo apachectl graceful' et c'est bon
 

Airborne

Nouveau membre
27 Septembre 2002
22
0
Visiter le site
Bon avec de la détermination et un très bon coup de main de ta part et bien j'ai réussit à régler mon problème et j'ai même retrouver un erreur à la ligne 171 alors je l'ai règlé et maintenant tout fonctionne pour le mieux


Encore merci !!
 

alfred

Membre d’élite
Club MacG
31 Janvier 2003
2 425
59
bxl
ch'comprend rien.
ca a l'air compliiiiiiiiqué le terminal.