pb avec fichier .htaccess (mot de passe pas reconnu en local

inaden

Membre junior
29 Mars 2008
38
0
Bonjour à tous,
voilà, j'ai configuré mon fichier httpd.conf pour qu'il prenne en compte mon fichier .htaccess :
<Directory "/Users/denis/Sites/php/tp3_blog/admin">
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
J'ai du visé directement le dossier en ajoutant un <Directory> au fichier sinon, ça ne fonctionnait pas.

Maintenant, lorsque je tente d'aller sur une page du dossier protégé, j'ai bien une fenêtre de login et mot de passe qui s'ouvre.
Le problème c'est que le mot de passe (ou l'utilisateur) n'est pas reconnu.

Mon fichier htaccess est le suivant :
AuthName "Page d'administration protégée"
AuthType Basic
AuthGroupFile /dev/null
AuthUserFile "/Users/denis/Sites/php/tp3_blog/admin/.htpasswd"
Require valid-user

Le fichier htpasswd était tout bête :
ou bien den:den pour le pas crypté ou bien den:passcrypté pour le crypté. Le mot de pase crypté était obtenu avec la fonction crypt de php.

Si quelqu'un a une idée. Merci d'avance.

---------- Nouveau message ajouté à 08h19 ---------- Le message précédent a été envoyé à 06h26 ----------

Ah oui, une précision, je suis sur snow (10.6.3)

---------- Nouveau message ajouté à 08h20 ---------- Le message précédent a été envoyé à 08h19 ----------

Juste une précision : je suis snow (10.6.3)
 

barme

Nouveau membre
27 Janvier 2011
1
0
Les mots de passe généré par crypt() depuis PHP ne sont pas valides sur Max OS X 10.6 !

On peut contourner le problème en utilisant un mot de passe généré par la commande htpasswd. Par exemple depuis un Terminal :

htpasswd -nb den den

Mais si quelqu'un a une solution pour générer un mot de passe valide depuis PHP, je suis preneur...