Pb avec iphoto, une des photothques ne se charge plus

Tichka

Membre émérite
9 Mars 2003
625
10
ma photothèque est organisée en 3 phototéques que je gère avec iphoto library manager. Toutes les photos sont indexées avec des mots clés. Mon problème est le suivant : une des photothèques n'est plus chargées lorsque je la choisi. Après plusieurs essais j'ai découvert que le fichier iphoto library n'existait plus alors que sur les autres phototèques se chargent sans problème et le fichier iphoto library existe. J'ai donc procédé à une nouvelle importation des dossiers se trouvant dans la photothèque à problème. Les photos ont été chargées sans problème mais les mots clés ont disparus. Sachant que j'ai 1000 photos indexées , je n'ai pas envie de reprendre l'indexation. Serait-il possible de résoudre ce problème et retouver ma photothèque défectueuse telle qu'elle était ? J'espère que j'étais clair et merci pour votre aide .
 

plh

Nouveau membre
28 Juillet 2007
6
0
57
J'ai le même problème depuis une semaine. J'ai plusieurs photothèques dont certaines sont archivées sur disque externe. Deux photothèques (sur le disque dur) ne s'ouvrait plus. En déplaçant une des deux dans un autre dossier "image" je l'ai récupérée, mais l'autre reste "inouvrable" et plante iPhoto. Je crois que le problème est que j'ai déplacé une des photothèques alors que ce n'était pas celle ouverte en priorité avec iPhoto (voir aide iPhoto). J'ai vérifié les autorisations, j'ai essayer de l'ouvrir à partir d'un autre ordi (en réseau) et je n'ai toujours pas trouvé de solution. En as-tu trouvé une (en dehors de réimporter les images et de recréer les albums) ?

merci
 

plh

Nouveau membre
28 Juillet 2007
6
0
57
J'ai le même problème depuis une semaine. J'ai plusieurs photothèques dont certaines sont archivées sur disque externe. Deux photothèques (sur le disque dur) ne s'ouvrait plus. En déplaçant une des deux dans un autre dossier "image" je l'ai récupérée, mais l'autre reste "inouvrable" et plante iPhoto. Je crois que le problème est que j'ai déplacé une des photothèques alors que ce n'était pas celle ouverte en priorité avec iPhoto (voir aide iPhoto). J'ai vérifié les autorisations, j'ai essayer de l'ouvrir à partir d'un autre ordi (en réseau) et je n'ai toujours pas trouvé de solution. En as-tu trouvé une (en dehors de réimporter les images et de recréer les albums) ?

merci
OK ça marche : j'ai reconstruit la photothèque comme indiqué dans les forums précédent sur iPhoto (pomme - alt restant enfoncé on ouvre iPhoto) et il propose de reconstruire la photothèque; j'ai coché les 4 items proposés et ma photothèque a pu s'ouvrir. J'ai quand même pris garde de créér une session utilisateur sans photothèque (pour faire la manip sans risquer de modifier mes photothèques valides), et j'ai mis dans le dossier "partagé"
la photothèque qui ne s'ouvrait plus.

PS : iPhoto 5.0.4
iMacG5 - 1,8 (MacBook / eMac / G4 Cube)