Mac Pro Pb de boot : impossible de démarrer sur un autre disque que la baie1

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Bjr :
Config : MacPro 3.1 (2008) Dual Xeon 2,8 Ghz • Ram : 20 Gb • Disk : 4 x 1 To + 1 x 250 Gb (IDE).
Système : OSX 10.9 • OSX 10.9.5 • OSX 10.11 • OSX 10.11

Voici mon problème : Je peux sélectionner n'importe quel disque dans le tableau de bord démarrage, le Mac redémarre uniquement sur le disk en baie 1.
J'ai inversé les disques, rien ne change, c'est toujours le disque en baie 1 qui boot.
En revanche, je peux sélectionner/changer le disque au démarrage (touche alt), dans ce cas c'est bien le disque sélectionné qui boot.
A noter que si je mets un système sur le DD IDE, c'est lui qui va booter en premier.
A priori (mais sans certitude), je pense que le bug a du se produire lors d'une mise à jour du système.
J'ai bien entendu zappé la PRam/NVRam, changer la pile de la carte mère, fait un reset de la CM (petit bouton sous la baie 4).
Après moult recherches sur internet, je n'ai pas trouvé de problème équivalent qui ne soit réglé par la réinitialisation de la PRam/NVRam.
la commande nvram -xp ne sonne aucune information sur un "boot device"
La commande bless ne donne rien non plus : can't access "efi-boot-device" nvram variable
Pour l'instant, mes hypothèses de travail sont :
• soit un problème de hardware et dans ce cas c'est mort.
• soit un problème de firmware et dans ce cas ça va être très compliqué de restaurer le firmware. Le firmware étant à jour, l'update refuse de s'installer et le méthode de restauration prévue par Apple nécessite un graveur de CD en état de marche et un CD vierge :(
• soit un problème de corestorage logical volume qui n'est présent sur aucun disque. Mais j'avoue de ne pas m'être tenu au courant des évolutions des structures de disque d'Apple et j'ignore totalement si cela a un rapport.
Je suis à votre disposition pour tester toutes les commandes/config qui pourraient réparer ce bug.
Merci
V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
Bonsoir Galax

Dans une session «El Capitan» (et pas «Mavericks») > passe les commandes :
Bloc de code:
diskutil list
csrutil status
nvram -p

  • la 1ère retourne le tableau de disques
  • la 2è le statut du SIP (System Integrity Protection) - la commande csrutil (configuration_security_rootless_utility : utiliaire "sans root" de la sécurité de la configuration) n'est reconnu qu'à partir d'«El Capitan»
  • la 3è le tableau des variables de la NVRAM

Poste ici les retours en copier-coller > et pour bien faire ton coller -->

  • dans la page de ce fil de MacGé > presse le bouton (carré avec un + inscrit - juste au milieu de la largeur de la fenêtre totale) dans la barre de menus au-dessus du champ de saisie d'un message > menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)

=> ces informations apporteront (peut-être) un éclairage.
 

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Merci de ton aide. Voici les résultats :

diskutil list
Bloc de code:
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            999.9 GB   disk0s2
/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS backup                  999.9 GB   disk1s2
/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS El Capitan              999.3 GB   disk2s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3
/dev/disk3 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS El Capitan (hackinto... 999.3 GB   disk3s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk3s3
/dev/disk4 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk4
   1:                        EFI EFI                     209.7 MB   disk4s1
   2:                  Apple_HFS draft                   249.2 GB   disk4s2
/dev/disk5 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *160.0 GB   disk5
   1:                        EFI EFI                     209.7 MB   disk5s1
   2:                  Apple_HFS Sans titre              159.2 GB   disk5s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk5s3
Ma

csrutil status
Bloc de code:
System Integrity Protection status: enabled.

nvram -p
Bloc de code:
LocationServicesEnabled   %01
fmm-computer-name   Mac Pro de Vincent
bluetoothActiveControllerInfo   %06%82%ac%05%00%00%00%00 ]%00%1f[%7f?%e7
SystemAudioVolumeDB   %fe
bluetoothInternalControllerInfo   %06%82%ac%05%00%00 ]%00%1f[%7f?%e7
SystemAudioVolume   >
V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
Hé ! je n'ai jamais vu un tableau de la NVRAM aussi merd.... anémique - veux-je dire.

Le mien à titre d'exemple :
Bloc de code:
gpu-policy    %01
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>EB3524FD-9766-486D-A5B9-67BA6BEC9871</string></dict></dict><key>IOEFIShortForm</key><true/><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\refind\refind_x64.efi</string></dict></array>
IORegistryCurrentSleepMode    %00
prev-lang:kbd    fr:1
SystemAudioVolumeDB    %e3
BootCampHD    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%00%00%00%00%00%00%7f%ff%04%00
csr-active-config    w%02%00%00
InstallWindowsUEFI    0
fmm-computer-name    MacBook Pro 15
backlight-level    %ee%03
efi-backup-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>EB3524FD-9766-486D-A5B9-67BA6BEC9871</string></dict></dict><key>IOEFIShortForm</key><true/><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\refind\refind_x64.efi</string></dict></array>%00
efi-backup-boot-device-data    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>EB3524FD-9766-486D-A5B9-67BA6BEC9871</string></dict></dict><key>IOEFIShortForm</key><true/><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\refind\refind_x64.efi</string></dict></array>%00
previous-system-uuid    85001507-D318-307B-B288-727F4A3F0B22%00
bluetoothActiveControllerInfo    %1a%82%ac%05%00%00%000%11%fa%e0%f8G5D%87
boot-args    mbasd=1
SystemAudioVolume    9
efi-backup-boot-device-data-data    %04%01*%00%01%00%00%00(%00%00%00%00%00%00%00%00@%06%00%00%00%00%00%fd$5%ebf%97mH%a5%b9g%bak%ec%98q%02%02%04%04:%00\%00E%00F%00I%00\%00r%00e%00f%00i%00n%00d%00\%00r%00e%00f%00i%00n%00d%00_%00x%006%004%00.%00e%00f%00i%00%00%00%7f%ff%04%00
efi-boot-device-data    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00XG%f8%0d%00%00%00%00rjM%0c%8c%91%f8J%b4c%c1%0f<%dc%07%8a%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hBK%1d%a2%11%b2%91yL%bd%1d%07<%18%ef%a8%d4%04%04%9a%00\%008%005%000%000%001%005%000%007%00-%00D%003%001%008%00-%003%000%007%00B%00-%00B%002%008%008%00-%007%002%007%00F%004%00A%003%00F%000%00B%002%002%00\%00S%00y%00s%00t%00e%00m%00\%00L%00i%00b%00r%00a%00r%00y%00\%00C%00o%00r%00e%00S%00e%00r%00v%00i%00c%00e%00s%00\%00b%00o%00o%00t%00.%00e%00f%00i%00%00%00%7f%ff%04%00
boot-gamma    %10%06%00%00%05%a0%00%00%00%00%00%00%ba%00%00%00%00%00%00%00%0c%00%02%0bJ%08%85%17a%15%09$%0d%25O>JH%13M%88YYd%0do%9e{6%82%a9%a4%e7%aa%b0%c01%c9%f2%c9%91%cf%fd%f4%b4%f1%fd%f7%ff%f4%0c%00%82%0aA%07%05%17C%13H"- %0f>%a3BRKAQZk7ma%84%a5%80d%93G%8e%a9%a7%d7%a1%f1%c5%d7%c1%fa%e8|%e1%fd%f6B%f0%10%00%02%0b%f2%06E%17%a7%11%c8!%8c%1c%8f>%d5<SLsJ%1dt%9di%a5%96%a2%81n%b8s%9e%f1%c5f%abv%d8`%bf%fa%e9%a3%d0%fd%f6%ea%df%fe%fa%0e%e7%ff%fc%cd%ec%ff%fd%9c%f1%ff%fe)%f8
bluetoothInternalControllerInfo    %1a%82%ac%05%000%11%fa%e0%f8G5D%87

Si tu regardes le haut du tableau --> tu notes la variable clé : efi-boot-device > qui se trouve renseignée de l'adresse de boot automatique pour l'EFI = chez moi --> l'UUID de la partition disk0s1 (EFI_System_Partition) > avec le chemin de boot dans le volume EFI = \EFI\refind\refind_x64.efi (au boot_loader de «rEFInd»).

La présence de la variable efi-boot-device est cruciale pour tout démarrage automatique de l'EFI > car c'est l'adresse en regard qui détermine nécessairement le boot. Lorsque tu sélectionnes un volume dans le panneau : Disque de démarrage des Préférences Système > cet acte graphique écrit à la variable efi-boot-device de la NVRAM l'adresse au volume choisi (dans la syntaxe ad hoc).

L'absence de la variable efi-boot-device dans ta NVRAM est la raison suffisante qui fait qu'aucun choix de volume de démarrage ne se trouve inscrit en NVRAM.

L'absence à côté d'une foultitude d'autres variables dont celle du SIP notamment ou encore celle du démarrage alternatif en mode Récupération [etc.] constitue une anomalie absolue.

Je ne m'explique pas cet état de choses invalide.

Je te conseille de re-démarrer avec "alt" > de choisir un des volumes Récupération 10.11.x > qui t'amène à l'écran des 4 Utilitaires OS X. Va à la barre supérieure de menus de l'écran > menu : Utilitaires > lance le Terminal.

Passe la commande :
Bloc de code:
csrutil disable

  • pour désactiver le SIP. Cette désactivation n'intervient qu'après un re-démarrage.

Re-démarre avec "alt" encore pour rebooter encore en mode Récupération 10.11.x.

Passe la commande :
Bloc de code:
nvram -c

  • qui efface toutes les variables de la NVRAM (et normalement ré-inscrit la distribution par défaut - mais ne réactive jamais le SIP)

Re-démarre avec "alt" > ouvre une session «El Capitan» > passe la commande :
Bloc de code:
nvram -p

  • et poste le tableau histoire de voir s'il y a enfin la distribution normale des variables de la NVRAM.

[Note : le SIP verrouille en loucedé la plupart des variables de la NVRAM. Sauf si l'on agit via les utilitaires Apple comme le logiciel : "Disque de démarrage". Tu vas bien voir...]
 
Dernière édition:

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Résultat : rien de bon, j'en ai peur.
J'ai réalisé les opérations proposées plusieurs fois. Bilan : le contenu de la nvram n'a pas changé.
MAIS. Lorsque je fais csrutil disable, le mac me répond bien que SIP est désactivé. Mais au démarrage suivant sur la recovery part, le SIP est toujours verrouillé : csrutil status : enabled (j'ai essayé 2 ou 3 fois)
Du coup, j'ai quand même tenté de zapper la pram au démarrage suivant (alt pom PR), mais ça ne change rien. Le contenu de la nvram n'a pas changé.
Ou j'ai loupé quelque chose, ou ça sent le sapin :(
V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
La mémoire NVRAM de ton Mac échappe à tout contrôle et ne comporte qu'une sous-distribution des variables attendues. Comme si elle était verrouillée.

Dans le tableau des disques que tu avais posté --> est-ce que c'est le disk0 actuel (celui qui porte le volume Macintosh HD) qui est dans la baie 1 ? --> donc est-ce que c'est Macintosh HD le volume de démarrage par défaut ? - recelant quel OS : «Mavericks» ?

- question : qu'est-ce que contient le volume backup (disk1s2 sur le disk2) ? - un OS démarrable ?
 

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Désolé pour le retard, je n'étais plus à coté de la machine.

/dev/disk0 baie1 Macintosh HD osx10.9.5
/dev/disk2 baie2 El Capitan osx10.11

J'ai inversé baie1 et baie2 et c'est là que ça se complique
Bloc de code:
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS El Capitan              999.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS Macintosh HD            999.9 GB   disk1s2
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS backup                  999.9 GB   disk2s2
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS draft                   249.2 GB   disk3s2
/dev/disk4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk4
   1:                        EFI EFI                     209.7 MB   disk4s1
   2:                  Apple_HFS El Capitan (hackinto... 999.3 GB   disk4s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk4s3

Ne tiens pas compte du disque sans titre du tableau précédent. C'était un disque USB que j'ai retiré depuis.
Tu remarqueras que le dev/disk2 est devenu /dev/disk0 et que /dev/disk0 est devenu /dev/disk1.
Il me semblait que sous linux les /dev/diskx étaient attaché à leur position physique dans la machine.
Backup est en baie3 et contient un OSX 10.9 D'ailleurs je devrais plutôt l'appeler SandBox. C'est un volume où je teste les logiciels et les versions mini du système correspondant.
V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
Il me semblait que sous linux les /dev/diskx étaient attaché à leur position physique dans la machine.

Oui et non. Le n° de disque est un index affecté au disque en fonction de son rang temporel d'attachement au Système du Mac au démarrage (dans le temps du boot). C'est donc une variable.

Mais dans un Mac simple (un seul disque) > c'est le disque interne (connexion SATA sur les anciennes bécanes) qui est toujours le plus rapide à être attaché temporellement au Système du Mac au démarrage --> il est donc toujours disk0. Cet index n'est donc pas une constante - c'est une variable qui a l'air d'une constante > parce que la connexion SATA interne conditionne une priorité temporelle.

Dans un Mac Pro (4 baies) > il est vraisemblable que ce principe s'applique aussi --> à savoir que l'ordre temporel d'attachement au Système du Mac au démarrage dépende de l'ordre des baies. Donc que le disque de la baie n°1 soit toujours le premier à être temporellement attaché = disk0 > le disque de la baie n°2 toujours le second = disk1 etc.

----------

Bref. Comme actuellement le disque qui supporte le volume El Capitan est dans la baie n°1 = disk0 --> je suppose que c'est sur ce volume El Capitan que ton Mac démarre automatiquement.

Alors > dans ta session de ce volume El Capitan démarré > passe la commande (copier-coller - déroule bien le tapis roulant car la commande est kilométrique) :
Bloc de code:
sudo bless --folder /Volumes/Macintosh\ HD/System/Library/CoreServices --file /Volumes/Macintosh\ HD/System/Library/CoreServices/boot.efi --setBoot

  • cette commande re-bénit l'en-tête du volume Macintosh HD en y inscrivant l'adresse de boot pour l'EFI au fichier boot_loader : boot.efi --> mais surtout par l'option finale --setBoot détermine (normalement) l'inscription en NVRAM > à la rubrique : efi-boot-device > d'une adresse de démarrage automatique pour l'EFI au volume Macintosh HD monté sur la partition disk1s2. Ce qui oblige l'EFI > dans le temps du boot > à attendre que le volume Macintosh HD soit monté après le volume El Capitan monté préalablement > pour booter ce volume épigone

Cette commande passée > re-démarre sans option (pas de touches pressées au clavier) --> est-ce que le boot se fait sur le volume Macintosh HD (= «Mavericks») ou bien sur le volume El Capitan (= «El Capitan») ? --> si le boot continue de s'effectuer sur le volume El Capitan > c'est que la NVRAM est in-inscriptible dans ton Mac Pro et que le boot s'effectue par défaut - via le boot_manager de l'EFI - sur le premier volume monté par défaut dans le temps du boot (càd. le 1er volume démarrable trouvé) = le volume du disque de la baie n°1 > parce qu'il est le premier temporellement attaché au Système du Mac et donc disk0.
 
Dernière édition:

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Humm. Voici le résultat (qui n'est guère encourageant)
Bloc de code:
sudo bless --folder /Volumes/Macintosh\ HD/System/Library/CoreServices --file /Volumes/Macintosh\ HD/System/Library/CoreServices/boot.efi --setBoot
Password:
Could not set boot device property: 0xe00002bc

Tu as l'air de bien t'y connaître en la matière aussi j'ai quelques questions annexes :
Le contenu de la nvram est-il entièrement fixé par le système : variables et valeurs de variables ?
ou
les variables sont-elles définies par le firmware et c'est le système qui fixe les valeurs ?
Je pose la question car je me dis que si la nvram est verrouillée, la solution la plus simple serait peut-être de débrancher la machine, enlever la pile de sauvegarde de la nvram et attendre 24/48 que l'alim se vide complètement de son jus. Parallèlement, supprimer tous les disques et remettre un disque avec un système 10.6.9 qui lui n'a pas de fonction SIP si je ne m'abuse. Dans ce cas le système devrait restaurer une nvram complète si ma première proposition est juste.
En revanche, si c'est le firmware qui définit les variables, cela permettrait de voir s'il n'y aurait pas une corruption du firmware.

Mais je garde cette solution comme plan Z et je suis prêt à essayer toutes les autres solutions que tu pourras me proposer.
Et merci encore de prendre du temps pour résoudre ce problème.

V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
À l'alternative que tu poses > je n'ai pas la réponse de science sûre. Je ne peux qu'avancer une conjecture de raisonnement -->

  • le firmware : c'est la même chose que le programme interne du Mac ou EFI (= programme de boot). Logiciel recelé dans une puce de la Carte-Mère et activé par le bouton d'alimentation. Ce programme : a) teste le hardware (protocole du POST) > b) lit les valeurs des variables de la NVRAM > c) exécute le boot_loader-cible en lui passant (s'il y a lieu) les instructions lues en NVRAM (comme les flags du SIP qui transitent de la NVRAM au boot.efi via l'EFI puis du boot.efi au kernel ).

  • étant donné le déterminisme restreint de l'EFI (qui n'est qu'un programme de boot) > j'aurais donc tendance à dire que c'est le Système qui conditionne la distribution des variables de la NVRAM. Avant «El Capitan», par exemple, la variable csr-active-config n'existait pas en NVRAM --> c'est ce qui correspond au SIP.

Tu peux toujours tenter ton expérimentation sans la pile pour voir.
 

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Après avoir éteint et tout démonter, pile, CG et disques (y compris CD), je n'ai remis qu'un DD contenant un 10.6.9 server, la pile de sauvegarde et la CG (GT120). Après le redemarrage, j'obtiens
nvram -xp :
Bloc de code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EFIBluetoothDelay</key>
    <data>
    uAs=
    </data>
    <key>SystemAudioVolume</key>
    <data>
    MA==
    </data>
</dict>
</plist>
J'ai "setté" le DD de démarrage, mais pas de différence sur la nvram
Du coup je me suis dit, faisons varier les paramètres de 2 items affichés. Couper le BT et le son et re
nvram -xp
Bloc de code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EFIBluetoothDelay</key>
    <data>
    uAs=
    </data>
    <key>SystemAudioVolume</key>
    <data>
    gA==
    </data>
    <key>boot-args</key>
    <string>srv=1</string>
    <key>efi-boot-device</key>
    <string>&lt;array&gt;&lt;dict&gt;&lt;key&gt;IOMatch&lt;/key&gt;&lt;dict&gt;&lt;key&gt;IOProviderClass&lt;/key&gt;&lt;string&gt;IOMedia&lt;/string&gt;&lt;key&gt;IOPropertyMatch&lt;/key&gt;&lt;dict&gt;&lt;key&gt;UUID&lt;/key&gt;&lt;string&gt;BECFA985-BC18-475D-8318-02A50655CD36&lt;/string&gt;&lt;/dict&gt;&lt;/dict&gt;&lt;key&gt;BLLastBSDName&lt;/key&gt;&lt;string&gt;disk0s2&lt;/string&gt;&lt;/dict&gt;&lt;/array&gt;</string>
    <key>efi-boot-device-data</key>
    <data>
    AgEMANBBAwoAAAAAAQEGAAIfAxIKAAAAAAAAAAQBKgACAAAAKEAGAAAAAACwFiITAAAA
    AIWpz74YvF1HgxgCpQZVzTYCAn//BAA=
    </data>
    <key>prev-lang:kbd</key>
    <data>
    ZnI6MQ==
    </data>
</dict>
</plist>
ou si tu préfère nvram -p
Bloc de code:
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>BECFA985-BC18-475D-8318-02A50655CD36</string></dict></dict><key>BLLastBSDName</key><string>disk0s2</string></dict></array>
efi-boot-device-data    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%b0%16"%13%00%00%00%00%85%a9%cf%be%18%bc]G%83%18%02%a5%06U%cd6%02%02%7f%ff%04%00
boot-args    srv=1
EFIBluetoothDelay    %b8%0b
SystemAudioVolume    %80
prev-lang:kbd    fr:1

J'ai préféré te donner ces infos avant de redémarrer le Mac. La suite, après redemarrage...

V.
 

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Bon, depuis ce post (qui n'était pas passé), les news sont moins bonnes. En gros, la nvram ne se sauvegarde pas. Après redémarrage, je ne retrouve que les paramètres relatifs au volume du son et délai BT. Je viens de rechanger la pile, par une neuve sortie du blister, mais cela ne change rien. Je suppose donc qu'il s'agit un problème sur la carte mère. Peut-être un contact de la pile dessoudé. Le temps d'écrire ce post, je fais un dernier test pour valider ma supposition. J'ai débranché l'alim et le réseau. En tout état de cause, l'horloge devrait retourner au 01/01/2001. Si ce n'est pas le cas, alors je n'y comprends plus rien :'(
Aurais-tu d'autres idées à me soumettre ?

V.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
Tu avais récupéré une variable efi-boot-device > pointant à la partition disk0s2 du disk0 (baie 1) - mais apparemment ce sont des évanescentes. Donc la NVRAM ne conserve pas les instructions (un comble pour un mémoire non-volatile > que de se comporter comme une RAM).

Je n'ai pas de meilleure idée.
 

Galax-Ajh

Membre confirmé
5 Janvier 2018
73
3
59
Et bien, je crois que j'ai le truc le plus improbable. Bien que j'ai débranché TOUS les câbles, l'heure est conservée, donc la pile est bien opérationnelle. Ou alors il y en a une autre cachée quelque part et non documentée..
Il ne me reste plus qu'à trouver un truc bien improbable sur la base d'un hackintosh...
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 705
26 341
Forêt de Fontainebleau
:coucou: Galax

Comme je suis ignare dans le domaine du hardware du Mac --> je ne peux plus d'être d'aucun secours.

Le problème est circonscrit localement : mémoire NVRAM qui ne stocke pas la distribution des variables de démarrage. Quant à la raison du problème : ça reste une inconnue.