Pb de connexion base de données avec MAMP

tranquila

Nouveau membre
12 Avril 2014
2
0
Bonjour,
Dans le but de passer de IWEB à Wordpress, j'ai installé wordpress et MAMP. Je rencontre un problème de connexion à la base de données lors de l'accès à Wordpress.

Ma configuration : MACbook - Maverick 10.9.2 Mémoire 2Go
Ma configuration WP actuelle
- Version MAMP 3.0.4
- Version de WordPress : 3.8.1 français
- Version de PHP/MySQL : PHP 5.5.10 - MySQL 5.5.34
- Thème utilisé : Néant
- Extensions en place : Néant
- Nom de l'hebergeur : Néant
- Adresse du site : Localhost

MAMP est dans /application/
Les Fichiers wordpress sont dans /users/Tranquila/site/

Avec FIREFOX accès à MAMP " http://localhost:8888/MAMP/?language=French " --> OK
Accès à la base "tranquila" avec PhpMyAdmin à partir de la page MAMP --> OK
Démarrage de Wordpress en tapant " http://localhost:8888 " dans FIREFOX
ERREUR rencontrée : Erreur lors de la connexion à la base de données

1° Extrait du fichier wp-config.php de wordpress
// ** Réglages MySQL - Votre hébergeur doit vous fournir ces informations. ** //
/** Nom de la base de données de WordPress. */
define('DB_NAME', ‘tranquila’);

/** Utilisateur de la base de données MySQL. */
define('DB_USER', ‘root’);

/** Mot de passe de la base de données MySQL. */
define('DB_PASSWORD', ‘root’);

/** Adresse de l'hébergement MySQL. */
define('DB_HOST', 'localhost');

2° extrait de config.inc.php de MAMP (Je ne sais pas si cela est utile à la compréhension du problème...)
PRE { font-family: "Times New Roman",serif; }P { margin-bottom: 0.21cm; } // The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use $cfg['Servers'][0]. // You can disable a server config entry by setting host to ''. $i++; $cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address $cfg['Servers'][$i]['port'] = '8889'; // MySQL port - leave blank for default port $cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket $cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket') $cfg['Servers'][$i]['extension'] = 'mysql'; // The php MySQL extension to use ('mysql' or 'mysqli') $cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection // (requires PHP >= 4.3.0) $cfg['Servers'][$i]['controluser'] = ''; // MySQL control user settings // (this user must have read-only $cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user" // and "mysql/db" tables). // The controluser is also // used for all relational // features (pmadb) $cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (config, http or cookie based)? $cfg['Servers'][$i]['user'] = 'root'; // MySQL user $cfg['Servers'][$i]['password'] = 'root'; // MySQL password (only needed // with 'config' auth_type) $cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only // this db is displayed in left frame ------------
Merci de votre aide.
Tranquila
 

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 853
Bordeaux (33)
www.momofr.net
Heu, tu nous indiques un accès sur localhost:8888 et pour la BDD sur localhost, n'utilisant pas Mamp avec les règles de bases mais plutôt celle du HTTP je ne sais plus ce qu'il faut rencarder là (je sais que j'ai galéré avec le p#tain de :8888).

De toute évidence il ne trouve pas le serveur MySQL ou ta base de données (que tu as créée)… c'est bien démarré ? :rolleyes:

La procédure n'est pas compliquée mais il faut que tout soit bien suivi (notamment la syntaxe des noms)…
 
Dernière édition:

luc1en

Membre émérite
19 Août 2011
788
76
Ici et là, j'aime bien changer
Bonjour,

un extrait de votre page d'accueil de MAMP serait bienvenue, pour aider en connaissance de cause.

Exemple
installation standard de MAMP a dit:
Pour vous connecter au serveur MySQL dans vos propres scripts PHP, utilisez les paramètres suivants:

Hôte localhost
Utilisateur 8889
User root
Mot de passe root

Dans les préférences de MAMP, onglet Apache, on doit avoir
installation standard de MAMP a dit:
/Applications/MAMP/htdocs

Le lien donné par momo-fr explique vraiment tout en détail.
La base de données a-t-elle été créée ? Porte-t-elle bien le nom qui a été reporté dans le fichier wp-config.php ?

Déjà un bon point : "Erreur lors de l’établissement de la connexion à la base de données" signifie que MAMP est correctement installé.
C'est donc le paramétrage de Wordpress qui clocherait.
 
Dernière édition:

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 853
Bordeaux (33)
www.momofr.net
Dans ce genre de cas le mieux c'est de supprimer config.php et replacer le fichier original wp-config-sample.php ça va relancer la procédure.

Auparavant vous créez un nouvelle BDD dans PhpMyAdmin (avec un autre nom). Une fois tout rentré dans l'ordre on peut juste changer le nom de la base de données dans config.php pour retourner sur la BDD précédente si elle contient des contenus existant (sinon pas la peine on la supprime). En local c'est très simple.

Sinon cet article sur ce sujet est instructif… bon courage. :cool:
 

tranquila

Nouveau membre
12 Avril 2014
2
0
Bonjour,

Merci à tous.
J'ai réinstaller wordpress.
Sans créer le fichier wp-config.php je me suis connecter sous firefox à localhost:8888
la Procédure d'installation a démarré me proposant de créer le fichier wp-config.php.
J'ai suivi les instructions et tout c'est bien passé.
Reste à maitriser la bête.:siffle:

Encore merci à tous.:up:

Jean-luc - Tranquila
 

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 853
Bordeaux (33)
www.momofr.net
Pense à passer en 3.9, l'éditeur a pas mal évolué côté gestion des médias, tu seras plus tranquille pour la suite.

Si tu souhaites tester des thèmes Premium contacte-moi en MP, j'ai un petit stock dans mes cartons dont je ne me sert pas.