PDF ne marchant pas sous OS X mais si sous windows !

Jerome_C

Membre émérite
5 Février 2007
825
34
Poissy
Salut,

bon alors là c'est fort : tous mes relevés de banque sont stockés sur mon site bancaire en pdf, en général je traine pour les récupérer (j'utilise pas le papier, y'a le site hein) et là je m'y mets (archivage), ils sont tous ok jusqu'à celui de septembre, et tous les suivant sont pourris : quand aperçu les ouvre il y a du blanc dedans, et des caractères pourris dans la barre de navigation (ils ont normalement 2 ou 3 pages).

J'ai alors l'idée de tenter via parallels sous win XP, où je suis obligé d'installer adobe reader que j'avais jamais mis (c'est nul windows / troll), et là ça marche nickel. Je peux les voir et les imprimer.

Avec textedit ça commence par ça :

%PDF-1.6
%����
1 0 obj
[/PDF/ImageB/ImageC/ImageI/Text]
endobj
4 0 obj
<</Length 5 0 R
/Filter/FlateDecode
>>
stream
<...plein de jolis caractères...>

mais ceux que j'arrive à ouvrir sans problème sous OS X, aussi.

Comme si à partir de septembre ils avaient changé quelque chose dans leur façon d'encoder les pdf... pas compatible avec le mac ??

Bon je suis plus bloqué, grâce à windows :casse: mais ça me broute !!
 

macaccro

Membre confirmé
7 Octobre 2002
357
9
Bonjour,

Euh lire vos PDf avec Aperçu ça devrait aller mieux ou avec QuickLook (la barre d'espace sur Leopard)

Textedit c'est pas sa spécialité les PDF
 

Jerome_C

Membre émérite
5 Février 2007
825
34
Poissy
Mais non enfin bien sûr que je les lis avec aperçu :D

La je montrais ce qu'il y a dedans, histoire de vérifier que c'est bien du pdf, et on dirait bien (cf. ma remarque).

Pas de quicklook, je suis en 10.4.11.

C'est donc sous aperçu qu'ils sont "blancs" avec des caractères tout caca dans la barre de navigation...
 

twinworld

Vétéran
Club MacG
4 Janvier 2007
7 818
409
49
Lausanne et Paris
c'est possible que la banque ait changé d'encodage. ça serait pas la première fois qu'une banque fournit des documents informatiques lisibles uniquement sur PC. ça arrive même que l'accès à leur site soit restreint aux seuls PC.

En vous lisant, j'ai cru comprendre que c'est seulement sur PC que vous utilisez Acrobat Reader. C'est juste ? Sur OS X vous l'avez pas installé ? Si vous n'avez pas Reader sur Tiger, et que vous l'installez, ça fonctionne ?
 

Jerome_C

Membre émérite
5 Février 2007
825
34
Poissy
Hé bé la voila la réponse !

Sot que je suis, à aucun moment il m'était venu à l'idée que Acrobat Reader existait pour OS X :D

Donc oui ça marche très bien sous AR (avec un warning sur une police mais ça le lit bien on dirait, sous windows je n'avais pas ce warning), c'est aperçu qui ne s'en sort pas.

Merci !!
 

Rurutu

Nouveau membre
5 Décembre 2007
9
0
64
Bonjour,

J'ai des problèmes récents avec des pdf certainement non encodés pour mac. Je ne peux les lire que sur un PC, car mon aperçu ne les lit pas.
J'ai pensé installer Acrobat Reader, mais j'ai un OSX.3.9 et adobe ne propose plus de téléchargements antérieurs à 10.4...

Pouvez-vous m'aider ou mon vieil emac (1GHz avec Panther) est-il condamné ?

Merci !

Rurutu
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 469
3 529
68
Sous la limite KT
Bonjour,

J'ai des problèmes récents avec des pdf certainement non encodés pour mac. Je ne peux les lire que sur un PC, car mon aperçu ne les lit pas.
J'ai pensé installer Acrobat Reader, mais j'ai un OSX.3.9 et adobe ne propose plus de téléchargements antérieurs à 10.4...

Pouvez-vous m'aider ou mon vieil emac (1GHz avec Panther) est-il condamné ?

Merci !

Rurutu

Je ne sais pas combien de fois il va falloir le répéter : les PDF il faut les lire avec "Adobe Reader", Aperçu ne sait lire que les PDF "basiques", mais pour tous les PDF utilisant les fonctions avancées d'Acrobat (les fonctions de sécurité contre la falsification, essentiellement), seul Adobe Reader permet de les lire correctement !
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
13 975
964
Toulouse.cong
faq.office.macintosh.free.fr
On peut aller plus loin et préciser qu'il y a une notion de compatibilité de version dans les PDF "avancés" qui fait qu'il n'est pas possible d'ouvrir certains PDF avec des versions plus anciennes d'Acrobat Reader. Aussi bien sous Windows que sur Mac. Ainsi, certains PDF créés avec une version très récente sont impossibles à ouvrir avec Acrobat Reader 5. Comme il n'existe pas de version récente fonctionnant avec Mac OS 10.3.9, Rurutu se trouve peut-être dans un cas de figure de ce type.

Solution de contournement : demander à l'expéditeur de faire une version compatible avec des "vieux" Acrobat - ou trouver quelqu'un équipé d'Acrobat Pro qui puisse faire la manip pour toi (cas de figure que je rencontre de temps en temps au boulot où certains vieux PC n'ont pas de version récente d'Acrobat Reader).
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 469
3 529
68
Sous la limite KT
Solution de contournement : demander à l'expéditeur de faire une version compatible avec des "vieux" Acrobat - ou trouver quelqu'un équipé d'Acrobat Pro qui puisse faire la manip pour toi (cas de figure que je rencontre de temps en temps au boulot où certains vieux PC n'ont pas de version récente d'Acrobat Reader).

L'expéditeur de ce genre de PDF étant le plus souvent une administration, un organisme consulaire ou une grande entreprise, qui les génère par un processus informatique entièrement automatisé, c'est peu réaliste, comme solution de contournement, le plus simple reste quand même la mise à jour d'Adobe Reader, qui est, faut-il le rappeler, gratuit !
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
13 975
964
Toulouse.cong
faq.office.macintosh.free.fr
L'expéditeur de ce genre de PDF étant le plus souvent une administration, un organisme consulaire ou une grande entreprise, qui les génère par un processus informatique entièrement automatisé, c'est peu réaliste, comme solution de contournement
Tout à fait, sans compter que c'est parfois protégé, en plus.


le plus simple reste quand même la mise à jour d'Adobe Reader, qui est, faut-il le rappeler, gratuit !
Oui, mais il n'est pas toujours aisé de trouver une version adaptée. En l'occurrence sur Panther (config de Rurutu), on ne peut pas installer de version 8 ou 9 d'Acrobat Reader (et peut-être même pas la version 7). On peut se retrouver coincé comme ça lorsqu'on a un document trop récent et pas assez "rétro-compatible"...
 

Rurutu

Nouveau membre
5 Décembre 2007
9
0
64
Rebonjour et tout d'abord, merci de vos réponses.


  • A Pascal 77 :
J'ai omis de préciser que le PC sur lequel j'ai pu lire les pdf en question est équipé de la dernière version d'Acrobat Reader. D'où je suppose la volée de bois vert administrée en retour :rolleyes:

  • A Aliboron :
Je teste ce soir ce que je peux installer sur Panther, soit la version 8 pour ppc. Sinon ou puis-je trouver des versions antérieures sachant qu'Adobe ne les propose pas sur son site ? Je veux quand même tenter le coup, car autrement je vais devoir me débarasser de mon emac...

Rurutu.
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
13 975
964
Toulouse.cong
faq.office.macintosh.free.fr
Je teste ce soir ce que je peux installer sur Panther, soit la version 8 pour ppc. Sinon ou puis-je trouver des versions antérieures sachant qu'Adobe ne les propose pas sur son site ?
La version la plus récente qui puisse s'installer sur Panther est a priori la 7.0.9. En tout cas, à partir de la 8.0, c'est Tiger minimum...
 

Rurutu

Nouveau membre
5 Décembre 2007
9
0
64
Bonsoir,

Effectivement la 8 ne marche pas avec Panther. Et la 7 est introuvable. Etait, merci à toi, Pascal 77.
Je vous tiens au courant pour savoir si elle lit les derniers pdf reçus par ma compagne. Je lui envoie de suite.

Rurutu
 

Rurutu

Nouveau membre
5 Décembre 2007
9
0
64
Notre emac est toujours en place et fera encore du service : la version 7.0 lit tous les récents pdf reçus.
Merci à vous deux pour votre aide précieuse :up:

Rurutu
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 469
3 529
68
Sous la limite KT
Notre emac est toujours en place et fera encore du service : la version 7.0 lit tous les récents pdf reçus.
Merci à vous deux pour votre aide précieuse :up:

Rurutu
Content d'avoir pu t'aider. Cela dit, un eMac, ça ferait tourner Tiger sans problème, tu devrais y penser, car bien que son développement soit aussi arrêté, il reste quand même compatible avec beaucoup plus de choses que Panther !
 

Rurutu

Nouveau membre
5 Décembre 2007
9
0
64
Pourquoi pas ? Je pensais que ce n'était pas possible... Ma fille a Tiger sur son imac G5 ppc. Si tu dis que c'est possible, je tente le coup.

Cordialement,

Rurutu
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 469
3 529
68
Sous la limite KT
Pourquoi pas ? Je pensais que ce n'était pas possible... Ma fille a Tiger sur son imac G5 ppc. Si tu dis que c'est possible, je tente le coup.

Cordialement,

Rurutu

Tiger a fonctionné des années sur mon iMac G4/700 Mhz avec 512 Mo de Ram, or, même si ton eMac est le modèle à 700 Mhz, il est au minimum aussi puissant, donc, avec 512 Mo de Ram, Tiger doit tourner dessus !

D'ailleurs, Tiger tourne aussi sur mon "Pismo" (PowerBook G3/500 Mhz), mais là avec 1 Go de Ram :
pismo104.jpg