perte du fichier domaine d'iweb...

lisboalisboa

Nouveau membre
1 Septembre 2007
1
0
bonjours,

il y a quelque temps j'ai réalisé un petit site internet avec iweb.
Et depuis j'ai changé d'ordinateur, mais je n'ai pas sauvegardé le fichier domaine. ce fichier me semble t il me permetait de faire évoluer mon site et de le mettre à jour. il me reste heureusement sur mon server le site, mais y aurait il un moyen de recréer un fichier domaine pour continuer à faire evoluer et à mettre a jour mon site web ?

merci
 

tweek

Membre d’élite
Club MacG
3 Septembre 2005
2 309
538
31
Los Angeles, CA.
www.cocoagrove.com
bonjours,

il y a quelque temps j'ai réalisé un petit site internet avec iweb.
Et depuis j'ai changé d'ordinateur, mais je n'ai pas sauvegardé le fichier domaine. ce fichier me semble t il me permetait de faire évoluer mon site et de le mettre à jour. il me reste heureusement sur mon server le site, mais y aurait il un moyen de recréer un fichier domaine pour continuer à faire evoluer et à mettre a jour mon site web ?

merci
Malheureusement, non. Il va te falloir tout recréer. Copier-coller de tes pages (textes et photos) dans un nouveau fichier iWeb ;)
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 046
367
92
Tu arrives dans les limitations de logiciels du genre d'iWeb : un fichier format propriétaire qui une fois perdu ou endommagé oblige à tout refaire. :hein:
Pour faire un site web, rien ne vaut un bon éditeur de texte et un peu de formation à HTML. Ce n'est pas bien sorcier et bien plus efficace sur le long terme. :zen:
 

apenspel

Vétéran
Club MacG
23 Juin 2002
7 055
329
.be - BXL
Si je comprends bien, Apple a refait avec iWeb d'un format de fichier qui n'est en fait qu'un dossier ?
Moi, dans iMovie, plutôt que d'y importer mes captures venues d'un autre logiciel, je les y plaçais, pour éviter la copie par doublon.
Il n'y a pas moyen de faire pareil avec iWeb ?
 
D

Deleted member 18124

Invité
Tu arrives dans les limitations de logiciels du genre d'iWeb : un fichier format propriétaire qui une fois perdu ou endommagé oblige à tout refaire. :hein:
Pour faire un site web, rien ne vaut un bon éditeur de texte et un peu de formation à HTML. Ce n'est pas bien sorcier et bien plus efficace sur le long terme. :zen:
C'est un peu pareil pour n'importe quel fichier, non ? Si tu le perds, tu recommences tout. :siffle:
A vrai dire, le problème avec iWeb est qu'il faut savoir que le site créé est enregistré dans un fichier "Domain" logé dans Dossier utilisateur / Bibliothèque / Application Support / iWeb. On n'a pas forcément l'idée d'aller le chercher là. Et la publication dans un dossier peut être trompeuse.

Si je comprends bien, Apple a refait avec iWeb d'un format de fichier qui n'est en fait qu'un dossier ?
Moi, dans iMovie, plutôt que d'y importer mes captures venues d'un autre logiciel, je les y plaçais, pour éviter la copie par doublon.
Il n'y a pas moyen de faire pareil avec iWeb ?
Non. Je ne pense pas.
 

apenspel

Vétéran
Club MacG
23 Juin 2002
7 055
329
.be - BXL
Je vérifierais tout de même l'arborescence interne de ces "fichiers" de iWeb (clic droit, afficher le contenu du paquet). Si je me décidais à l'installer.
 

kitetrip

Membre d’élite
Club MacG
25 Août 2003
1 698
134
ici
www.rasolon.com
Ca y est iWeb m'a tout perdu :mad::mad::mad::mad:

Plus de sites plus rien...
Et là vous allez me dire : as-tu sauvegardé le "Domain" dans utilisateur / Bibliothèque / Application Support / iWeb... Eh bah OUI :eek: Et même en deux exemplaires étant d'un naturel méfiant.

Mais là je remets ma sauvegarde dans le répertoire, relance iWeb et RIEN. Rien....

Ca c'est la meilleure, même avec des sauvegardes ça ne revient pas iWeb est comme à son tout premier lancement...
Je suis sous Tiger (10.4.11) et iWeb 1.1.2... Mon site n'avait rien de particulier (ni vidéo ni flash ni son).

Je suis perdu, aidez-moi :(
 

MireilleG

Membre junior
1 Mars 2008
95
8
Ca y est iWeb m'a tout perdu :mad::mad::mad::mad:

Plus de sites plus rien...
Et là vous allez me dire : as-tu sauvegardé le "Domain" dans utilisateur / Bibliothèque / Application Support / iWeb... Eh bah OUI :eek: Et même en deux exemplaires étant d'un naturel méfiant.

Mais là je remets ma sauvegarde dans le répertoire, relance iWeb et RIEN. Rien....

Ca c'est la meilleure, même avec des sauvegardes ça ne revient pas iWeb est comme à son tout premier lancement...
Je suis sous Tiger (10.4.11) et iWeb 1.1.2... Mon site n'avait rien de particulier (ni vidéo ni flash ni son).

Je suis perdu, aidez-moi :(
Si tu as réussi à ouvrir iweb sur un nouveau site ton fichier Domain.sites à été remplacé par le nouveau site. Donc il est très important que tu ouvres iweb à partir du fichier de sauvegarde. trouve ce fichier et double click. Cela devrait l'ouvrir. fait quand même une autre copie du fichier avant de faire quoi que ce soit.
Mireille
 

Crunch Crunch

Membre confirmé
9 Septembre 2000
281
12
44
C'est clair !
IL FAUT OUVRIR DIRECTEMENT LE FICHIER "DOMAIN" ET NON IWEB !!!

Sinon, il y a de forte chance que le fichier "Domain" soit remplacé par un truc vierge...
 

kitetrip

Membre d’élite
Club MacG
25 Août 2003
1 698
134
ici
www.rasolon.com
As-tu essayé de relancer en ouvrant
par le dossier domain dans ta sauvegarde
et non pas par iWeb ?
Oui et j'obtient une version de mon site web d'il y a 6 mois je ne comprends rien à rien :(
Pourtant ma sauvegarde date de 2 jours...

Si tu as réussi à ouvrir iweb sur un nouveau site ton fichier Domain.sites à été remplacé par le nouveau site. Donc il est très important que tu ouvres iweb à partir du fichier de sauvegarde. trouve ce fichier et double click. Cela devrait l'ouvrir. fait quand même une autre copie du fichier avant de faire quoi que ce soit.
Mireille
Exactement le même résultat...

C'est clair !
IL FAUT OUVRIR DIRECTEMENT LE FICHIER "DOMAIN" ET NON IWEB !!!

Sinon, il y a de forte chance que le fichier "Domain" soit remplacé par un truc vierge...
Et encore le même résultat... Pas un site vierge mais toujours mon site comme il ya 6 mois (donc avec pleins d'autres pages en moins).

Je ne comprends vraiment rien à rien : ma sauvegarde date de ce lundi 10 mars et elle est en double (oui car une expérience fâcheuse sous Adobe m'avait corrompu ma sauvegarde...).


Donc résumé : j'ai tout tenté...
- réparer les autorisations du disque -> NADA
- double-cliquer sur le fichier "Domain" directement -> NADA

- remplacer le fichier "Domain" dans utilisateur / Bibliothèque / Application Support / iWeb - > NADA

- supprimer le fichier "Domain" de utilisateur / Bibliothèque / Application Support / iWeb puis relancer iWeb, j'obtient cette fenêtre :

je cherche mon "Domain" et là -> NADA


Donc en fait comme par magie mes deux sauvegardes me ramènent toujours sur mon site d'il y a 6 mois (donc avec au moins 10 pages en moins sans compter la mise en page):(:(:(...
 

Crunch Crunch

Membre confirmé
9 Septembre 2000
281
12
44
A un moment donné (je ne sais pas comment, ni quand), tu as du écraser le fichier "Domain" le
plus récent , par celui d'il y a 6 mois. PUIS, tu as sauvegardé celui-ci...

Et aujourd'hui... Tu réalise ton erreur...

Ce genre de scénario m'est déjà arrivé. Mais pas encore pour iWeb...
 

Crunch Crunch

Membre confirmé
9 Septembre 2000
281
12
44
Il te reste la solution de chercher sur ton disque dur (avec Spotlight ou autre), TOUS les fichiers "Domain" existant.

Tu l'a peut-être égaré quel que pars...
 

kitetrip

Membre d’élite
Club MacG
25 Août 2003
1 698
134
ici
www.rasolon.com
A un moment donné (je ne sais pas comment, ni quand), tu as du écraser le fichier "Domain" le
plus récent , par celui d'il y a 6 mois. PUIS, tu as sauvegardé celui-ci...

Et aujourd'hui... Tu réalise ton erreur...

Ce genre de scénario m'est déjà arrivé. Mais pas encore pour iWeb...
Alors là c'est fort peu probable, étant donné que je ne conserve que la sauvegarde la plus récente... Je ne peux remplacer que le fichier Domain par une sauvegarde datant tout au plus d'une semaine.

Je plaide plutôt pour l'erreur logiciel avec la fonction "Revenir à la version enregistrée" :hein: