PHP

A

Anonyme

Invité
J'ai voulu utiliser la fonction include dans mes pages mais il y avait toujours une parse error et j'ai découvert que le responsable était ceci
Bloc de code:
 <?xml version="1.0" encoding="iso-8859-1"?>
!!!
Je l'ai enlevé et cela fonctionne. Est-il nécessaire de mettre cette ligne de code car en passant mon site sans, on dit qu'il est valide au XHTML 1.1 (j'utilise les balises meta pour définir le "character coding")?
Merci
 

molgow

Vétéran
Club MacG
4 Janvier 2002
5 493
612
37
Suisse
www.monts-chevreuils.ch
C'est parce que les 2 caractères "<?" font croire à PHP que tu commences du code PHP, alors que ce n'est pas le cas.

La solution c'est de mettre :

<font class="small">Code:</font><hr /><pre>
&lt;?php echo '&lt;?xml version="1.0" encoding="iso-8859-1"?&gt;'; ?&gt;
</pre><hr />