plantage imac avec dd externe???

kardamol

Membre junior
25 Octobre 2008
47
1
Salut

J ai maudit mon imac, déception totale.

de temps en temps , mon imac devait être allumé / éteint plusieurs fois de suite pour aboutir à un démarrage complet.
debut démarrage ( pomme et roue ensuite écran bleu et plus rien )

reinstal leopard, reeinstal leo et toujours ce pb.

Et d un démarrage foireux ,j ai éteind le dd externe wd firewire et miracle le boot c est terminé

Pardon je demande pardon à mon imac

et donc question pourquoi le dd externe provoque ce disfonctionnement de temps en temps?

merci
 

Flibust007

Membre d’élite
Club MacG
15 Février 2006
2 177
67
78
Tu n'es pas fort explicite quant à la nature de ce disque externe.
Tu l'as depuis quand ?
Cela a toujours fonctionné jusque maintenant ?
Qu'as tu changé entre le moment où cela fonctionnait et maintenant ?
Quelle capacité ?
La partition est de quel type ?
Il contient quoi ?
Y a-t-il des bibliothèque Itunes, Iphoto, Aperture ou autres que tu y as déménagé ?
 

kardamol

Membre junior
25 Octobre 2008
47
1
C est un western digital.
500go-firewire 800

au début je l ai partitionné en 2 : une pour time machine et l autre comme stockage.

il y quelques jour , l envie m pris de faire de ce dd un disc de boot.

et donc formatage et suppression des 2 partitions.

création de 3 partitions : une bootable avec leopard- 1 pour time machine -l autre pour le stockage.

mais dan sles 2 cas j ai droit au plantage . c est trés aléatoire, rien pendant des semaines et un jour ça plante.

Au début , en éteignant et rallumant le mac trois fois, le boot se terminait.

Ce n est que récemment que j ai eu l idée d éteindre le dd lors d un plantage et le boot s est de suite terminé.

voila si quelqu'un a une idée du pb

merci
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 529
3 549
68
Sous la limite KT
C est un western digital.
500go-firewire 800

au début je l ai partitionné en 2 : une pour time machine et l autre comme stockage.

il y quelques jour , l envie m pris de faire de ce dd un disc de boot.

et donc formatage et suppression des 2 partitions.

création de 3 partitions : une bootable avec leopard- 1 pour time machine -l autre pour le stockage.

mais dan sles 2 cas j ai droit au plantage . c est trés aléatoire, rien pendant des semaines et un jour ça plante.

Au début , en éteignant et rallumant le mac trois fois, le boot se terminait.

Ce n est que récemment que j ai eu l idée d éteindre le dd lors d un plantage et le boot s est de suite terminé.

voila si quelqu'un a une idée du pb

merci

Une idée précise, nan, mais j'ai un problème presque similaire avec un disque USB2 (en fait un boîtier mixte USB2/Fw400 dont le Fw est mort). Si le disque est allumé : démarrage sans problème, s'il est éteint mais branché sur le hub alimenté, le démarrage de Leo bloque au même stade que toi (écran bleu clair, pas de curseur de souris).

Par ailleurs, si ce même disque est branché (allumé ou éteint), un démarrage avec la touche "alt" enfoncée à pour résultat que mes disques comportant un système s'affichent bien, mais le curseur de souris reste bloqué sur la montre, impossible de poursuivre le démarrage.

Un de mes disques système est sous Tiger, je vais tester si ça fait pareil au démarrage, je reviendrais le dire ici !



EDIT : Bon, ça y est, j'ai testé, ça ne le fait pas sous Tiger, uniquement sous Leopard, donc, Leo doit effectuer des contrôles sur sa périphérie que Tiger ne faisait pas.

Lorsque ton démarrage bloque, est-ce que le disque est resté allumé depuis l'arrêt précédent de ton Mac ? Si oui, essaie de voir ce qui se passe en éteignant le disque, puis en le rallumant avant de démarrer le Mac, comme ça, pour voir :nailbiting:
 

kardamol

Membre junior
25 Octobre 2008
47
1
Si le dd est coupé au démarrage : ras tout est ok.

Maintenant ce problème n intervient pas à chaque boot mais de temps en temps.

Le fait d éteindre le dd au plantage fait que boot se termine bien.

Mais bon , on ne connait toujours pas le l origine du pb.

Je vais surveiller l état du dd ext au démarrage.

un truc qui me vient : est il possible que imac trouve plus vite de dd externe et essaye de booter dessus. Ce qui peut expliquer que le demarrage se fait apres plusieurs allumages ?

bonne chance à toi
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 529
3 549
68
Sous la limite KT
Si le dd est coupé au démarrage : ras tout est ok.

Ça n'est pas ce que je voulais dire.

Le test à faire (en deux étapes) :

1) Tu éteins la Mac, mais pas le disque, et tu redémarres le Mac : plante ? plante pas ?

2) Tu éteins le Mac et le disque. Tu rallumes le disque, puis le Mac : plante ? plante pas ?


un truc qui me vient : est il possible que imac trouve plus vite de dd externe et essaye de booter dessus. Ce qui peut expliquer que le demarrage se fait apres plusieurs allumages ?

Non, le Mac démarre sur le disque désigné comme disque de démarrage par sa PRam. Si aucun disque n'est sélectionné, il bootera par priorité sur le disque zéro du contrôleur interne zéro.

D'ailleurs, le plantage survient bien alors que le démarrage est amorcé depuis un bon moment, puisque c'est au moment où l'écran bleu clair sans curseur de souris remplace la pomme grise et la "roue dentée" que ça bloque.

Je pense qu'à ce stade, Leopard fait un tour de contrôle de ses périphériques, et qu'il se prend dans un dead lock lorsqu'il y en a un qu'il ne peut pas monter.

Dans ton cas, ça serait qu'un périphérique Fw aurait enregistré son démontage sans être réinitialisé (d'où le test que je te propose), et dans le mien, ça serait un périphérique USB2 qu'il détecterait (le disque est éteint, mais le bridge reste alimenté par le hub, donc le Mac le voit) sans pouvoir le monter.

Cette hypothèse aurait le mérite d'expliquer nos deux cas si chez toi, le problème se manifeste dans la partie 1) du test, et pas dans la partie 2). Dans ce cas, il s'agirait d'un bug de Leo (puisque Tiger n'est pas touché par le phénomène), à signaler à Apple !
 

kardamol

Membre junior
25 Octobre 2008
47
1
Salut

le point 1 est la situation la plus fréquente et ce là ou le plantage se manifeste.

Je viens de faire un démarrage selon les consignes du point 2 et ras.

je vais essayer le 'mode' 2 pus souvent pour voir l effet

merci
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 529
3 549
68
Sous la limite KT
Ça semble donc bien confirmer ce que je pensais. Le bridge de ton disque, c'est quoi ("Menu Pomme -> A propos de ce Mac -> Plus d'infos -> Firewire" La première ligne lorsque tu sélectionne le disque dans la liste des périphériques (Fabricant)) ?
 

kardamol

Membre junior
25 Octobre 2008
47
1
et par 'chance' l imac vient de planter après un redémarrage .

j ai installé parallels desktop 4 + xp sur la partition bootable du dd externe, question de ne pas encombrer le hd du mac.

tout est ok.

J ai laissé le mac dans cet état pendant quelques heures ( san l utiliser ).

A la reprise n je le redemarre pour revenir en mode ' normal ' et hop boot interrompu . J eteind le dd externe et le boot se termine en deux secondes.

Je me demande et comme le dd externe s emet en veille si le pb ne vient pas de là.

je te met les infos demandées:

Bus FireWire :

Vitesse maximum : Jusqu’à 800 Mb/s

My Book :

Fabricant : WD
Modèle : 0x1103
GUID : 0x90A9E1BDD331AE
Vitesse maximum : Jusqu’à 800 Mb/s
Vitesse de connexion : Jusqu’à 800 Mb/s
Sous-unités :
My Book Unit :
Version du logiciel de l’unité : 0x10483
Identifiant de l’unité : 0x609E
Révision du programme interne : 0x1025
Niveau de révision du produit : 1025
Sous-unités :
My Book SBP-LUN :
Capacité : 465,76 Go
Support amovible : Oui
Nom BSD : disk2
Gestionnaires Mac OS 9 : Non
Type de carte de partition : GPT (Tableau de partition GUID)
État S.M.A.R.T. : Non géré
Volumes :
mac bboot :
Capacité : 63,93 Go
Disponible : 34,44 Go
Inscriptible : Oui
Système de fichiers : Journaled HFS+
Nom BSD : disk2s2
Point de montage : /Volumes/mac bboot
wd time :
Capacité : 89,96 Go
Disponible : 69,62 Go
Inscriptible : Oui
Système de fichiers : Journaled HFS+
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 529
3 549
68
Sous la limite KT
Je me demande et comme le dd externe s emet en veille si le pb ne vient pas de là.

On peut raisonnablement le supposer ! Depuis mon dernier post, j'ai débranché mon disque USB2 externe du hub alimenté pour le connecter directement sur un port resté libre de ma carte. Depuis, je n'ai plus de problème, puisque l'alimentation du bus USB se coupe à l'extinction du Mac (alors que le hub USB reste lui alimenté en permanence).

Dans ton cas, je ne vois qu'une explication : ton disque se met en veille, mais Leo cherche à le réveiller à un moment où il n'a pas encore chargé toutes les extensions nécessaires pour y parvenir, et il part sur un dead lock "disque réveillé ? non -> réveiller le disque" et repartir au début. Tu débranches le disque, il sort de la boucle et finit son démarrage !

Curieusement, ce problème (du moins pour la version présente chez moi) ne se manifestait pas avant Leo, ça doit être un effet de bord du à la correction mal faite d'un problème (c'est un classique en informatique : en voulant corriger un bug, on en introduit un nouveau) !
 

kardamol

Membre junior
25 Octobre 2008
47
1
et bien je crois que la boucle est bouclée.

faut il prévenir apple ?

je ne pense pas qu'ils se préoccuperont de notre petit inconvénient .

Je souhaite juste que notre expérience soit utile à d autres.

qu'en penses tu ?

cordialement
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 529
3 549
68
Sous la limite KT
et bien je crois que la boucle est bouclée.

faut il prévenir apple ?

je ne pense pas qu'ils se préoccuperont de notre petit inconvénient .

Je souhaite juste que notre expérience soit utile à d autres.

qu'en penses tu ?

cordialement

Ben, je pense plutôt que le côté "marginal" du problème a très bien pu leur échapper, mais que si on parvient à faire remonter l'info à la bonne personne chez eux, ça les intéressera. Je vais voir si je peux trouver cette personne, et lui faire parvenir un lien vers ce fil !

En attendant, tu n'as plus qu'à éteindre ton disque lorsque tu éteins ton Mac ! :zen: