Plantage mail

Bozzo

Membre junior
4 Décembre 2002
62
2
Bonjour à tous.

Depuis une clean-install, j'ai quelques soucis avec Mail. Ma config : iBookG3 600Mhz, MacOs 10.4.10, Mail 2.1, je gère 2 comptes à laposte.net.
Certains messages d'amis ont été mis par Mail dans le dossier "Indésirables" (j'ai bien dit "par Mail" et pas par moi). Lorsque je tente de les rendre désirables, ou que je tente de les remettre dans le dossier de réception, Mail plante.

- J'ai réinitialiser la gestion du courrier indésirable.
- J'ai supprimé les préférences et sauvegardé le dossier Mail, j'ai reparamétrer Mail de zéro, puis j'ai remis SEULEMENT les 2 dossiers contenant UNIQUEMENT mes messages reçus et envoyé, sans AUCUN autre fichier style plist index, table ou autre.
- j'ai passé un coup de réparation d'autorisations
- j'ai passé un coup d'ONYX
- J'ai cherché un peu partout sur le net et ici
- j'ai essayé en ré-installant Mail en version 2.0

Rien à faire, le problème se reproduit...
Je n'ai pas de soucis si la gestion des spams est désactivée.

Une idée ?
Amicalement.
Bozzo
 

Bozzo

Membre junior
4 Décembre 2002
62
2
Bonjour à tous.

Encore une petite tentative pour faire remonter mon post et, je l'espère, trouver quelqu'un qui aurait une idée sur le problème que je décris plus haut.
Cela évoque une interférence entre les mails de laposte.fr et la gestion de spam de Mail.app.

Qu'en pensez-vous ?
 
D

Deleted member 18124

Invité
Bonjour à tous.

Encore une petite tentative pour faire remonter mon post et, je l'espère, trouver quelqu'un qui aurait une idée sur le problème que je décris plus haut.
Cela évoque une interférence entre les mails de laposte.fr et la gestion de spam de Mail.app.

Qu'en pensez-vous ?
Si c'est ça, désactive le filtrage des indésirables dans les préférences de Mail et filtre-les manuellement avec des règles.

Désolé, je n'ai rien de mieux à te proposer.
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
Bon je vois plusieurs causes possibles
*fichiers de gestion du courrier indésirable mal fagottés pour x raisons
** les messages eux mêmes ( certains messages sont plantogènes)
** mail ou OS

Un point m'intrigue

tu ne dis pas grand chose de ton utilisation "filtre indésirable" ( qui est le point central ici)

A priori il est en mode automatique
Lors d'une réinstall il faut le mettre en mode essai qu'il réapprenne tout

Et autre chose
Tu dis que ce sont des messages d'amis
Les adresses email de ces amis ont elles été placées dans ton carnet d'adresse?
As tu coché-décoché le critère de filtrage carnet d'adresse?

bref, globalement quels réglages de filtrage appliques tu?
 

Bozzo

Membre junior
4 Décembre 2002
62
2
Bon je vois plusieurs causes possibles
*fichiers de gestion du courrier indésirable mal fagottés pour x raisons
** les messages eux mêmes ( certains messages sont plantogènes)
** mail ou OS
- Sauf erreur de ma part, comme je le disais dans mon post initial, j'ai viré tous les fichiers de gestion de mail. Donc c'est pas ça.
- Un message plantogène ? Je l'envisage effectivement (cf plus bas)... faudrait que je fasse des tests en mettant et enlevant le ou les fichiers qui pourraient être en cause. Si j'ai le temps, je mettrait les résultats ici...
- Mail ou MacOS ? Peu probable vu que 1-C'est une clean install avec toutes les mises à jour faites d'emblée 2-En remplaçant mail 2.1 par la version initiale (2.0) ça ne change rien.

Un point m'intrigue
tu ne dis pas grand chose de ton utilisation "filtre indésirable" ( qui est le point central ici)
A priori il est en mode automatique
Lors d'une réinstall il faut le mettre en mode essai qu'il réapprenne tout
Je suis en mode automatique et il me semble que c'était le réglage par défaut. Et puis, sur plusieurs autres machines, je me suis mis d'emblée en mode auto, sans aucun problème ! D'autre part, je n'ai jamais lu qu'il faut commencer par le mode apprentissage... A mon avis, le seul risque du mode automatique d'emblée, c'est de trouver des messages désirables dans la boite indésirables. Suffit alors de les étiquetter "désirable" et de les remettre dans leur BAL d'origine.En tout cas, c'est ce que j'ai toujours fait sur plusieurs machines, sans aucun problème.


Et autre chose
Tu dis que ce sont des messages d'amis
Les adresses email de ces amis ont elles été placées dans ton carnet d'adresse?
As tu coché-décoché le critère de filtrage carnet d'adresse?
bref, globalement quels réglages de filtrage appliques tu?
Non, toutes les adresses de mes amis ne sont pas dans mon carnet d'adresse. Ceci peut effectivement expliquer que certains mails amis soient considérés comme indésirables, mais n'explique pas le plantage.
Les réglages de critères de filtrage sont d'origine.
En fait, il me semble que c'est surtout un message de laposte.net (genre Bienvenue à laposte.net...) qui est considéré comme indésirable, et fait planter mail lorsque je tente de le rendre désirable. Je vais creuser de ce coté là.

NB "rendre désirable", ça fait bizarre pour un mail, ;-), mais comment dire autrement ? "remettre désirable" c'est pas très terrible non plus... ;-)
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
et ce message de laposte il serait pas en format html par hasard?
( certains html sont très perturbateurs de Mail, de vrais fouteurs de zone dans certains cas)
 

Bozzo

Membre junior
4 Décembre 2002
62
2
et ce message de laposte il serait pas en format html par hasard?
( certains html sont très perturbateurs de Mail, de vrais fouteurs de zone dans certains cas)

Achhh zooooo... je vais regarder ça.
Sauf que je crois que ça s'est produit avec d'autres types de messages, mais je suis plus très sur...

En tous les cas, merci de ton aide !
 

Bozzo

Membre junior
4 Décembre 2002
62
2
Quelques nouvelles de mon problème :

Depuis que j'ai désactivé la fonction de filtrage des spam, mail fonctionnait normalement. Ce matin, je me suis dit que ce serait bien de remettre en marche cette fonction bien pratique. J'ai commencé par virer tous les mail de laposte.net, que je soupçonnais responsables de mes plantages.

Puis j'ai activé le filtrage des spams. Et là, surprise : un massage de MOI-MÊME se retrouve dans la boite "Courrier indésirable". Je tente de le remettre dans la boite d'origine et VLAN, mail plante comme avant !!!!

Je précise que l'adresse à partir de laquelle je m'envoyais un message à moi-même est enregistrée dans ma fiche personnelle, dans mon carnet d'adresses. Mail n'aurait donc logiquement pas du la traiter comme indésirable.

J'ai ensuite réinitialisé la fonction message indésirables et refait une tentative. Re-plantage de mail. Et maintenant, quand je lance mail, j'arrive sur la page d'accueil qui me demande de paramétrer mail, comme si je ne l'avais jamais utilisé !!!! Dur dur...
Bon, je devrais pouvoir réparer ce dernier problème en bidouillant, mais le problème de la gestion des spam restera entier !!!!

Si quelqu'un a une idée lumineuse, je suis hyper preneur !!!!!!

Amicalement à tous.
Bozzo
 

Bozzo

Membre junior
4 Décembre 2002
62
2
Pour Pascalformac : c'est du Pop.
Merci de t'intéresser à mon problème.

Je pense recommencer tout à la base, c'est à dire jeter tous les fichiers utilisés par mail, le re-paramétrer et ne ré-injecter dedans que les messages... Je crois avoir déja fait ça, sans succès, mais bon...

Mais avant, je voudrais essayer de vider le cache de mail... et je ne retrouve pas ou c'est rangé. MAil a bien un cache non ?

Bozzo
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
ben si tu fais des coups d'onyx tu as peut etre viré , parfois certains caches

sinon un peu de bon sens
A ton avis les caches de session ils sont où?

Ah ben mince dans le dossier..... Caches :D
(maison/biblio/caches)

et sinon il y a dans la doc Appleen ligne la procédure de nettoyage top avec reinstall propre des archives( de Mail) en anglais
j'avais le lien , je n'ai pas le temps de le retrouver maintenant
 

Bozzo

Membre junior
4 Décembre 2002
62
2
Ben justement, j'avais cherché le cache Mail à cet endroit, sans le trouver. C'était il y a une heure, lorsque Mail était planté et je suis formel : pas de cache Mail dans maison/biblio/caches !

Depuis, j'ai relancé Mail (tout simplement en supprimant le fichier de préférences et en le remplaçant par sa sauvegarde) et le cache est ré-apparu...
L'informatique, c'est plein de surprises...

En ce qui concerne mon problème de gestion des SPAMS, merci de ton info concernant la procédure de nettoyage avec réinstall propre. T'inquiètes pas pour le lien, je devrais trouver.

Je tiendrai ce post au courant de mes progrès... ou échecs...

Amicalement.
Bozzo