10.13 High Sierra Plus de compte admin après MaJ High Sierra

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Salut à tous,
petit problème :
je voulais tester HS sur un disque externe en Usb3. Après quelques péripéties, c'est fait.
Là, je voulais modifier 2 ou 3 trucs, mais à chaque fois mon couple identifiant/mot de passe est refusé.
Je viens enfin de voir que mes 2 comptes "admins" se sont transformés en comptes "standards"

Quelqu'un aurait une idée pour corriger ça ? :merci:
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
:coucou: Invité

Éteins le Système du volume externe > reviens dans ta session habituelle du volume interne du Mac.

Lance le «Terminal». Je vais supposer que le nom du volume externe du DDE recelant High Sierra est Brol (tu remplaceras mon Brol par le véritable nom du volume de ton DDE. S'il est en plusieurs mots, tu encadres le tout entre "" > par exemple si c'est : High Sierra Test --> tu écris le nom ainsi : "High Sierra Test" - c'est pour neutraliser les espaces libres dans le nom afin de ne pas casser la commande).

Passe la commande suivante :
Bloc de code:
sudo rm /Volumes/Brol/private/var/db/.AppleSetUpDone
(en remplaçant mon Brol par le nom du volume de ton DDE)

  • cette commande supprime un fichier de finalisation vide qui indique au Système du volume, au démarrage, qu'un premier compte admin est déjà créé et que l'écran d'ouverture de session peut être affiché. Son absence fait s'afficher les panneaux de configuration du Mac comme après la fin d'un clean install.

Démarre sur le volume de ton DDE > à la fin du chargement de l'OS tu vas toucher une série de panneaux de configuration > remplis les panneaux (Français etc. > inutile de te connecter) > crée un compte admin tel que --> Nom court = toto > nom long = toto > mot-de-passe = toto.

Tu ouvres la session admin toto > Préférences Système > Utilisateurs et groupes > tu déverrouilles le panneau avec le mot-de-passe toto > tu sélectionnes tes utilisateurs en cochant chaque fois la case : Autoriser l'administration du Mac.

NB. Une préférence d'ouverture de session automatique a dû s'incrire au profit de toto --> menu Options : tu la vires en restaurant la préférence : Afficher par liste d'utilsateurs.
 
Dernière édition:
  • J’aime
Réactions: Invité

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Mais oui, je ne voyais pas par où prendre le problème !

Mais à priori ça ne fonctionne pas. Le Système se lance bien, mais pas la session. Il ne reste qu'un écran gris indéfiniment. C'est peut être aussi mon vieux disque qui fatigue…
J'ai restesté le "rm", mais c'est bon, il n'a pas trouvé le fichier.

Je tente une ré-instal avec le "recovery" et je donnerai des nouvelles.

Merci pour ton intervention :merci:
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Bon, après une ré-instal via le "Recovery" la situation reste inchangée.
La pomme blanche avec la barre de chargement, et… un écran gris.
J'ai laissé toute la nuit pour le chargement, peine perdue le Mac s'est mis en veille.

La procédure ne fonctionne peut être pas sur High Sierra ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
J'avais effectué la suppression du fichier .AppleSetupDone dans mon clone de High Sierra (clone dépendant d'un Container APFS) --> en redémarrant sur mon clone --> j'ai eu le chargement de l'OS > l'écran gris dont tu parles un court moment > puis le 1er panneau de configuration : le Pays ... j'ai configuré un compe toto > ouvert sa session et je pouvais manœuvrer à ma guise.

Donc situation inchangée pour moi (en ce qui concerne cette manœuvre) par rapport aux OS antérieurs. Mon clone est sur SSD : est-ce que ça peut changer la donne ?

Quel est le nom exact du volume du DDE (où tu as ton High Sierra expérimental) que je te passe une commande de recréation d'un fichier de finalisation d'installation (ce fichier est vide par défaut --> il n'agit que par le seul fait d'exister) ?
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Je n'avais pas mis à jour le nom du disque, donc c'est "MacOs10-12"

Ah oui, c'est vrai qu'il suffit que le fichier existe pour que tout soit comme avant.

Je pense aussi que mon disque dur 3.5" dans son dock Usb3 est assez fatigué. Le démarrage long (presque 2mn) fonctionne quand même. Mais, si les applis s'ouvrent tout à fait correctement, j'ai des blocages (la roue arc en ciel) qui durent lors d'accès au disque.

L'autre disque dur de mes expérimentations conduit à un KP maintenant !

Je vais peut être cloner le disque d'expérimentation, une fois le fichier AppleSetupDone remis en place, sur un disque FW qui est redondant d'une sauvegarde Cloud.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
Tu n'as qu'à passer la commande :
Bloc de code:
sudo touch /Volumes/"MacOs10-12"/private/var/db/.AppleSetupDone
  • et un fichier de finalisation d'installation .AppleSetupDone est de nouveau à sa place dans le volume de ton DDE.

=> tu n'as plus qu'à tester un re-démarrage dessus.
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Bon, ça a foiré aussi.
A l'ouverture de session mon user normal n'était pas reconnu, ou son mot de passe. Pas moyen de savoir, toutes les lettres sont remplacées par des carrés.
L'user secondaire se charge et reste bloqué.

J'ai effacé le disque FW et je tente une clean instal, je ferais une migration après si ça marche.

Merci pour tes coups de main MacO :coucou:
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
Merci pour tes coups de main MacO
Ouaip ! sur ce coup-là, ce n'était pas brillant. Genre : balancer le manche du parapluie dans les rayons de roue de la bécane dont la chaîne a sauté -


Disons que ça aura servi à montrer que le fonctionnement du volume était déjà foireux - en radicalisant ce dysfonctionne-ment.

Je pense que tu as pris la bonne décision : reprendre tout à la base. Un certain nombre de fils sur les forums paraissent attester des loupés dès la mise en place de l'installation de High Sierra. En pareil cas > il vaut mieux ne pas insister pour rattraper l'irrattrapable > mais effacer l'ardoise et recommencer.
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Yep !
Je tiendrais le monde (et ses environs) au courant de ces évolutions :D

Mais malgré tout, merci renouvelés pour tes interventions :merci:
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Alors, après une clean instal sur un autre disque.
Tout fonctionne bien.
Je ré-importe les données de mon compte. Re-démarrage, puis re-démarrage.
Ecran noir !

Clairement mon "user" qui date d'Os9 (en MaJ) n'est plus d'actualité sur High Sierra :shifty:

C'est la première fois que je vais être obligé de faire une "clean instal". Avec la myriade de logiciels que j'ai accumoncelé je me demande combien de temps ça va me prendre.

Bah, pas prêt de passer sur HS en vrai, ça va me laisser du temps pour tester en live ce qui fonctionne encore et ne fonctionne plus…

:merci:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 895
3 143
Alors, après une clean instal sur un autre disque.
Tout fonctionne bien.
Je ré-importe les données de mon compte. Re-démarrage, puis re-démarrage.
Ecran noir !

Clairement mon "user" qui date d'Os9 (en MaJ) n'est plus d'actualité sur High Sierra :shifty:

C'est la première fois que je vais être obligé de faire une "clean instal". Avec la myriade de logiciels que j'ai accumoncelé je me demande combien de temps ça va me prendre.

Bah, pas prêt de passer sur HS en vrai, ça va me laisser du temps pour tester en live ce qui fonctionne encore et ne fonctionne plus…

:merci:
(tournure lyonnaise, non ?)
Quand tu écris 0S9, tu parles de Mac OS 9 ou de macOS X.9 ? Pour celui-ci, c'est effectivement dommage, pour celui-là, on peut considérer que la comptabilité ascendante a été assez bonne...
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
(tournure lyonnaise, non ?)
Quand tu écris 0S9, tu parles de Mac OS 9 ou de macOS X.9 ? Pour celui-ci, c'est effectivement dommage, pour celui-là, on peut considérer que la comptabilité ascendante a été assez bonne...
Je parle bien d'Os9 anté Mac OsX ;)

Pour accumoncelé c'est un mot valise que j'aime bien, d'un de mes ex beau frère…
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 637
21 495
Forêt de Fontainebleau
:coucou: Invité

Autant dire alors : Mac OS 9 (comme on disait à l'époque) > et si tu veux moderniser la scription : macOS 9.

À la fin de ton installation propre > je suppose que tu lances l'«Assistant de migration». Lequel doit te proposer une récupération de données multiples : compte d'utilisateur > applications tierces > réglages du Mac.

Si tu refais un essai à partir de la clean install > en t'arrangeant pour créer un compte admin bidon d'abord (nom = toto > mot-de-passe = toto) > puis dans le panneau de l'«Assistant de migration» en ne cochant comme données à récupérer que ton dossier de compte d'utilisateur --> cette recréation d'utilisateur ayant compte n'écrasera pas le compte toto (qui pourra te servir à ouvrir une session au cas où...).

=> est-ce que tu peux ouvrir ta session récupérée ou non ? - si oui > le problème est dans les autres données (applications tierces > réglages du Mac). Parce que > quand tu ouvres ta session récupérée avec le reste des autres données > il y aurait lancement de processus bloquants pour le processus launchd (par exemple) ou pour le Finder ou que sais-je ? - mais si tu t'abstiens de récupérer précisément ces ressources d'applications tierces > les processus afférants ne pourront pas être lancés à l'ouverture de ta session (disons qu'un certain nombre d'instructions avorteront). Un rapport «EtreCheck» alors apporterait peut-être des lumières.
 

Invité

Pommé
Club MacG
19 Février 2005
7 975
436
21000
Bah, après une remise à plat avec DiskWarrior ET un démarrage en Single User (au fait merci pour la touche F2 avec rEFInd, je ne connaissais rien à ces options :merci:) je peux redémarrer sur mon user créé, et même ensuite passer sur mon user habituel hérité de MacOS 9.

C'est quand même bizarre que ce soit le 3ème disque dur externe qui foire avec High Sierra et cet user historique.

Rien que l'idée de faire une "clean instal" pour passer à HS, me fatigue… :D
Ce qui m'intéressais le plus c'était les applications et toutes les licences liées. Je sais que de nombreux programmes ont installé des fichiers lors du boot. Je n'ai pas de rapport EtreCheck sous la main, mais j'ai déjà remarqué la chose.

Merci pour cette analyse qui m'impose du travail si je veux faire un grand saut dans le Système ! :shifty:
:D :merci: