Powerbook G4 12" Kernel Panic à répétition

badvallu

Membre actif
1 Mars 2005
103
4
39
Flack
Depuis quelques jours j'ai sous la main un Powerbook G4 12" 867Mhz, 1.12Go de Ram et 160Gb de DD qui fait des Kernel Panic à répétition au démarrage ou même d'un coup sans réelle explication.
Quand je l'ai eu il chauffait assez, et le ventilo se mettait tout le temps en route, et boum Kernel Panic, j'ai fait un reset de la Pram et de la Nvram, ça a fait descendre la température du CPU qui était à 47°C-53°C à 40°C-47°C. Et je me suis dis que c'était dû à la chaleur et que le problème était résolu, mais ce matin Kernel Panic à répétition au démarrage sauf les extensions désactivés.
J'ai fait booter l'ordinateur sur le Cd AHT fournit avec l'appareil, et RAS tout va bien, la même chose avec le Cd de TechtoolPro 5, RAS tout va bien. :mouais:
Je ne sais pas trop quoi faire en sachant que l'installation de Tiger est toute fraîche de 2 jours, que rien de spécial est installé et que mis à part ce soucis cet ordinateur est super.
Pour information je mets le dernier Panic.log si quelqu'un y comprend quelque chose:

Kernel version:
Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC
panic(cpu 0 caller 0xFFFF0003): 0x300 - Data access
Latest stack backtrace for cpu 0:
Backtrace:
0x000954F8 0x00095A10 0x00026898 0x000A8204 0x000ABB80
Proceeding back via exception chain:
Exception state (sv=0x30764280)
PC=0x002FB3F4; MSR=0x00009030; DAR=0xB7019084; DSISR=0x40000000; LR=0x002FB328; R1=0x1A26BB60; XCP=0x0000000C (0x300 - Data access)
Backtrace:
0x002FB314 0x002F9FE0 0x00300880 0x003009AC 0x003009AC 0x002EB0AC
0x0008AF40 0x00029234 0x000233F8 0x000ABEAC 0x0237ECE0
Exception state (sv=0x3063CA00)
PC=0x9000AF48; MSR=0x0200F030; DAR=0x02805424; DSISR=0x0A000000; LR=0x9000AE9C; R1=0xBFFF6610; XCP=0x00000030 (0xC00 - System call)

Au secouuuuuuuuuuuuuuuuuuuuuuurs! :(
 

SadChief

Membre actif
22 Novembre 2004
379
9
Montpellier
Enlève la barrette mémoire ajoutée (1 Go) et ne laisse que la mémoire d'origine (soudée).
Je crois que la machine a été livrée avec Panther (qui tournait avec 128 Mo RAM).
Donc il faudra que tu ré-installes Panther (10.3) si c'est bien ça.
Sinon vois si quelqu'un peut te prêter une barrette 1 Go pour essayer.
 

badvallu

Membre actif
1 Mars 2005
103
4
39
Flack
En fait j'ai déjà essayé ça mais sous Tiger, le résultat a été Kernel Panic au démarrage. La machine était livré avec 10.2.3, Jaguar donc, j'aurais bien voulu m'éviter de réinstaller cet antiquité. Panther passe encore, mais Jaguar n'était pas trop stable je trouve.
Si cela se reproduit, je vais essayer de trouver Panther (mais bof) sinon une install de Ubuntu (et encore sur Powerpc c'est pas le pied niveau support du matériel) pour voir si cela fait la même chose. Et voir comme tu dis pour une barrette de Ram mais si je ne pense pas que cela soit le problème, mais bon on ne sait jamais, des fois cela ne s'explique pas.
 

SadChief

Membre actif
22 Novembre 2004
379
9
Montpellier
... Et voir comme tu dis pour une barrette de Ram mais si je ne pense pas que cela soit le problème, mais bon on ne sait jamais, des fois cela ne s'explique pas.
Dans la plupart des situations comme celle-là, le problème venait justement d'une barrette de RAM défectueuse.
Comme tu dis, essaye, tu nous diras si c'était bien ça.
 

-oldmac-

Membre expert
Club MacG
22 Juillet 2007
1 608
68
28
Rennes
sauf si la ram défectueuse est celle qui est soudée sur la carte mère :rateau:
 

badvallu

Membre actif
1 Mars 2005
103
4
39
Flack
Finalement, j'ai trouvé le coupable, après plusieurs Tests sous Tiger et Sous Panther (avec toutes les mises à jour effectuées), c'est la carte airport extreme qui provoque ça. J'ai fait un test avec celle reçu avec le powerbook, Kernel Panic et un autre test avec une carte airport d'un ibook G4 14" décédé, Kernel Panic. J'essaierai encore avec la carte airport d'un ibook familial qui fonctionne correctement dès que je pourrais mais j'ai peur que ce soit le même résultat. :mouais:
 

christophe2312

Membre actif
30 Décembre 2005
946
15
54
Massy
Si il chauffe , la poussière dans les ventillos? donc mauvais refroidissement
Simplement si il n a jamais été démonter
 

badvallu

Membre actif
1 Mars 2005
103
4
39
Flack
Si, il a déjà été démonté, nettoyé. Pas de poussière dans le ventilo. Le coupable est bien la carte airport ou tout du moins le connecteur de la carte.