Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Problème avec Gimp

Discussion dans 'Unix, Linux et open source' créé par Ascriptel, 9 Juillet 2003.

Modérateurs: bompi, daffyb
  1. Ascriptel

    Ascriptel Nouveau membre

    Inscrit:
    20 Juin 2003
    Messages:
    17
    J'aime reçus:
    0
    J'ai installé Gimp en suivant l'article d'Univers Macworld, ai eu des problèmes avec la commande à taper, mais j'ai finalement réussi à arriver aux écrans Gimp User Installation.
    Le problème est maintenant que après m'avoir dit qu'il fallait créer un répertoire Gimp dans mon home directory, Gimp m'affiche:
    /opt/local/share/gimp/1.2/user_install does not exist. Cannot install
    Quelqu'un a-t-il une idée?
     
  2. Thierry6

    Thierry6 Membre émérite

    Inscrit:
    29 Avril 2003
    Messages:
    850
    J'aime reçus:
    24
    je ne connais pas l'article ni le répertoire /opt (sur Sun Solaris oui, pas sur OSX) mais le mieux pour installer Gimp est de passer par fink qui se chargera de tout installer avec les bonnes librairies.
    ensuite, tu n'auras qu'à rentrer /sw/bin/gimp dans le menu Customize de X11 et ça marche.

    http://fink.sourceforge.net/
    http://finkcommander.sourceforge.net/
     
  3. Ascriptel

    Ascriptel Nouveau membre

    Inscrit:
    20 Juin 2003
    Messages:
    17
    J'aime reçus:
    0
    Bon j'ai viré le dossier opt et j'ai essayé d'installer Gimp avec Fink. Le problème est que maintenant Fink me dit qu'il a besoin de packages (ex: giflib-bin: Depends: x11) alors que X11 je l'ai déjà (version d'Apple).
    De plus, quand je tente de réinstaller le x11 que Fink propose, déjà il n'autorise plus l'installation en package binaire, et quand je lance l'installation à partir du source il me dit: Failed: no version info available for x11
    Est-ce moi qui m'y prend mal?
     
  4. Thierry6

    Thierry6 Membre émérite

    Inscrit:
    29 Avril 2003
    Messages:
    850
    J'aime reçus:
    24
    puisque tu as installé X11 (tu dois aussi installer le X11 SDK qui se trouve sur la download page de X11), le premier package à installer par Fink est
    system-xfree86
    qui t'évite de tout réinstaller en disant à Fink que tu l'as fait par tes propres moyens.

    au cas où, n'oublie pas que tu as besoin d'avoir installé les developper tools et après l'installation de Fink, tu dois rentrer source /sw/bin/init.sh dans ton fichier .tcshrc
     
  5. Ascriptel

    Ascriptel Nouveau membre

    Inscrit:
    20 Juin 2003
    Messages:
    17
    J'aime reçus:
    0
    Merci mon Dieu!!! Gimp marche enfin!
    Par contre j'ai cru comprendre qu'il fallait installer des librairies supplémentaires pour qu'il puisse gérer les .jpgs... Ce serait lesquelles?
    Dernière question: imaginons qu'avec Fink j'installe par exemple un jeu de baxkgammon. Comment je fais pour touver la ligne de commande à mettre dans le menu Customize... ?
     
  6. Thierry6

    Thierry6 Membre émérite

    Inscrit:
    29 Avril 2003
    Messages:
    850
    J'aime reçus:
    24
    mon dieu, c'est un peu trop... [​IMG]

    Si tu utilises finkCommander (GUI pour Fink), regarde si libjpeg, libtiff sont installées avec Gimp (je pense que oui mais ne me souviens plus)
    si non, installe les toi même avec Fink.

    Toute application installée par Fink se retrouve dans /sw/bin, le fait d'avoir "sourcé" /sw/bin/init/sh met /sw/bin dans ton path, donc tu devrais simplement pouvoir lancer
    ./baxkgammon

    ou mettre baxkgammon dans le menu customize de X11

    si il y a un problème, avec xterm, tape
    cd /sw/bin
    ./baxkgammon
     
Modérateurs: bompi, daffyb
Chargement...