macOS Big Sur problème avec le terminal qui reste ouvert

cmt

Membre actif
9 Mai 2011
131
2
75
Bonjour
J'ai un pb avec le Terminal qui reste ouvert sur le MacBook Pro de mon épouse sous Big Sur, version 11.2.1. À chaque démarrage de son portable, le Terminal se lance en affichant un message incompréhensible pour moi. J'ai cherché dans les bibliothèques launchagents et launchdaemons, mais rien qui concerne le Terminal. J'ai également cherché dans groupes et utilisateurs les lancements par défaut, idem, rien.

Ne connaissant rien dans les commandes du Terminal, je joins une copie d'écran du Terminal quand il est ouvert :

1613040415816.png
Merci pour votre aide
André
 
Dernière édition par un modérateur:

izel mor

penn ar bed
Club MacG
4 Juin 2020
1 183
135
35
Bonjour,
C'est surprenant qu'il s'ouvre à l'insu de ton plein gré.
Sinon c'est une alerte pour signifier que depuis Catalina, l'interpréteur de ligne de commande a changé et que tu peux faire la modification.
 

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 212
1 039
Toulouse.cong
faq.office.macintosh.free.fr
Oui, mais en dehors de ça il indique une opération de sauvegarde au moment de la fermeture de session. Et je pense que c'est ça qui fait l'objet de l'affichage, le message ZSH s'affichant systématiquement au lancement du Terminal tant qu'on n'a pas fait la bascule.

Et ce message ressemble plutôt à un log, mais je ne sais pas pourquoi il s'affiche. Est-ce qu'il y aurait sur cette machine un (in)utilitaire qui pourrait expliquer ça ? Genre Antivirus ou autre...
 

cmt

Membre actif
9 Mai 2011
131
2
75
Bonjour, merci pour cette réponse
Concrètement comment définir ce Zsh et comment enfin éviter le lancement automatique du Terminal ?

Il y bien sûr un antivirus mais cela n'est pas nouveau (ESET) et il y a eu une sauvegarde faite depuis pas mal de temps avec Carbon Copy Cloner
 
Dernière édition par un modérateur:

maxou56

Membre expert
Club MacG
14 Avril 2020
2 686
558
Lorient
Concrètement comment définir ce Zsh et comment enfin éviter le lancement automatique du Terminal ?
Non il n'y a aucun lien entre les 2.
Tu peut rester en bash.

Sinon pour modifier,
Préférences système > Utilisateurs et groupes > Clique droit sur l'utilisateur > options avancées > /bin/zsh
 

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 212
1 039
Toulouse.cong
faq.office.macintosh.free.fr
Pour définir ZSH par défaut, il suffit de suivre le lien indiqué (et qu'a rappelé izel mor plus haut), tout est précisé avec même des images. Pour ce qui est du lancement du Terminal, c'est moins évident.

Concernant l'antivirus "bien sûr", tu devrais essayer de le désactiver, pour t'assurer qu'il n'est pas en cause (ce ne serait pas le premier antivirus qui crée plus de problème qu'il n'est censé en éviter...)
 
  • J’aime
Réactions: peyret

cmt

Membre actif
9 Mai 2011
131
2
75
désolé mais je suis nul et je ne comprends pas la réponse
je voudrais juste savoir comment empêcher le terminal de se lancer automatiquement a chaque démarrage de la machine
merci
 

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 212
1 039
Toulouse.cong
faq.office.macintosh.free.fr
comment empêcher le terminal de se lancer automatiquement à chaque démarrage de la machine
Mais ce n'est pas à proprement parler au démarrage qu'il se lance, c'est plutôt à l'extinction. Et c'est là qu'il faudrait savoir pourquoi. Ensuite, qu'il se relance automatiquement à l'ouverture, c'est quasiment secondaire, à mon avis...
 
  • J’aime
Réactions: izel mor

izel mor

penn ar bed
Club MacG
4 Juin 2020
1 183
135
35
Et est ce que c'est possible que le terminal se retrouve dans Préférences utilisateurs ☞ouverture ?
On peut le rajouter donc il pourrait y être. A vérifier dans Utilisateurs et groupes
La sauvegarde qui s'effectue est identique à celle qui se lance en quittant le terminal par exit. Mais qui tape...exit
 

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 212
1 039
Toulouse.cong
faq.office.macintosh.free.fr
Je regarderais plutôt dans le panneau de préférences système "Général" pour vérifier que la case "Fermer les fenêtres..." est cochée :

Capture d’écran 2021-02-11 aϰ 14.39.07.png

Ça pourrait éviter qu'elle se (re)lance automatiquement, peut-être...
 

cmt

Membre actif
9 Mai 2011
131
2
75
enfin j'ai réussi à me débarrasser de ce pb grâce à vos conseils
j'ai désinstalle et réinstallé 2 fois l'antivirus et cela semble avoir régler le pb
merci