• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Probleme avec Safari 12 sous Mojave

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
Salut,

Depuis que j'ai installé Mojave et mis à jour Safari dans sa version 12, je rencontre des soucis pour accéder à 2 sites (Leboncoin et Priceminister)

Lorsque j'arrive sur le site, la page d'accueil se charge mais il est impossible d'y naviguer (j'ai la petite roue colorée qui tourne indéfiniment)

Je précise que je n'ai installé aucun plugin, aucune extension, aucun bloqueur de quoi de que ce soit, j'utilise safari brut tel qu'il est fourni par apple.

Ce sont les 2 seuls sites sur lesquels ça me fait ça.
J'ai testé sous firefox, ça fonctionne parfaitement, ça vient donc forcement de Safari 12 sur imac (car sous iPad ios12, aucun problème non plus sous safari)

J'ai testé de vider les caches via le menu développement mais ça n'a rien changé.

Avez vous le même soucis ou des solutions à me proposer (nettoyage radical, désinstallation de safari ou autre) ?

Merci d'avance.
 
Dernière édition:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
30 393
3 138
Avez vous le même soucis ou des solutions à me proposer (nettoyage radical, désinstallation de safari ou autre) ?
Ça c'est impossible, mais tu peux le réinitialiser, comme Safari doit-être fermé, tu aurais intérêt à enregistrer ces lignes de commande dans un fichier TextEdit, à les exécuter une par une depuis le Terminal en faisant un Copier/Coller et en validant à chaque fois avec la touche Entrée, puis tu redémarres et vois ce qu'il se passe maintenant en allant sur tes sites.
Bloc de code:
cp ~/Library/Safari/bookmarks.plist ~/Desktop
Bloc de code:
rm -rf ~/Library/Safari/*
Bloc de code:
rm -rf ~/Library/Caches/com.apple.Safari/*
Bloc de code:
rm -rf ~/Library/Saved\ Application\ State/com.apple.Safari.savedState/*
Bloc de code:
cp ~/Desktop/bookmarks.plist ~/Library/Safari
Edit : ah oui, sauvegarde au préalable tes signets dans un endroit sûr en allant dans Safari/Fichier/Exporter les signets et si tout va bien, tu les réimportes.
 

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
Ça c'est impossible, mais tu peux le réinitialiser, comme Safari doit-être fermé, tu aurais intérêt à enregistrer ces lignes de commande dans un fichier TextEdit, à les exécuter une par une depuis le Terminal en faisant un Copier/Coller et en validant à chaque fois avec la touche Entrée, puis tu redémarres et vois ce qu'il se passe maintenant en allant sur tes sites.
Bloc de code:
cp ~/Library/Safari/bookmarks.plist ~/Desktop
Bloc de code:
rm -rf ~/Library/Safari/*
Bloc de code:
rm -rf ~/Library/Caches/com.apple.Safari/*
Bloc de code:
rm -rf ~/Library/Saved\ Application\ State/com.apple.Safari.savedState/*
Bloc de code:
cp ~/Desktop/bookmarks.plist ~/Library/Safari
Edit : ah oui, sauvegarde au préalable tes signets dans un endroit sûr en allant dans Safari/Fichier/Exporter les signets et si tout va bien, tu les réimportes.
Merci, je vais tester tout ça.

Pour Moonwalker, je le sais très bien pour Rakuten.
Pour ce qui est de la version 12 de safari, je parlais de mise à jour car j'avais en effet eu la mise a jour version 12 qui m'avait été proposé dans l'app store avant de mettre mon iMac à jour avec Mojave.
 

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
Me revoilà, j'ai fait toute la manip de A à Z, le problème persiste.
Tant pis, je vais migrer sur firefox.

Merci quand meme
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
Il n'y aurait pas un Adblock quelconque d'installé sur ce Mac?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 193
3 875
Nancy___
N'hésite pas non plus à tester dans une nouvelle session, juste créée pour ce test.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
30 393
3 138

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
Sous la seconde session: idem
Sous la nouvelle session créée pour le test : idem

On dirait que quelque chose bloque ca page, elle n'a pas une apparence normale (surtout au dessus et autour, tout est tout gris, tout vide)

Capture d’écran 2018-10-12 à 13.27.12.png
 

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
Je viens de faire un test en supprimant les cookies pour un des sites.
Au lancement, tout fonctionne bien, je me reconnecte, je clique sur 2 ou 3 liens, et hop, nouveau blocage empêchant la navigation.
Par contre, la molette de la souris fonctionne et je peux me balader de haut en bas du site mais je ne peux cliquer nulle part sinon la roue colorée apparaît.

J'aurais dû rester sous High Sierra :/`

PS : Sly54, vu que tu es de Nancy, tu ne veux pas venir voir le problème en direct ? :)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
34 193
3 875
Nancy___
Sous la seconde session: idem
Sous la nouvelle session créée pour le test : idem
Très très bizarre…
Le fait que le problème soit présent dans toutes les sessions montre que le problème est global et pourrait être réglé par une nouvelle application de l'OS

mais
Je viens de faire un test en supprimant les cookies pour un des sites.
Au lancement, tout fonctionne bien, je me reconnecte, je clique sur 2 ou 3 liens, et hop, nouveau blocage empêchant la navigation.
le fait que supprimer les cookies permette de régler temporairement le problème montre que le souci est localisé dans une session…

Très bizarre…


PS : Sly54, vu que tu es de Nancy, tu ne veux pas venir voir le problème en direct ? :)
Je ne fais pas encore de dépannage en direct ;)
 

mokuchley

Membre d’élite
Club MacG
27 Août 2010
3 418
153
regarder dans preferences système => reseau => avancés => proxy...est ce que proxy web est selectionné ? si oui, deselectionné le
en faites, il y a 2 a 3 jours j'ai vu, sur le forum, quelque reglant le problème grace au proxy.....le pire c'est que, je ne sais même pas comment se servir des proxy !!!
 

HuriKhan

Nouveau membre
12 Octobre 2018
12
0
48
Nancy
regarder dans preferences système => reseau => avancés => proxy...est ce que proxy web est selectionné ? si oui, deselectionné le
en faites, il y a 2 a 3 jours j'ai vu, sur le forum, quelque reglant le problème grace au proxy.....le pire c'est que, je ne sais même pas comment se servir des proxy !!!
Non, rien n'est sélectionné dans cette fenêtre.
Mais je pense que si y'fait un truc la dedans ca serait tous les sites qui poseraient problème, pas juste les 2 pré-cités.
 

Spec

Membre confirmé
24 Août 2008
204
12
Alors moi j'ai le même pour certain sites et c'est assez pénible... mais moi je suis sous H Sierra !!

Pour moi vente Privé/Auto plus...
 
Dernière édition:

Dan74

Membre confirmé
13 Octobre 2018
142
2
69
Annecy
Bonjour, je viens de découvrir ce topic en faisant une recherche et je prend part à la discussion car j'ai le même phénomène qui s'est produit sur mon iMac Sous High Sierra et cela depuis 15 jours. J'ai tout essayé (les caches, cookies) ouvert une nouvelle session et c'est pareil, la roulette multicolore qui tourne sur le suite leboncoin en particulier.
J'ai regardé sur mon MBP sous El Capitan et tout est OK .
J'ai donc appelé l'assistance Apple et après plusieurs manipulations dans la bibliothèque , rien n'y fait; hier j'ai donc j'ai réinstallé High Sierra après avoir redémarré sur CMD+R.
Et la tout est rentré dans l'ordre, plus de roue multicolore. Mais ce matin l'App Store m'indique une MàJ de Safari 12, sans me poser de question je la lance c'est rapide, sauf que des que je suis retourné sur le site leboncoin, rebelote, la roue multicolore ....alors serais-ce une piste ? c'est donc bien Safari 12 ? j'en ai fait part à Apple.
C'est décourageant et ne sais plus quoi faire a part passer par Firefox ou Chrome. ce qui me rassure un peu, c'est que je ne suis pas le seul, a suivre donc, merci.
 

papamadi

Nouveau membre
3 Février 2018
18
1
47
il apparait que chez certains utilisateurs Safari 12 soit devenu une pompe a vélo
en attendant mieux mieux vaut utiliser un navigateur alternatif
 
Dernière édition: