Problème : coins actifs & raccourcis trackpad ne fonctionnent plus

keloblock

Nouveau membre
4 Mars 2015
9
0
Bonsoir,

Depuis 1 mois à peu près mes coins actifs ainsi que certains raccourcis du trackpad (afficher le bureau / afficher les fenêtres de la même application) ne fonctionnent plus sur ma session. Je les ai déjà activé/désactivé dans les préférences système à plusieurs reprises mais en vain. J'ai également essayé sur une autre session (créée pour l'occasion) et là, ça fonctionne.

Merci de bien vouloir m'éclairer et m'orienter afin de résoudre ce problème qui me complique vraiment la tâche sans avoir à passer par un reboot du système si possible.

Bonne fin de journée !

ps : je possède un Macbook Pro (13 pouces, début 2011) - Yosémite 10.10.2 doté d'un SSD Samsung 250 go

Thibault
 
A

Anonyme

Invité
Bonsoir et bienvenue,

si ça fonctionne bien dans un autre session, des fichiers de préférences sont en cause.

Ils sont dans la Bibliothèque de l'utilisateur :
Finder, barre de menu, menu "Aller", appuyer sur la touche Alt pour faire apparaitre dans la liste la Bibliothèque de l'utilisateur, qui par défaut, est cachée.

Il y a trois fichiers possiblement en cause :

~/Bibliothèque/Préférences/com.apple.dashboard.plist
~/Bibliothèque/Préférences/com.apple.dock.plist
~/Bibliothèque/Préférences/Application Support/Dock/desktoppicture.db

Pour vérifier que c'est bien le cas, je te suggère de commencer par :
- mettre à la corbeille le 1 et le 3 (pour ne pas perdre la config du Dock). Ne PAS vider la corbeille.
- redémarrer
- tester

Si pas réglé, supprime le 2, redémarre et teste.
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
donc c'est dans ta bibliotheque (de session) que les reglages sont fautifs
ce fichier
com.apple.dock.plist

soit tu le vires et tu redemarres
soit tu passes par le Terminal

edit
grilled
note sur des fils apple c'est la plist dock qui semble gerer les coins
(hot corner en langue Apple)
 

keloblock

Nouveau membre
4 Mars 2015
9
0
@Rebad
Bonsoir et bienvenue,

si ça fonctionne bien dans un autre session, des fichiers de préférences sont en cause.

Ils sont dans la Bibliothèque de l'utilisateur :
Finder, barre de menu, menu "Aller", appuyer sur la touche Alt pour faire apparaitre dans la liste la Bibliothèque de l'utilisateur, qui par défaut, est cachée.

Il y a trois fichiers possiblement en cause :

~/Bibliothèque/Préférences/com.apple.dashboard.plist
~/Bibliothèque/Préférences/com.apple.dock.plist
~/Bibliothèque/Préférences/Application Support/Dock/desktoppicture.db

Pour vérifier que c'est bien le cas, je te suggère de commencer par :
- mettre à la corbeille le 1 et le 3 (pour ne pas perdre la config du Dock). Ne PAS vider la corbeille.
- redémarrer
- tester

Si pas réglé, supprime le 2, redémarre et teste.
Les fichiers :
~/Bibliothèque/Préférences/com.apple.dashboard.plist
~/Bibliothèque/Préférences/Application Support/Dock/desktoppicture.db
N'existent pas dans ma bibliothèque, j'ai supprimé le dernier fichier (qui lui était présent : ~/Bibliothèque/Préférences/com.apple.dashboard.plist) mais ça n'a rien changé.
J'ai, alors, supprimé le fichier restant (~/Bibliothèque/Préférences/com.apple.dock.plist) puis redémarré mais ça na rien changé à mon problème.

Merci pour votre réponse, je continue à rester à votre écoute.
 

keloblock

Nouveau membre
4 Mars 2015
9
0
donc c'est dans ta bibliotheque (de session) que les reglages sont fautifs
ce fichier
com.apple.dock.plist

soit tu le vires et tu redemarres
soit tu passes par le Terminal

edit
grilled
note sur des fils apple c'est la plist dock qui semble gerer les coins
(hot corner en langue Apple)
IDEM réponse précédente, cela ne fonctionne pas. Merci pour votre aide, je reste à votre écoute.
 
A

Anonyme

Invité
J'ai fait une erreur de chemin pour un fichier :

~/Bibliothèque/Application Support/Dock/desktoppicture.db (sans "Préférences" dedans)

Il existe forcément car il gère entre autres les fonds d'écran.

Tu devrais aussi avoir :

~/Bibliothèque/Préférences/com.apple.dashboard.plist

Attention on parle bien de la Bibliothèque de l'utilisateur :

Finder, barre de menu, menu "Aller", appuyer sur la touche Alt pour faire apparaitre dans la liste la Bibliothèque de l'utilisateur, qui par défaut, est cachée.

Si tu as supprimé : Macintosh HD/Bibliothèque/Preferences/com.apple.dock.plist, ce n'était pas le fichier à supprimer.

Il faut supprimer : ~/Bibliothèque/Préférences/com.apple.dock.plist, qui est dans la Biblio de l'utilisateur, pas celle de Macintosh HD.
 
Dernière édition par un modérateur:

keloblock

Nouveau membre
4 Mars 2015
9
0
Je n'avais pas pris en compte le ALT, je me suis égaré dans les fichiers de bibliothèque. J'ai donc supprimé les fichiers et du coup tout fonctionne correctement à présent.

Merci pour votre aide :)

Bonne soirée