MacBook Pro Problème de boot après remplacement du clavier (MBP 13'' mid-2010)

ilya1050

Membre confirmé
11 Mai 2020
20
12
31
Bonjour à tous,

J'ai décidé d'upgrader mon vieux Macbook pro en installant un SSD ainsi qu'en changeant la RAM. J'ai voulu également en profiter pour remplacer la batterie qui était en mauvais état ainsi que le clavier. Il s'agit d'un Macbook Pro 13'' mi-2010, sur lequel est installé El Capitan. Il fonctionnait "correctement" (bien mais lentement) avant l'intervention, et ce depuis une petite dizaine d'années.

J'ai donc commencé par m'occuper du clavier. J'ai précautionneusement retiré tous les composants nécessaires, j'ai retiré le vieux clavier que j'ai remplacé par le nouveau, et j'ai tout remonté. À ce stade c'est la seule modification que j'ai effectué.

Lorsque j'ai voulu vérifier que le nouveau clavier était opérationnel, l'ordinateur m'a fait quelque chose de très inhabituel, je ne trouve pas vraiment de problème équivalent ailleurs sur internet, me voilà donc pour vous demander conseil !

L'ordinateur se lance normalement, le son apple retentit, l'écran s'allume une fraction de seconde et redevient noir, puis les bruits que font le disque dur et le ventilateur en temps normal se font entendre... sauf que l'écran reste noir. Je veux donc dire par là que la séquence de boot SEMBLE aller à son terme sauf que bien-sûr, après s'être allumé une fraction de seconde (comme un flash), l'écran reste noir.

J'ai tenté les habituels resets SMC/PRAM etc.
J'ai ré-ouvert l'ordinateur pour refaire consciencieusement tous les branchements.

Rien ne semble y faire...

Par avance, un grand merci pour votre aide et à très vite !
Belle fin de journée !
 

ilya1050

Membre confirmé
11 Mai 2020
20
12
31
Bonjour,

As tu essayé de remettre l'ancien clavier ?

Eh non, pas encore. J'avoue que je pensais pas qu'un changement de clavier puisse provoquer un truc pareil...
Mais je vais peut-être devoir m'y résoudre en effet.
Je vais essayer et je te tiens au courant !
Merci !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
41 536
6 532
  • J’aime
Réactions: ilya1050

ilya1050

Membre confirmé
11 Mai 2020
20
12
31
Bonjour à vous !

J'ai tout re-démonté. J'ai mis l'ancien clavier, checké toutes les connectiques, etc.
Je tente un boot normal et cette fois-ci plus rien ne se passe. L'écran reste noir, aucun bruit de démarrage.
J'ai tenté de remplacer la vieille batterie morte par une nouvelle (tout en gardant tout le reste de la configuration tel qu'elle était auparavant) et toujours pas de boot, écran noir et rien d'autre.
Par contre la batterie donne des signes de vie et le Magsafe effectue sa charge normalement lorsqu'il est branché à l'ordinateur.

Des idées ? :)o_O:banghead:
 
Dernière édition:

ilya1050

Membre confirmé
11 Mai 2020
20
12
31
Si tu as un bong au démarrage et si l'écran reste totalement noir, il faut te focaliser sur le connecteur de la dalle-écran et en particulier sur celui qui relie la carte mère à l'écran.

C'était juste. Je poste ici la solution pour ceux que ça pourrait intéresser.
Il s'agissait d'une sorte de court-circuit que provoquait la languette en plastique qui est attaché à l'embout du câble reliant l'écran à la carte mère. Lorsqu'il était connecté "normalement" le plastique touchait un peu le connecteur et il y avait un problème. Il suffisait de ne pas remettre la languette comme elle était placer à l'origine et de la positionner de sorte que le plastique ne touche pas le reste. Voilà !

Merci à vous et à bientot !!
 
  • J’aime
Réactions: Sly54

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
41 536
6 532
Il s'agissait d'une sorte de court-circuit que provoquait la languette en plastique qui est attaché à l'embout du câble reliant l'écran à la carte mère.
Non, ce n'est pas un court-circuit qui lui provoque des dégâts irréversibles sur des composants, mais un mauvais positionnement de ce connecteur qui je le répète est la seule connexion entre la carte mère et la dalle-écran. De plus sa manipulation demande la plus grande attention, il est assez fragile. Problème résolu et c'est tant mieux pour toi. ;)
 
  • J’aime
Réactions: ilya1050