Probleme de changement de resolution - MacOS X 10.3.2

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 490
4 287
58
St Germain en Laye - FRANCE
Je me demande si il n'y a pas un pb avec les drivers NVidia de la dernière mise à jour 10.3.2. En effet depuis cette mise à jour je suis régulièrement confronté à des soucis de changements de résolution.

Ma config:
iMac G4 17"LCD 800 Mhz (bought in 2002/10)
NVidia GeForce 4 MX 32 MO
MacOS X 10.3.2 - Quicktime 6.5
Ram: 768 MB
Classic chargé au démarrage de session

régulièrement certaines applications (Application Formac Studio, des jeux comme Harry Potter La Chambre des Secrets, Captain Bumper...) ne parviennent pas à changer de resolution, l'écran restant bloqué sur 1440x900. Dans ce cas le jeu s'affiche dans une zône d'écran de la taille de la resolution normale du jeu (un rectangle de 1024x768 en bas à gauche de l'écran pour Harry Potter par exemple).

Quand ce pb se produit, après avoir quitté le jeu, le panneau de configuration Moniteur n'arrive plus non plus à changer de resolution. Il faut alors poubelliser les fichiers com.apple.windowserver.plist et com.apple.windowserver.000393d79772.plist et redémarrer (l'un de ces fichiers se corrompant semble-t-il)

je me demande si le bug n'est pas lié à Classic. En effet la dernière fois que ceci s'est produit, après redémarrrage et ouverture d'une application Classic, l'affichage était complètement "merdique" et illisible. Il a fallu accéder "à l'aveugle" au tableau de bord Moniteur (via le menu Pomme de Classic), changer de résolution sous Classic (avec les flèches haut et bas du clavier), pour retrouver un affichage normal de l'envirronnement Classic...

Je me demande si je ne vais pas essayer de remplacer tous les fichiers NVidia installés par 10.3.2 par ceux de l'installeur 10.3...

D'autres ont ce genre de soucis?

(NB: rapport de bug envoyé à Apple via l'onglet FeedBack de la page MacOS X du Web Apple)
 
A

Anonyme

Invité
r e m y a dit:
Classic chargé au démarrage de session
(...)
je me demande si le bug n'est pas lié à Classic.
et en désactivant le lancement de classic au démarrage, ça donne quoi ?
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 490
4 287
58
St Germain en Laye - FRANCE
Ben je ne sais pas encore... vu que c'est un bug qui survient de façon fortuite (du moins je n'ai pas encore isolé la suite d'opération à effectuer pour quil se produise)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 490
4 287
58
St Germain en Laye - FRANCE
Pb résolu.

Le problème est le suivant.

Si Classic est chargé en mémoire et réglé pour se mettre en veille (mettons après 2 minutes). Lorsqu'une application MacOS X (par exemple un jeu) change la résolution de l'environnement MacOS X, Classic ne reçoit pas cette instruction et reste sur la résolution précédente.

Du coup, lorsqu'on lance une application Classic, la différence de réglage de résolution entre l'environnement Classic et l'environnement MacOS X conduit à un affichage illisible.

Lorsque ceci se produit, il faut aller dans "Dossier système", "Tableau de bord", ouvrir "Moniteur" et cliquer au hasard pour changer de résolution l'environnement Classic, ce qui restaure un affichage correct.

Pour EVITER ce problème, il suffit de mettre la mise en veille de Classic (onglet Avancé dans le PrefPane Classic) sur JAMAIS

et ensuite attendre la résolution du bug par Apple (d'après le support technique d'un éditeur de jeu à qui j'avais signalé ce bug, c'est prévu pour MacOS X 10.3.5 !!!
)

(Rapport de "bypass" de bug envoyé à Apple)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 490
4 287
58
St Germain en Laye - FRANCE
désolé..; ce n'est pas la solution... Le bug vient de se produire alors que Classic est maintenant réglé pour ne JAMAIS se metttre en veille.