10.14 Mojave Problème de démarrage lent sur MacBook 2016

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Salut à tous !
Nouveau venu sur votre forum de passionnés, je poste déjà un soucis qui me turlupine avec mon MacBook de début 2016, sous Mojave.

Ayant été habitué il y a quelques années (et pour quelques mois seulement) a un MacBook Air 2012, et ayant trouvé cette machine très agréable à utiliser quotidiennement pour de la bureautique et un peu de multimédia, ne serait-ce que par sa rapidité d’allumage et d’ouverture des logiciels.
J’ai craqué pour un petit MacBook de début 2016. Apparemment le disque dur SSD a été changé avant l’achat car c’est un modèle que j’ai acheté reconditionné (c’est un 256go).

Le soucis c’est qu’au démarrage, il se passe 45 secondes entre le son de démarrage, et l’apparition de la pomme. Le chargement de la pomme dure lui une dizaine/quinzaine de secondes.

J’ai donc fait immédiatement une Clean install sous Mojave afin de repartir sur du propre (Je suppose...). Mais aucun changement.

J’ai lu ici même qu’il s’agissait éventuellement d’un problème de sélection de disque de démarrage dans les réglages. Mon disque interne n’était effectivement pas sélectionné. Je le sélectionne donc, je redémarre via le petit bouton à côté et le démarrage est toujours aussi lent.
Je repars dans les réglages et constate que le disque n’est plus sélectionné .

Je fouille un peu plus sur ce forum et tombe sur un autre conseil.
J’ai donc réinitialisé les permissions utilisateur via ce tutoriel :
https://www.google.fr/amp/s/www.mac...isations-de-votre-dossier-personnel-97278?amp


Avant de retenter la sélection du disque de démarrage.

Je redémarre, et là toujours aucun changement ! Et le disque n’est toujours plus sélectionné dans les réglages, après ce dernier redémarrage.

Je suis donc perdu car je ne comprends pas pourquoi certaines actions ne se sauvegardes pas (j’ai notamment tenté de couper le son au démarrage grâce à la petite commande via terminal, mais pareil ça ne fonctionne pas après redémarrage...)
 

Fichiers joints

  • 7C39277A-ACEB-4E06-9FA3-2E614BF6A262.jpeg
    7C39277A-ACEB-4E06-9FA3-2E614BF6A262.jpeg
    1,1 Mo · Affichages: 83

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
Bonjour Marty

Je te propose de fournir ainsi les informations de base -->

- va à : Applications > Utilitaires > lance le «Terminal». Dans la fenêtre ouverte > saisis la commande (informative) :
Bloc de code:
diskutil list
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)

  • tu vas voir s'afficher le tableau des disques attachés au Mac (en interne / externe) > avec leurs paramètres de tables de partition > partitions > Conteneur CoreStorage si présent > Conteneur apfs si présent

Poste ce tableau ici en copier-coller (pas de capture) > mais attention ! > avant de faire ton coller -->
  • dans cette page de MacGé > presse le bouton
    524315_original.png
    ici :
    521520_original.png

    menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)

=> ces informations montreront la configuration du disque.
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Merci de ton aide.
Voici ce que j'obtiens :

Bloc de code:
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         251.0 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         250.7 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +250.7 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume MACBOOKSSD              25.3 GB    disk1s1
   2:                APFS Volume Preboot                 47.6 MB    disk1s2
   3:                APFS Volume Recovery                522.7 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
Le volume de démarrage MACBOOKSSD a un format apfs. Passe encore la commande :
Bloc de code:
nvram efi-boot-device

  • la commande lit en NVRAM > à la variable efi-boot-device (appareil de démarrage automatique de l'EFI) --> le chemin de démarrage correspondant

Poste le retour complet (même si le chemin en question est d'une rédaction abstruse).
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Je ne suis pas assez expérimenté pour comprendre clairement ce que tu me dis, mais comme tu m'expliques les commandes à réaliser, je m'exécute. Et je te remercie de prendre du temps pour moi.

Après avoir entré la nouvelle commande, voici ce que j'obtiens :
Bloc de code:
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>25650435-84B8-469F-961E-2D81837CE394</string></dict></dict><key>BLLastBSDName</key><string>disk1s2</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\1091EE7A-0B90-4F09-810C-1CB2A34ED369\System\Library\CoreServices\boot.efi</string></dict></array>
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
En résumé : le chemin inscrit en NVRAM tel que mentionné ici doit faire démarrer automatiquement le Mac sur le volume MACBOOKSSD. Càd. que le programme interne du Mac (l'EFI) > déclenché à l'allumage du Mac > va consulter la NVRAM > lire le chemin de démarrage automatique > le suivre au volume de prédémarrage Preboot > et effectuer le déclenchement du démarrage du volume MACBOOKSSD.

- je ne vois aucune anomalie ici.​

----------

Si tu consultes le panneau : "Disque de démarrage" des Préférences Système > le volulme MACBOOKSSD n'est pas actuellement indiqué comme disque de démarrage automatique ?
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Je suis étonné (presque déçu) qu’il n’y ait pas d’anomalie car un démarrage si lent n’est forcément pas normal, je pense.

Voici deux petites vidéos, filmées à l’instant.
La première du démarrage en entier :

La seconde, du panneau « disque de démarrage » dans les préférences systèmes, où je suppose que le disque MACBOOKSSD n’est pas sélectionné comme disque de démarrage (les deux vidéos ont été filmées à la suite) :
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
Le chemin de démarrage en NVRAM est toujours inscrit dans une syntaxe impossible. Mais il peut-être simplifié à ceci -->
Bloc de code:
25650435-84B8-469F-961E-2D81837CE394 ... disk1s2 ... \1091EE7A-0B90-4F09-810C-1CB2A34ED369\System\Library\CoreServices\boot.efi

  • tu vas me dire que ce n'est guère plus parlant. Le 1er UUID = 25650435-84B8-469F-961E-2D81837CE394 est celui du volume de prédémarrage Preboot du Conteneur apfs. disk1s2 est son index d'appareil. Donc l'EFI du Mac adresse directement ce volume (monté automatiquement dans le temps du boot).
  • le 2è UUID = 1091EE7A-0B90-4F09-810C-1CB2A34ED369 est celui du volume de démarrage Macintosh HD. C'est aussi l'intitulé d'un dossier contenu dans le volume Preboot et dédié au prédémarrage de ce volume. Dans ce dossier > il y a un répertoire System > contenant un dossier Library > contenant un sous-dossier CoreServices > contenant un lanceur intitulé boot.efi. C'est le sens du chemin dans Preboot = \1091EE7A-0B90-4F09-810C-1CB2A34ED369\System\Library\CoreServices\boot.efi.

Bref : l'EFI doit foncer au volume Preboot > y exécuter le lanceur boot.efi --> lequel à son tour va adresser le volume de démarrage Macintosh HD. C'est compliqué logiquement > mais ça ne prend pas de temps à un processus en terme exécutif. L'ensemble du chemin de démarrage pour l'EFI que tu as en NVRAM est canonique : aucune erreur. J'en ai un exactement identique dans la NVRAM de mon Mac > à la différence des UUID près. Mais chez moi > la  (signalant le lancement de démarrage de l'OS) s'affiche après quelques secondes à peine.

Chez toi > il y a manifestement un délai tout à fait anormal. Entre le Chime (carillon de démarrage signalant que l'EFI a exécuté les tests préliminaires) et la  --> il se passe un temps fou. Or la  devrait s'afficher quasi dans la foulée du Chime.

----------

Je note que si le volume MACBOOKSSD est bien affiché (comme volume démarrable) dans le panneau "Disque de démarrage" --> il n'y a aucune mention en-dessous indiquant qu'il a été sélectionné comme disque de démarrage automatique. Ce qui est une autre anomalie - alors qu'un chemin canonique existe en NVRAM.

----------

Passe encore la commande :
Bloc de code:
diskutil mount disk1s2

  • qui monte le volume de prédémarrage Preboot (toujours non monté par défaut pendant la session d'utilisateur). Si tu obtiens un :
Bloc de code:
Volume Preboot on disk1s2 mounted

  • c'est bon. Passe alors la commande :
Bloc de code:
bless --info /

  • qui affiche le chemin de démarrage de Macintosh HD > tel que stocké dans Preboot

Poste le tableau retourné. C'est pour vérifier si l'information obtenue de cette façon --> corrobore bien le chemin de la NVRAM.
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Je me disais bien que le disque de démarrage se devait d'être sélectionné (avec la mention en dessous) après le redémarrage également mais je n'en étais pas sûr. Mon doute était donc bien fondé.

Comme tu as pu le constater, le démarrage est je trouve excessivement long. D'autant plus que même le chime est également long à arriver après pression du bouton power, en comparaison avec d'autres modèles que j'ai pu voir ou prendre en main rapidement. Et ça commence à m'inquiéter.

Je continue donc.
Après avoir tapé la première commande,
J'obtiens ceci (comme prévu) :
Bloc de code:
Volume Preboot on disk1s2 mounted

et après avoir entré la seconde commande, j'obtiens ceci :
Bloc de code:
12884902260 => Blessed System File is /Volumes/Preboot/1091EE7A-0B90-4F09-810C-1CB2A34ED369/System/Library/CoreServices/boot.efi
12884902111 => Blessed System Folder is /Volumes/Preboot/1091EE7A-0B90-4F09-810C-1CB2A34ED369/System/Library/CoreServices
The blessed volume in this APFS container is "/".
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
Logiquement parlant --> il n'y a aucune faute. Le chemin de démarrage du volume MACBOOKSSD est comme il doit être --> pour que le démarrage de ce volume s'effectue automatiquement et sans délai. Ce qui rend incompréhensible justement l'énorme délai que tu expérimentes.

- je peux > si tu voulais être absolument certain que ce chemin de démarrage (en NVRAM et dans Preboot) est hors de cause --> te passer une commande qui réécrit le chemin en NVRAM (à la variable efi-boot-device). Ce qu'il n'est possible d'effectuer dans un terminal de la session d'utilisateur --> que si le SIP (protocole de sécurisation) est désactivé. Ne serait-ce que provisoirement pour permettre la passation de cette commande.​

=> c'est qui vois, ici.
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Je pense qu’il serait bon de savoir évidemment. Si tu as quelque chose à me proposer, c’est avec plaisir que j’accepte !

En tous cas, sache que je n’ai absolument aucun fichier sur ce macbook pour l’instant donc si besoin de formatage, aucun problème non plus de ce côté là.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 077
25 015
Forêt de Fontainebleau
Enabled = activé. Pour tester une réécriture "manuelle" (via le terminal) du chemin de démarrage en NVRAM --> il faut désactiver le SIP. Qui sinon verrouille la variable efi-boot-device en NVRAM.

----------

Pour désactiver le SIP > redémarre > les 2 touches ⌘R (cmd R) tenues pressées de l'écran noir => à la  = démarrage sur l'OS de secours. Tu obtiens un écran affichant une fenêtre de 4 Utilitaires macOS. Va à la barre de menus supérieure de l'écran > Menu Utilitaires > sous-menu : Terminal.

Lance-le et passe la commande :
Bloc de code:
csrutil disable

  • qui désactive le SIP

Cela fait > quitte le Terminal > va à : Menu  > Disque de démarrage > sélectionne Macintosh HD > redémarre dessus.

----------

De retour dans ta session > repasse la commande :
Bloc de code:
csrutil status

  • et poste le statut du SIP.
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
J’ai effectué ce que tu m’as demandé sur le terminal après avoir démarré l’utilitaire via CMD+R,
le terminal m’a bien affiché que le statut était passé disabled.
J’ai sélectionné le disque de démarrage sans problème comme demande, et redémarré.

Après l’ouverture de la session, je tape :
Bloc de code:
csrutil status
dans le terminal,

Et malheureusement (je suppose), réponse :
Bloc de code:
System Integrity Protection status: enabled.
 

litobar71

Achemineur de vrac
Club MacG
24 Novembre 2012
5 277
13 597
65
Vignes Beaujolaises
bonjour à tous les deux,

Apparemment le disque dur SSD a été changé avant l’achat car c’est un modèle que j’ai acheté reconditionné (c’est un 256go).
répétant souvent qu'il est utile de consulter l'aide des logiciels, je m'y colle régulièrement pour faire ce que je dis et je suis tombé sur ceci dans l'aide de CarbonCopyCloner:

Capture d'écran 2019-04-11 à 09.30.08.jpg

ce SSD est un portable mais c'est peut-être une piste.
 
Dernière édition:
  • J’aime
Réactions: macomaniac

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Pensez-vous que ceci puisse être effectivement mon problème ?
Dois-je essayer cette solution ?

Car je possède un MacBook de début 2016. Et je ne connais pas le disque dur installé bien entendu.
 

MartyTCL

Membre junior
10 Avril 2019
33
1
31
Merci pour ton aide.
Voici ce que j'obtiens dans le panneau SATA/SATA Express (j'obtiens la même phrase à la rubrique PCI ) :


Peut-être que cette ligne ci-dessous peut te renseigner ?

 
Dernière édition:
M

Membre supprimé 1138547

Invité
Merci pour ton aide.
Voici ce que j'obtiens dans le panneau SATA/SATA Express (j'obtiens la même phrase à la rubrique PCI ) :


Peut-être que cette ligne ci-dessous peut te renseigner ?


C’est louche
Tu devrais l’avoir en SATA
Essaye > Stockage