Problème de FTP depuis plusieurs semaines

ccciolll

Membre expert
Club MacG
Bonjour,

je rencontre un problème pour déposer des fichiers en FTP sur un serveur.
Ce problème est nouveau, il dure depuis qqes semaines (un peu moins d'un mois il me semble).

Je vais essayer de donner un maximum de détails, probablement dans le désordre car ce domaine est assez obscur pour moi.

Donc voilà, une connexion FTP qui fonctionnait très bien depuis des mois et des mois se met à déconner. Il est utile de savoir que j'utilise d'autres serveurs en FTP, pour d'autres usages, et qui eux continuent de fonctionner. Donc ce n'est pas un pb général mais uniquement avec ce serveur là. (et je n'ai pas fait de mises à jour d'OS ou de logiciel FTP entre temps, en tout cas rien de volontaire, j'ignore si des mises à jour auraient eu lieu dans mon dos, en automatique).

Il n'accepte plus très bien que je passe en écriture. Voici ce qui se passe dans Cyberduck : quand j'envoie un fichier dessus, même très léger, il dit OK, il commence à faire comme si ça passait. Premier symptôme bizarre : au lieu de charger le fichier de 0 à 100 % en passant par les étapes intermédiaires qu'on pourrait s'attendre à voir, il affiche d'emblée 100% du poids uploadé. Par contre, la vitesse de connexion notée un peu plus loin baisse petit à petit jusqu'au moment où ça s'arrête. Là, soit il me dit connexion timed out, soit parfois il dit qu'il a réussi (enfin il ne dit pas qu'il a échoué…).
Mais le fichier uploadé fait un poids de zéro et n'est pas exploitable de l'autre côté (forcément…)

Des tests ont été faits avec un autre mac et aussi avec FileZilla , avec c edernier le résultat est le même au final. Les symptômes sont similaires : barre de remplissage à 0% d'emblée, après un temps d'attente il fini par mettre un message d'erreur comme quoi le fichier existe déjà sur le serveur, et il me montre mon fichier (avec son poids normal) et le fichier sur le serveur, d'un poids de zéro k, en me demandant lequel je veux garder. Si je dis d'écraser, ça revient au bout d'un moment avec la même question. Cela se passe même si c'est un nouveau fichier, avec un nouveau nom qu'il n'avais jamais vu.

C'est comme si il commençait par construire une coquille vide dans le but de la remplir, puis il oublie qu'il a construit cette coquille, il la voit et il dit « oh, le fichier est déjà là » mais non, c'est juste une coquille vide. (oui, bon, j'exprime ça avec des mots du quotidien…)

J'ai bien sûr commencé par demander aux informaticiens de la boîte, mais après des semaines sans réponse, celui qui a bien voulu essayer de m'aider n'a pas pu faire grand chose. On a essayé en coupant le pare feu du mac ou en autorisant les connexions entrantes, mais ça n'a rien donné. Et aujourd'hui, la seule solution qu'il me propose serait de remplacer le mac par un PC…

Pour info, le même fichier envoyé depuis un vieux PC, ça passe. Donc le pb est bien entre mac et ce serveur. Les macs que j'utilise sont un snow leo et un lion. Et pour le technicien (qui indique tout de même ne rien connaître en mac) c'est juste une faille de sécurité due à l'age de mes OS. Peut-être, mais j'aimerais au moins avoir l'avis de qqun qui s'y connaisse vraiment en mac.