Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Problème de ftp

Discussion dans 'FAI et réseau Mac' créé par Floppy, 4 Juin 2003.

Modérateurs: Nephou
  1. Floppy

    Floppy Membre d’élite
    Club MacG

    Inscrit:
    19 Avril 2001
    Messages:
    1 458
    J'aime reçus:
    4
    Salut,

    Depuis peu, je souhaite accéder à ma machine par ftp mais je rencontre un problème.

    Je me connecte en administrateur sans problème. Je peux changer de dossier par cd. En revanche, où que j'aille, impossible d'obtenir la liste des fichiers que ce soit par dir ou ls. Je n'ai pas de réponse à la commande jusqu'au timeout.

    Quand j'essaie depuis la machine qui héberge le serveur, ça marche mais avant la liste j'obtiens :
    ftp> ls
    229 Entering Extended Passive Mode (|||54306|)

    Qu'est ce ça veut dire et pourquoi ça ne marche pas depuis un client distant ?

    Les droits de mon home directory sont :
    drwxr-xr-x

    D'avance merci.
     
  2. albin

    albin Membre émérite

    Inscrit:
    20 Mai 2000
    Messages:
    688
    J'aime reçus:
    4
    tu pourrai précisé quel type de réseau tu as des deux coté si il y as des firewall et quek type d'OS.
    et avec logiciel de FTP tu as testé ???
    a+
     
  3. Floppy

    Floppy Membre d’élite
    Club MacG

    Inscrit:
    19 Avril 2001
    Messages:
    1 458
    J'aime reçus:
    4
    réseau internet. serveur Mac OS X 10.2.6, ftp de base. client ftp de windows. firewall des 2 cotés.
     
  4. maousse

    maousse Vétéran
    Club MacG

    Inscrit:
    20 Avril 2002
    Messages:
    7 224
    J'aime reçus:
    445
    si tu as un firewall sur le serveur, ouvre le port 21, c'est le port standard pour le ftp.

    Ensuite, il vaut mieux, pour être sûr d'arriver un bon port, utiliser un client qui se connecte en mode passif, c'est à dire en mode passe-partout, ce qui force la communication à passer par le port 21, donc ce qui donne la possibilité de régler un firewall éventuel comme il faut et passer à travers.

    (sans passer en mode passif, un cilent établit la connexion par le port 21, et le transfert de fichier se fait via un port aléatoire, donc, c'est pas possible de régler un firewall pour cela. Que quelqu'un me corrige si je me trompe, mais, en gros, je crois que c'est ça)

    Je ne sais pas si le client ftp intégré à windows permet se réglage en mode passif, si ce n'est pas le cas, procure toi un réel client ftp pour windows dédié à cette tâche, c'est une option standard [​IMG]
     
  5. Floppy

    Floppy Membre d’élite
    Club MacG

    Inscrit:
    19 Avril 2001
    Messages:
    1 458
    J'aime reçus:
    4
    J'ai ouvert le port 21 bien sûr. Seule la connexion se fait. C'est sûrement un problème de ftp passif. Faut que je me trouve un client plus sérieux !
     
Modérateurs: Nephou
Chargement...