10.9 Mavericks Problème de mise à jour applications iTunes, macOS...

poeta

Membre junior
12 Juin 2010
16
1
47
Bonjour à tous,
Je souhaite réinitialiser mon iPhone SE qui est en version iOS 11.2.2
Seulement iTunes me signale ce message:
Pour restaurer votre iPhone avec iOS 13.4, installez OS X 10.11.4 (ou ultérieur) et iTunes 12.8.
Mon Mac est de 2010 en version OSX 10.9.5 et n'accepte plus de version ultérieure.
J'ai déjà fait faire une mise à jour de l'OS sur cet iMac il y a quelques années par iConcept, mais c'était la dernière possible car mon Mac n'est pas assez récent et bien configuré matériellement parlant (4 Logements de 2GO utilisés).
Du coup, je ne vois pas comment pouvoir mettre à jour tout ça et réinitialiser mon iPhone.

Autre point, sur iTunes, quand je lance une Maj des applications, quasi rien ne se passe. Je ne vois plus l'icône en haut à droite pour le menu déroulant des applications en téléchargement et il semblerait que la touche "Mettre à Jour toutes les applications" en bas à droite se grise une fois que j'appuie dessus et revienne à son état initial après quelques dizaines de secondes (après avoir passé en revue toutes les applications dans la petite fenêtre Pomme en haut au milieu).

J'ai peur de quelque chose que je n'espère pas. Rassurez-moi, mon iMac n'est pas trop vieux et bloqué parce-que plus rien est possible avec les mise à jour ?
Je vous remercie par avance pour votre aide.
 
Dernière édition par un modérateur:

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
Mon Mac est de 2010 en version OSX 10.9.5 et n'accepte plus de version ultérieure.
Là, ce n'est pas normal.

2010 c'est l'année où tu l'as acheté ou le modèle ?

Tout iMac de 2009 et 2010 est compatible au moins à OS X 10.11 El Capitan, souvent à macOS 10.13 High Sierra (late-2009 et mi-2010).

Il y a là, à quelques mètres de moi, un iMac mi-2010 doté de macO 10.13.6 High Sierra, 8 Go de RAM (4x2 Go) et qui fonctionne parfaitement avec un iPhone 8 iOS 13.4.

Donc la grande question : t'as essayé de faire une upgrade ou tu restes confiné dans ta fausse idée ?


D'une façon générale, OS X 10.9 Mavericks est un système mort au champ d'honneur. Apple ne veut plus en entendre parler. Ce ne m'étonne pas que tu n'arrives plus à rien avec son éco-système.



Procédure de mise à niveau vers macOS High Sierra

Ne pas oublier de faire des sauvegardes… AVANT.
 

poeta

Membre junior
12 Juin 2010
16
1
47
Bonjour Moonwalker,

Un grand merci pour ta réponse qui me rassure.
Mon Mac est bien de Mi-2010 et acheté en Aout 2010, processeur 3,2 GHz Intel Core i3, Mémoire 8GO 1333Mhz DDR3, ATI Raedeon HD 5670 512 Mo, OS X 10.9.5. La mise à jour date de Janvier 2015.
Si tu me confirmes que je peux avancer dans la mise à jour, alors oui, je vais le faire et je ne vais pas rester confiné dans ma fausse idée qui n'est pas la mienne d'ailleurs mais celle de mes revendeurs Iconcept!!!
Nous sommes en plein confinement justement, j'ai donc le temps de le faire, mais aussi de planter l'Imac et me retrouver dans le caca!;)
J'ai bien lu la procédure, qui me semble simple. Pour sauvegarder, j'utilise Time Machine. Me confirmes-tu que ça enregistre bien toutes les cessions d'un Imac et que je retrouverai tout par la suite.
J'ai bien lu, qu'en passant à Sierra, certaines applications pourraient demander la mise à jour, je me doute bien, ce n'est pas un problème.
En gros, je suis bien entendu prêt à faire le pas, mais j'ai peuro_O;):D:D:D
 
Dernière édition par un modérateur:

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
Mon Mac est bien de Mi-2010 et acheté en Aout 2010, processeur 3,2 GHz Intel Core i3, Mémoire 8GO 1333Mhz DDR3, ATI Raedeon HD 5670 512 Mo, OS X 10.9.5. La mise à jour date de Janvier 2015.
La machine dont je parlais est exactement la même.

En gros, je suis bien entendu prêt à faire le pas, mais j'ai peur
Il ne faut pas. La peur conduit au côté obscur.

Si tu fais ce que je préconise, et que j'applique à chaque mise à niveau, tu n'auras pas de mauvaise surprise.

Une fois Installation de macOS High Sierra.app téléchargé dans /Applications, au lieu de lancer immédiatement la procédure d'installation proprement dite, tu feras un programme d'installation amorçable sur un DD externe ou une clé USB (8 Go).

Tu le gardes au chaud. C'est ton assurance vie.

Si tu as un anti-virus ou un coupe-feu tiers, tu le dés installes en suivant la procédure prévue par le développeur (pas de logiciels de désinstallation ni de mise à la corbeille brutale). Les trucs comme Bitdefender, LittleSnitch, etc.
Si tu as installé un programme pour écrire le NTFS, genre Paragon NTFS for Mac, tu fais pareil.

Concernant les pilotes de périphériques : tu vérifies que tu as bien la dernière version à jour pour ton Mac, et qu'elle est compatible 10.13 High Sierra.

Le but est d'éviter que le système se bloque lors d'un redémarrage après l'installation parce qu'il tombe sur un truc mal ficelé.


High Sierra contient des mise à jour de l'EFI firmware de ta machine. Ne t'affole pas si tu entends la "corne de brume" entre deux redémarrages.

Dans tous les cas, une fois la procédure d'installation lancée, tu laisses courir jusqu'à ce qu'il te remettre ta session. Tu n'interrompras pas même si ça te semble long. La procédure peut prendre facilement une heure.

Une fois la mise à niveau installée, tu laisses le système faire ses indexations (une heure de plus environ).

Il y aura encore la mise à jour de sécurité 2020-02 à faire, ainsi que la mise à jour de iTunes, celle de Safari (version 13.1 !!!), etc.

Même précautions que pour la mise à niveau, surtout avec la mise à jour de sécurité qui reprend toutes mes mises à jour de sécurité depuis 10.13.6. Là aussi mise à jour de l'EFI firmware et plusieurs redémarrages à attendre.

Bonne sauvegarde et bonne installation.
 

poeta

Membre junior
12 Juin 2010
16
1
47
La peur conduit au coté obscur? :bookworm:
Bon oui peut-être.
Tes explications sont assez claires, mais encore trop imprécises pour le novice que je suis.
Je vais donc reprendre:
  • Une fois l'application téléchargée dans "Applications"... c'est fait, je l'ai même fait en 2018 pour je ne sais quelle raison, l'icône Installer High Sierra est déjà dans mon dossier "Applications". Dois-je supprimer et le réinstaller?
  • Je viens de faire un programme d'amorçage avec succès sur un disque dur 1TO que je viens de "Partitionné" En Mac OS étendu (journalisé) et avec une seule partition appelée MYVOLUME, comme conseillé si je ne me trompe pas.
  • Si j'ai des anti-virus, coupe-feu ou NTFS? Je n'en sais rien. J'ai Malwarebytes Anti-Malware et "je crois" que c'est tout.:bigtears:
  • Pour les Pilotes de périphériques, j'imagine que je contrôlerai ça une fois High Sierra installé?Non avant? J'ai une imprimante et deux disques dur en périphériques. Comment vérifier ce que tu me demandes?
  • Du coup, tu ne dis pas à quel moment je peux faire feu pour lancer l'installation. C'est quand?:D
  • A un moment donné, dans la procédure de création du programme amorçable, il est dit: Important : pour obtenir le programme d’installation requis, téléchargez-le à partir d’un Mac doté de macOS Sierra 10.12.5 ou version ultérieure ou d’El Capitan 10.11.6. Du coup, c'est grave si je démarre de 10.9.5?
  • Il est écrit aussi dans cette même procédure sous une fenêtre: * Si votre Mac est doté de macOS Sierra ou version antérieure, incluez l’argument --applicationpath, de la même façon qu’il s’utilise dans la commande pour El Capitan.

Bon enfin voila quoi.
Je suis content de 3 choses pour le moment: Installation de l'icône de lancement de High Sierra, Le programme d'amorçage installé sur le DD et le fait que je commence à comprendre ce que tu me dis...
A plus tard et merci à toi.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
je l'ai même fait en 2018 pour je ne sais quelle raison, l'icône Installer High Sierra est déjà dans mon dossier
Outch !

Il vaut mieux télécharger de frais. Les certificats des anciennes versions, celles d'avant le 20 octobre 2019, ne sont plus valides. Cela entraine des complications qui nécessitent d'antidater l'horloge de son Mac.

Si j'ai des anti-virus, coupe-feu ou NTFS? Je n'en sais rien. J'ai Malwarebytes Anti-Malware et "je crois" que c'est tout.
Je pense que tu le saurais si tu avais installé de telles choses.
Malwarebytes c'est ok. Pas lui qui va mettre son souk.

Pour les Pilotes de périphériques, j'imagine que je contrôlerai ça une fois High Sierra installé?Non avant? J'ai une imprimante et deux disques dur en périphériques. Comment vérifier ce que tu me demandes?
Sur le site du constructeur pour l'imprimante.

Question disque durs, les drivers sont inclus dans l'OS donc normalement il n'y a rien à installer.

A un moment donné, dans la procédure de création du programme amorçable, il est dit: Important : pour obtenir le programme d’installation requis, téléchargez-le à partir d’un Mac doté de macOS Sierra 10.12.5 ou version ultérieure ou d’El Capitan 10.11.6. Du coup, c'est grave si je démarre de 10.9.5?
C'est parce que Apple ne veut plus rien savoir des OS précédents. Il n'y a pas si longtemps c'était Mavericks qui constituait le minimum.

D'ailleurs, il est aussi indiqué : * Si votre Mac est doté de macOS Sierra ou version antérieure, incluez l’argument --applicationpath, de la même façon qu’il s’utilise dans la commande pour El Capitan.

Ce qui correspond à ton cas.

Du coup, tu ne dis pas à quel moment je peux faire feu pour lancer l'installation. C'est quand?
Quand tu le sens. :D
 

poeta

Membre junior
12 Juin 2010
16
1
47
Salut Moonwalker,
Bon ça y est, j'ai réinstallé le programme de lancement de la mise à jour High Sierra dans "Application".
  • Question: Je ne suis pas obligé de refaire un Programme d'installation amorçable maintenant que j'ai remis l'application à jour?
  • Autre question (il y en a de moins en moins ;)): Ca veut dire quoi du coup: incluez l’argument --applicationpath, de la même façon qu’il s’utilise dans la commande pour El Capitan. Je ne sais pas ce que ça veut dire, quand est-ce qu'il faut l'inclure et ou?

Sinon, je suis prêt, ça sera ce soir pour l'installation.
Merci à toi.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
Question: Je ne suis pas obligé de refaire un Programme d'installation amorçable maintenant que j'ai remis l'application à jour?
Ben si, ça vaudrait mieux.

Autre question (il y en a de moins en moins ;)): Ca veut dire quoi du coup: incluez l’argument --applicationpath, de la même façon qu’il s’utilise dans la commande pour El Capitan. Je ne sais pas ce que ça veut dire, quand est-ce qu'il faut l'inclure et ou?
La ligne de commande pour El Capitan :

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

Du coup, comme tu procèdes depuis Mavericks, cela te donne pour High Sierra la ligne de commande suivante :

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ High\ Sierra.app

D'ailleurs, si tu regardes la fenêtre de Terminal mise en exemple au point 7, c'est exactement ce cas. ;)
 

poeta

Membre junior
12 Juin 2010
16
1
47
Arfffff.
Et bien merci, je trouve légère, l'explication d'Apple comparée à la tienne qui est mieux détaillée.
Bon cependant, j'ai quand même un piti problème.
L'application de lancement High Sierra est bien dans mon dossier "Application", mon disque dur est à nouveau formaté en Mac Os étendu (journalisé) avec comme nom MyVolume. Et quand le lance Terminal avec la ligne que tu me donnes et celle que je devrais taper selon Apple, je me retrouve avec ce message :

Bloc de code:
Last login: Tue Apr  7 18:18:05 on ttys000

You have new mail.

iMac-de-Frederic-GOUBe:~ fredericgoube$ sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ High\ Sierra.app
Password:

/Applications/Install macOS High Sierra.app does not appear to be a valid OS installer application.

iMac-de-Frederic-GOUBe:~ fredericgoube$
Sais-tu pourquoi ?
Bien qu'apparemement il faut que je rédige ma ligne comme pour El Capitan, ne penses-tu pas que la fin de la ligne suivante soit inutile ?
/Applications/Install\ macOS\ High\ Sierra.app
Apple semble dire de ne rajouter que : --applicationpath
Ou alors mon problème vient d'ailleurs ? Pour info, je n'ai pas fait "continuer" sur l'application de lancement High Sierra, une fois téléchargée, j'ai bien fait ou il fallait que j'avance un peu ?
Merci par avance.
 
Dernière édition par un modérateur:

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
La ligne de commande est exactement celle qu'ils donnent dans l'exemple illustré.

Le problème est clairement sur Install macOS High Sierra.app qui n'est pas déclaré "valide".

Ce High Sierra est bien téléchargé de neuf ? Il fait bien plus de 5 Go ?
 

poeta

Membre junior
12 Juin 2010
16
1
47
Moonwalker,
Téléchargé de neuf? Qu'entends-tu par neuf?
J'ai téléchargé de l'Appel Store selon le lien Apple.
Et effectivement, l'application ne fait pas 4,8GO comme indiqué sur Apple mais 24,5MO, c'est pas terrible!!!
Il y a un loup.
 

Fichiers joints

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
Le loup c'est qu'il t'a refourgué le "faux" installer. Enfin, la version réduite.

Apple, non seulement tu fais cher mais en plus tu fais ch*er !!! :rage:

Alors, ou tu utilises ton ancienne version (et tu changeras la date du Mac au 01 janvier 2017 si tu dois l'utiliser pour installer) ou tu utilises cette méthode pour récupérer un "vrai" installer :


L'article parle aussi de High Sierra.
 

poeta

Membre junior
12 Juin 2010
16
1
47
Merci Moonwalker.
J'essaierai demain de restaurer l'ancienne version, car je l'ai jeté avant-hier. Avec Time machine, ça devrait aller.
J'antidaterai en suivant.
La deuxième méthode n'a pas l'air super fiable aux vues des différents commentaires. Ou alors, les gars ont fait ça n'importe comment.
Dernière méthode, aller chez Iconcept et faire la mise à jour avec eux, ça ne devrait pas leur prendre trop de temps!
C'est un vrai grand bordel, heureusement que nous avons communiqué, je savais bien que c'était pas simple...pour moi.;)
Je te tiens au courant demain.
Merci encore à toi.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
Sinon, comme t'as tes sauvegardes, tu peux faire la mise à jour. L'installer c'était vraiment pour assurer les arrières, bien fait c'est comme un disque d'installation.
 

poeta

Membre junior
12 Juin 2010
16
1
47
Salut Moonwalker,
Je viens te donner des nouvelles.
Tout est rentré dans l'ordre en payant.
Ca a été le bazar quand j'ai voulu faire la mise à jour en changeant la date et d'autres messages sont apparus (je te joins une copie d'écran de ce que j'avais).
Avant de sombrer dans le coté obscur:), j'ai fini par amener mon Mac chez Iconcept et leur demander de la faire.
1h plus tard, j'avais un appel me disant que mon disque dur commençait à avoir des problèmes, bing, un disque dur en plus!
Pour minimiser les coûts, j'ai fait pas la suite moi-même l'installation de la mise à jour IOS et de tout ce qui a suivi, les sécurités, Itunes, les applications...
Ca à l'air de fonctionner maintenant.
D'ici 2 ans, j'ai bien compris qu'il faudra que je renouvelle cet Imac (tout en gardant celui-ci pour le minimum), car Apple finira par classer High Sierra comme les versions antérieures et plus grand chose ne sera possible (Business is business).
Je vais lancer un autre sujet à présent, car je ne comprends pas comment fonctionne Time machine dans le détail, mais ça, c'est une autre affaire.
En tout cas, je te remercie pour ta présence, pour ta patience et ton aide malgré tout, c'est juste moi qui n'ai pas pu aller plus loin.
A très bientôt.
 

Fichiers joints

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 631
3 642
Là-haut
D'ici 2 ans, j'ai bien compris qu'il faudra que je renouvelle cet Imac (tout en gardant celui-ci pour le minimum), car Apple finira par classer High Sierra comme les versions antérieures et plus grand chose ne sera possible
Deux ans est un peu court. Bon, à l'automne prochain il n'aura plus de mise à jour de sécurité ni pour Safari, mais les développeurs tiers attendront encore deux trois ans supplémentaires pour couper le cordon.

Actuellement, pour te donner une idée, le macOS le plus ancien utilisable est 10.11 El Capitan.