10.12 Sierra Problème de mise en veille

romain.jl

Nouveau membre
24 Janvier 2015
7
0
Salut a tous. Je fais remonter le sujet, vu que je rencontre des problèmes assez similaires avec un Mac mini Server 2012 quad core, OS X. 10.12.6 installé, connecté à écran tiers Philips.

Préférences réglées sur: mise en veille = jamais, mettre les disques en veille des que possible = décoché. Parfois, et de façon aléatoire, que ce soit après 5 minutes ou une nuit entière, le mac va se mettre dans un sommeil profond (hibernation?), et rien ne peut le réveiller, ni le clavier, la souris, ou le bouton on/off à l'arrière, et dans ces cas-là, ma seule option est de faire un hard reboot.

Mais ça ne le fait pas systématiquement non plus. J'imagine qu'a force, ça va créer des problèmes avec le disque dur :-/ J'ai suivi quelques conseils ici et là (commandes terminal pour supprimer l'hibernation), mais rien à faire: quand il se bloque, l'écran affiche un message comme quoi il ne reçoit pas de signal vidéo.

Débrancher-rebrancher le moniteur ne fait rien, même chose avec les périphériques usb. Le système a été réinstallé il y a 3 mois par Apple, et à part ça, je n'ai pas d'autres soucis. Dans ma configuration, il y a un Time Capsule et un NAS reliés au mac, ainsi qu'un UPS (APC). Si vous avez une idée, merci de me faire signe, car ça commence vraiment à m'inquiéter ce truc là!

Note de la modération : aucun rapport avec le message dans lequel tu as répondu, on déménage au bon endroit ! Et une petite aération de ton pavé de texte ne fait pas de mal.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 491
22 671
Forêt de Fontainebleau
Salut romain

Va à : Applications > Utilitaires > lance le Terminal.app.

Dans la fenêtre qui s'est ouverte > saisis la commande informative :
Bloc de code:
pmset -g custom
  • qui va retourner le tableau des paramètres de la gestion d'alimentation du Mac

Poste ce tableau ici en copier-coller (pas de capture) > mais attention ! avant de faire ton coller -->

  • presse le bouton (carré avec une croix incrite - juste au milieu de la largeur de la fenêtre totale) dans la barre de menus au-dessus du champ de saisie d'un message > menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)

=> je ne dirai si quelque chose me frappe à la lecture de ce tableau.
 

romain.jl

Nouveau membre
24 Janvier 2015
7
0
Merci de ton aide macomaniac: voilà ce que dit le terminal
Bloc de code:
AC Power:
Sleep On Power Button 1
autopoweroff         1
autopoweroffdelay    28800
standbydelay         4200
standby              1
ttyskeepawake        1
hibernatemode        0
powernap             1
hibernatefile        /var/vm/sleepimage
displaysleep         25
womp                 1
networkoversleep     0
sleep                0
autorestart          0
disksleep            0
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 491
22 671
Forêt de Fontainebleau
Le standby (= hibernation) est activé (1) avec un délai de 4200 seconces (70') après le déclenchemement du sommeil.
L'autopoweroff (= sommeil profond) est aussi activé (1) avec un délai de 28800 secondes (8 H).

Tu as désactivé le sleep (sommeil du kernel) - donc il ne devrait pas y avoir de déclenchement de ces 2 états > mais pour un mac de bureau il vaudrait mieux les désactiver.

Le displaysleep (= sommeil de l'écran) est sur 25' - cela paraît trop élevé.

Le disksleep (sommeil du disque) et sleep (sommeil du kernel) sont désactivés : pourquoi ne pas tester avec un délai fixé ? - étant donné que la RAM est maintenue sous tension pendant le sommeil-Système > cela permet un réveil instantané.

Je te propose de passer en guise de test la commande suivante (en copier-coller direct) :
Bloc de code:
sudo pmset -c autopoweroff 0 standby 0 powernap 0 displaysleep 10 disksleep 12 sleep 15
  • après validation > une demande de password va s'afficher (commande sudo) --> tape ton mot-de-passe de session admin à l'aveugle - aucun caractère ne se montrant à la frappe - et valide de nouveau
  • cette commande désactive l'autopoweroff et le standby ainsi que le powernap ; et fixe un délai : d'obscurcissement de l'écran de 10' d'inactivité en session > du disque de 12' et du kernel de 15'
  • J'ai sur mon MacBook Pro 2011 (qui me sert de Mac de Bureau exclusivement) des réglages trés voisins et > quel que soit le délai pendant lequel je ne m'en sers pas (une nuit par exemple) > si l'écran est bien noir et le kernel en sommeil au moment où je le reprends > une simple pression sur une touche rallume instantanément l'écran avec affichage du Bureau. Il est vrai aussi que je ferme toutes les applications avant de le laisser inactif pour un bon moment.

Cette commande écrit les valeurs de ces paramètres au fichier suivant dans l'OS : Bibliothèque (Générale de l'OS) > Preferences > com.apple.PowerManagement.plist. Tout est réversible ou éditable à ta guise.

=> Je te recommande de re-démarrer ton Mac une fois pour que ces nouvelles instructions soient chargées. Tu n'auras qu'à dire s'il y a un changement.
 
  • J’aime
Réactions: FULLCRUM

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 491
22 671
Forêt de Fontainebleau
:coucou: FULLCRUM

Le panneau graphique de l'Économiseur d'énergie (dans les Préférences Système) a quelque chose de "mal dégrossi" > en ce qui concerne la gestion de l'utilitaire pmset : des options "sommaires" et "peu explicites". Dans ce cas précis > la supériorité de la ligne de commande est éclatante.

L'affichage retourné par la commande :
Bloc de code:
pmset -g custom
met littéralement sous les yeux le tableau d'ensemble des paramètres d'alimentation en cours --> il est donc possible de réfléchir à un dispositif complet aux implications claires et distinctes --> et il suffit après cela d'ajuster une commande pour transformer une « intention rationnelle » en « routine exécutive ».

Remise dans son contexte > une commande du Terminal se trouve assignée à sa juste valeur : un simple moyen d'exécuter une intention préalable de la raison. Coupée de cet a priori rationnel qui seul déploie une dimension d'intelligibilité > une commande du Terminal reste dénuée de sens > car le fait brut d'être opératoire n'en fait jamais la formulation d'une raison.
 
  • J’aime
Réactions: FULLCRUM

romain.jl

Nouveau membre
24 Janvier 2015
7
0
Étonnant tout de même que ces états soient aussi peu documentés et les réglages aussi peu intuitifs.
Lorsque le problème s'est présenté, je n'avais pas fait de réglage particulier après ma dernière réinstallation système (qui datait de quelques semaines) ni touché au Terminal avant d'essayer de régler le problème. C'est anormal que le mac ne réponde plus après une simple période de non-utilisation, et ça ressemble à un bug.
Je vais tester ta solution, mais pour un réglage de ce type, il devrait y avoir un panneau de préférences "avancées", et c'est ce que tu sembles dire aussi.
L'utilisation du Terminal n'est pas agréable pour une majorité de personnes, et sans ton aide, je serais toujours coincé avec ce problème...
 

romain.jl

Nouveau membre
24 Janvier 2015
7
0
Il va falloir songer à créer un sujet unique sur les mises en veilles :D
Ce qu'il faudrait surtout, et particulièrement si c'est quelque chose de récurrent, c'est qu'Apple prenne conscience que ce genre de problèmes n'est pas acceptable. J'en ai eu des macs avant celui-là, et c'est surtout les dernières années qu'on a pu voir des problèmes à la sortie de veille, sauf erreur de ma part. Devoir en passer par le Terminal est exactement l'inverse de ce que veulent les non-informaticiens (notamment les créatifs ou ceux pour qui le résultat d'un travail, la fiabilité et la simplicité d'utilisation sont plus important que l'ordinateur ou son OS), et c'est pourtant là-dessus qu'Apple met l'accent. Contradictoire. Encore merci à macomaniac pour son temps, sa solution détaillée et sa patience.
 

romain.jl

Nouveau membre
24 Janvier 2015
7
0
je remonte le sujet, car le problème s'est manifesté à nouveau malheureusement (sans pour autant que je ne fasse aucune modification depuis l'autre jour)... tout semblait aller mieux, je ne comprends pas
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 491
22 671
Forêt de Fontainebleau
Salut Romain

Est-ce que tu peux rappeler quel est ce problème : plongée du Mac dans une hibernation sans appel ?

Passe par ailleurs la commande :
Bloc de code:
pmset -g custom
  • et poste le tableau retourné (dans une fenêtre de code) pour que je voie quels sont tes paramétrages actuels.
 

romain.jl

Nouveau membre
24 Janvier 2015
7
0
Est-ce que tu peux rappeler quel est ce problème : plongée du Mac dans une hibernation sans appel ?
En effet, c'est bien ça: touches clavier, clic de souris, bouton arrière, rien n'y fait. Avant de quitter le poste, généralement, je passe ma souris sur un coin actif pour lancer l'économiseur d'écran, ou bien j'éteins le moniteur.
Bloc de code:
AC Power:
Sleep On Power Button 1
autopoweroff         0
autopoweroffdelay    28800
standbydelay         4200
standby              0
ttyskeepawake        1
hibernatemode        0
powernap             0
hibernatefile        /var/vm/sleepimage
displaysleep         10
womp                 1
networkoversleep     0
sleep                15
autorestart          0
disksleep            12
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 491
22 671
Forêt de Fontainebleau
Pourtant les paramètres sont ultra-simples : sommeil-écran après 10' d'inactivité en session > sommeil-disque après 12' et sommeil-Système après 15'.

Je te propose le petit test suivant -->

tu passes la commande :
Bloc de code:
sudo pmset -c displaysleep 8
  • cette commande ramène le délai d'obscurcissement de l'écran de 10' à 8' d'inactivité en session

La commande passée + re-démarrage > la prochaine que tu quittes le Mac --> ne fais rien : (pas d'extinction de l'écran ni de lancement forcé de l'économiseur d'écran) --> est-ce que l'écran devient noir après 8 minutes ? - si oui > vérifie quand tu reprendras le Mac si la sortie de veille est immédiate.

Répète plusieurs fois ce protocole et dis s'il y a retour à la normale. Ton Mac > avec ses paramétrages > ne devrait jamais plonger dans le "coma" > il devrait à la première pression sur une touche se réveiller instantanément.