Problème déconnexion intempestive partages SMB

Pef56

Membre enregistré
29 Février 2012
2
0
Bonjour à tous,

Je fais appel à vos connaissances, car de mon côté, je suis un peu perdu.

Je vous explique mon problème.

Dans une des filiales du groupe dans lequel je travaille, nous avons installé récemment un domaine AD sous Windows 2008R2, plus un serveur de fichiers, également dans ce domaine.

Cette filiale utilisait avant un serveur Mac pour stocker ses données, et ce dernier utilisait les protocoles AFP et SMB pour les accès via Mac et PC. Ça c'est juste pour info.

Ce dernier montrait des signes de grosse fatigue, et j'ai du migrer les données de ce serveur vers le nouveau dans le domaine AD.

Les PC et les Mac accèdent bien aux différents partages de ce serveur, l'authentification se fais sans problème, les droits sont bien gérés, bref à ce niveau aucun soucis.

Mon problème arrive. Sur les Mac (en 10.5, 10.6 et 10.7), les utilisateurs observent quelques problèmes de lenteurs. Quand ils se connectent, le Finder peut mettre plusieurs minutes avant d'afficher les répertoires et fichiers.

Une des solutions trouvée sur le net, qui est de créer une nouvelle clé de registre sur le serveur forçant l'utilisation du protocole SMBv1 par le serveur n'y change rien.

Si ce n'était que ça mon problème ça irait.

L'autre aspect du problème, plus embêtant celui-là, est la déconnexion intempestive et aléatoire des partages sur les Mac.

En détail, ça donne ça :

- Un utilisateur s'identifie pour monter les partages dans le Finder -> OK
- Les partages sont montés, l'utilisateur travaille, écrit dans des fichiers, certains restent ouverts, etc...
- D'un coup, et sans savoir pourquoi, les partages ne sont plus accessibles

Quand cela arrive, la plupart du temps, le Finder perd complètement les pédales et plante. Obligé de rebooter le Mac "à la sauvage".

Ce problème arrive principalement en Wifi (bornes Airport), mais c'est arrivé également en Ethernet (une seule fois).

Dans les logs du Mac, j'ai observé ceci après avoir redémarré :

smbfs_smb_lookup: smbfs_smb_qpathinfo error = 60

Les recherches sur cette erreur ne m'ont pas plus avancé.

J'ai également cherché du coté du Wifi. Vu que les utilisateurs qui ont des Mac bougent beaucoup, je me suis dit que le Wifi était mal configuré ou que le Mac n'arrivait pas à passer d'une borne à une autre et qu'il perdait la connexion.

Négatif car j'ai en permanence un accès réseau où que je sois (tout du moins une réponse à un ping).


Voilà je vous ai exposé l'étendue de mon problème, peut-être que certains parmi vous auront des idées.

Merci d'avance.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 952
3 163
Je crains fort que tu ne trouves pas plus de solution ici que dans les forums Apple ou ailleurs [sur des fils remontant à 2008...]
Ça semble être un vrai bug mal (ou pas) corrigé.

À titre expérimental, tu peux considérer d'installer sur un poste une version récente de SAMBA et voir si ça marche mieux avec cette version qu'avec les binaires d'Apple.

Inversement, tu peux peut-être regarder du côté d'AFP (mais je ne me souviens plus jusqu'à quel point ça marche sous Lion) en installant un service AFP sur le serveur Ouinedoze. Voire carrément tenter le diable avec NFS.

Je déplace côté Réseau, qui me semble plus approprié.
 

Pef56

Membre enregistré
29 Février 2012
2
0
Merci pour ta réponse.

Pour ce qui est d'installer une version récente de Samba, je ne pense pas que soit faisable, étant donné que les Mac sont sans cesse utilisé par leurs propriétaires. Si jamais ça pose un autre problème et que le Mac devient "inutilisable" ça posera un gros problème.

Pour l'utilisation d'AFP ou NFS, j'y ai déjà pensé (et NFS me semblerait la solution la plus appropriée) mais ça implique qu'ensuite j'aurai deux arborescences de droits à gérer ... Je préfère éviter ça étant donné que la migration à été faite pour simplifier tout ça.

Je me concentre actuellement sur le WIFI. Les bornes Airport actuelles posant pas mal de problèmes (déconnexion, plantages aléatoires, etc...). Je vais les remplacer par des bornes NetGear neuves et on verra bien ce que ça donne.

Dans tous les cas je ne manquerai pas d'alimenter ce fil, ça pourra toujours servir à quelqu'un qui se retrouverai dans le même cas que moi.