Problème démarrage MBP sous Snow léopard

totolito62

Membre enregistré
24 Juin 2009
4
0
Bonjour,

Mon Mac Book Pro Unibody de 2009 Core 2 Duo 8Go de RAM, 750 Go de HD, ne démarre plus sous Mac OSX Snow Léopard,
je j'ai éteint avant hier soir, plus moyen de démarrer aujourd'hui, il est resté pendant 6h00 sur la page de grise avec la pomme et la petite roue qui tourne indéfiniment.
Voici donc ce que j'ai fait pour me sortir de ce problème:

- Il démarre et fonctionne parfaitement sous Windows 7 via BootCamp, donc il ne semble pas que ce soit un problème de matériel.

- J'ai vérifié le disque dur à l'aide du DVD d'installation de Snow Léopard, avec l'Utilitaire disque, "le volume Macintosh HD semble être en bon état",

- par contre la vérification des permissions me donne toujours des erreurs (toujours les mêmes) après avoir essaye de réparer 5 fois ces maudites autorisations, après chacune de ces réparations, j'ai le message "Permissions réparées",

-Puisque cette dernière solution ne fonctionne pas je démarre en mode Single User
-- mount -uw /
-- chown root: admin
-- chmod 1775 /
-- exit
Surprise, il ne reboot pas.

Ne démarre toujours pas en mode normal

Redémarrage en Single User
-- /sbin/fsck -fy
Affichage ***** FILE SYSTEM WAS MODIFIED *****
--/sbin/mount -uw/
-- exit
re plantage après la ligne "Ethernet.....NVEthernet::setLinkStatus - Active"

je remarque quelques lignes plus haut "systemShutdown false"
puis un peu plus bas "Previous Shutdown Cause : 3
Donc je reboot à nouveau manuellement (appui sur le bouton de mise sous tension).

Le MBP ne démarre toujours pas, je teste le mode sans échec (appuis sur Shift gauche), avec lequel je n'ai pas plus de succès, affichage de la pomme, de la roulette et de la barre de progression qui disparait au bout de 1/3 du chemin et la toupie continue de tourner indéfiniment (au moins 20 minutes...)

Il me restait un doute au sujet des permissions: je repart en mode single user et je m'aperçois que les fichiers dont les permissions n'était pas bonnes sont en double; par exemple le fichier MainMenu.nib existe ainsi qu'un double suivi d'un espace et d'un 1 lorsque je tape "ls -la"les permission sont -rwxr-xr-r, ce qui me semble normal pour des fichiers, pourtant l'utilitaire disque dit que le fichier devrait être à drwxr-xr-r, le d signifie bien qu'il s'agit d'une directory donc pas d'un fichier,
et LA MAINTENANT JE N'Y COMPRENDS PLUS RIEN,

DISK WARRIOR me dit signale les mêmes erreurs...

Je remercie d'avance celui, ou celle qui voudra bien me consacrer un peu de son temps pour permettre de me sortir de cette impasse.
 

totolito62

Membre enregistré
24 Juin 2009
4
0
Bonjour,
Personne ne semble avoir de piste à me proposer...

Par contre je me pose une question à savoir, est-il normal que les fichiers qui sont trouvé avec de mauvaises permissions soient en double exemplaire par exemple pour la ligne:

System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/Support/LockScreenLeopard386.app/Contents/Resources/Italian.lproj/MainMenu.nib
le fichier MainMenu.nib existe ainsi qu'un autre fichier MainMenu.nib 1
Si je ne me trompe, il s'agit bien d'un fichier et non pas d'un dossier, pourtant les utilitaires (utilitaire disque, DiskWarrior,) m'informent que les permissions devraient être drwxr-xr-x alors quelles sont -rwxr-xr-x, le d des permissions indique qu'il s'agit d'un dossier et non pas d'un fichier.

Si quelqu'un pouvait me renseigner sur ces 2 points je pourrai peut-être avancer.

Sinon est-il possible de faire une réinstallation du système et uniquement du système sans perdre mes données?

Merci d'avance
 

jugnin

Glorious bastard
Club MacG
7 Octobre 2004
4 154
1 314
38
Sur ta tête
Sinon est-il possible de faire une réinstallation du système et uniquement du système sans perdre mes données?

Merci d'avance

Bonjour, j'ai rien pigé à ton problème car je suis nul. Mais tu peux réinstaller le système sans problème et sans perdre tes données, si tu les as sauvegardées. :zen:
 

totolito62

Membre enregistré
24 Juin 2009
4
0
Je ne peux que réinstaller qu'avec le DVD de snow leopard, je n'ai rien d'autre sous la main, je n'ai pas mes sauvegardes qui datent d'un mois.

Donc je ne voudrais réinstaller que le système sans toucher à rien d'autre sur le disque dur, existe t-il une possibilité d'installation dans ce sens avec snow leopard?

merci d'avance
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 148
26 160
Forêt de Fontainebleau
Salut totolito.

Le fait que tu accèdes à l'écran 'Pommé', signifie que ton Mac franchit les 2 premières étapes du démarrage de façon satisfaisante : le 'POST' (check-up hardware par l'EFI qui se conclut par le retentissement du carillon = 'chime') et le 'booter' (exécution du fichier d'initialisation boot.efi qui charge le kernel = mach_kernel et les kexts = extensions essentielles, ce qui a lieu pendant l'écran 'Pommé').

Maintenant, le fait que ton Mac reste scotché en montrant l'écran 'roue crantée giratoire' qui tourne indéfiniment, veut dire que le kernel qui est maintenant chargé avec ses extensions natives ne parvient pas à compléter la tâche qui lui est impartie à ce 3è stade du démarrage : càd. le chargement des kexts subsidiaires de tierce partie + le lancement des sous-bassements UNIX de l'OS = le BSD_UNIX_System + le lancement du Processus_Parent de tous les processus_fils de l'OS, càd. le Process number 1 = launchd.

Où est-ce que cela coince exactement et pourquoi? - Là, c'est manifestement une autre paire de manches, parce que, comme tu peux voir, il y a 3 opérations kernel qui s'imbriquent, ce qui ouvre un champ multiple de possibilités de plantage. S'agit-il d'une kext (extension du noyau) de tierce partie qui fait coincer le kernel? S'agit-il d'un composant du Système UNIX de Bas_Niveau qui se trouve défaillant? S'agit-il du processus_parent launchd qui ne parvient pas à se lancer?

Le diagnostic est d'autant plus difficile que l'accès à l'OS est bloqué (malgré les indications éventuelles du verbose mode en général assez cryptiques). Tu sembles avoir fait preuve d'initiative de façon compétente et active, sans issue positive. Il y a juste quelques petits points qui m'intriguent :

- Quand tu évoques, en mode Single User, la passation de commandes chown et chmod, j'espère que tu as fait des lapsi d'écriture dans la transcription de ton post? Car :

Bloc de code:
chown root: admin

ça ne peut pas marcher, il faut que le : relie le u (user) et le g (group) sans espace. Et comme cela concerne des items systèmes, le groupe devrait être wheel et pas admin. Étant en équivalent session 'root' en 'Single User', je suppose que point n'est besoin de se promouvoir sudoer? De toute façon, la commande doit être récursive pour étendre son autorité aux éléments contenus. Et il faut indiquer un espace-cible au verbe de changement de propriétaires. Donc en fait, en cas, j'aurais plutôt fait :

Bloc de code:
sudo chown -R root:wheel /

- Quant à la commande 'chmod', j'espère que le '1775' est un lapsus de retranscription? Et normalement, s'agissant des items système, seul root possède les droits complets en r+w+x = 7. Le groupe wheel même (dédié au seul root) est en r-x = 5. Donc j'aurais plutôt fait :

Bloc de code:
sudo chmod -R 755 /

Mais, pour le dire brièvement, je ne pense pas que ce soit un simple problème de permissions corrompues qui empêchent le kernel de charger le BSD_UNIX, car il opère en droits root par défaut (c'est pourrait-on dire le premier de tous les sudoers :D).

- Incidemment, quand tu es en commande : fsck -fy, est-ce que tu ré-itères bien cette commande aussi longtemps que tu n'obtiens que des 'file system was modified', jusqu'à l'obtention espérée du 'OK'? Car sinon, se précipiter sur 'exit' est inopérant.​


Bref, «ce que je sais c'est que je ne sais rien», comme l'eût dit Socrate, dès lors que ça bafouille au moment où le kernel a pris la main, car c'est vraiment opaque, ce qui se passe en fait. Je te remets donc aux conseils avisés de Sly :)coucou:), peut-être en glissant un tuyau préalable à la ré-installation : si tu peux mettre ton Mac en mode 'Target' (touche 'T' maintenue pressée au démarrage jusqu'à apparition à l'écran du logo Y mobile du FireWire) et le relier en FireWire à un autre, tu pourrais par précaution récupérer tes données sensibles ainsi. Le volume du disque de ton Mac en position 'Target' apparaissant sous forme d'image-disque montée sur le Bureau du Mac d'accueil (comme celle d'un DDE), il est facile de faire des copies de docs sur un DDE connecté en USB au Mac d'accueil en parallèle.
 
Dernière édition:

totolito62

Membre enregistré
24 Juin 2009
4
0
:up:
Merci de vos réponses,

:eek:
Je pense que je vais régler mon problème en achetant un nouveau disque dur interne (Seagate Laptop thin SSHD 500 Go), ainsi qu'un boitier pour utiliser mon ancien disque en externe.

Ce nouveau disque dur hybride devrait permettre d'accélérer les accès aux programmes sur le mac, je vais y réinstaller OSX Snow léopard, je migrerai mes applications et mes documents, et j'y ferai un clone de ma partition Windows.

Ainsi je pense que les problèmes seront réglés.

:rolleyes:
D'autre part, je viens de m' apercevoir d'un nouveau problème sur le MBP, il ne produit plus de bip au démarrage alors qu'hier il fonctionnait, cela aurait-il un lien avec le problème de mon HD, ou est-ce indépendant, se pourrait-il que ce soit un problème de la nappe de connexion SATA.

:zen:
Je vous remercie d'avance des réponses que vous voudrez bien m'apporter.

Totolito