iMac Problème d'impression curieux

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
Bonjour,

J'utilise plusieurs iMac qui datent de 2009, des iMac 27 qui tournent sous 10.13.6. J'utilise également une vieille imprimante laser Dell 3110cn. J'ai fait l'installation de l'imprimante de manière identique sur tous les iMac mais seul 1 parvient à imprimer. Pour tous les autres, j'ai comme réponse "L'imprimante ne répond pas". Or j'ai du refaire des installation from scratch sur certains d'entr'eux. Mais pas moyen de faire fonctionner l'imprimante. Pourtant, c'est le même système, même pilote, même réseau et même sur une installation vierge de High Sierra, l'imprimante est bien installée mais toujours le même message d'erreur.

Du coup je n'ose plus toucher à l'iMac qui imprime. J'ai tenté de le cloner avec Carbon copy cloner et sur un autre iMac, le clone imprime. Mais je ne peux pas me servir de cette vieille installation pour refaire les autres. Et surtout, je voudrais comprendre.

Où puis je regarder pour essayer de voir ce qui fait que d'un côté ça marche et pas des autres ? En apparence, tout à l'air identique.

Si quelqu'un a une idée, merci de m'aider.

Christine
 

JOEL65

Membre actif
18 Février 2007
322
14
Je ne suis pas spécialiste , mais d'abord est ce que tu vois l'imprimante dans tes périphériques sur chaque iMac lorsque l'imprimante y est branchée ? si non c'est qu'il y a un problème avec l'installation du pilote du périphérique
 

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
Oui, dans tous les cas l'imprimante est bien installée et allumée. Elle est en vert dans les préférences. C'est le même système OS X et le même pilote.
Je me demandais s'il y avait une possibilité d'aller creuser du côté du système un peu plus profondément en ligne de commande par exemple pour voir ce qui cloche sur les iMac qui n'impriment pas.

Je précise que dans tous les cas, je pingue bien l'imprimante.
 
Dernière édition:

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
9 226
4 336
Questions stupides, mais bon, il s'agit d'essayer de cerner le problème.
Ton imprimante est en wi-fi, puisque tu pingues. Donc
  • Wifi ok sur tous les iMac ?
  • Pas de conflit d'IP ?
  • 'partager sur le réseau' coché dans les prefs imprimantes sur tous les iMac ?
  • imprimante visible dans les prefs partage sur tous les iMac ?
  • toujours dans les prefs partage, impression autorisée pour tous les utilisateurs sur tous les iMac ?
 

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
L'imprimante est en filaire, comme tous les mac. Ils sont tous sur le même swtich de la Freebox. Même plage, 192.168.1.XXX
  • Pas de conflit d'IP, freebox en DHCP. Baux statiques pour l'imprimante et non statique pour les iMac y compris pour celui qui imprime.
  • Quand je partage l'imprimante sur l'iMac où ça fonctionne, les autres iMac la voit, et une fois installée sur les autres iMac je peux imprimer. Mais si j'essaie d'imprimer avec une installation en direct, ça ne marche pas.
  • L'imprimante est configurée de manière basique. Aucune limitation d'IP ou de chose de ce genre.
  • Dans les préférences de partage, l'impression est autorisée pour tous.
  • Pas de redirection de port particulière sur ma Freebox hormis un vieux port FTP (21 et 22)
PS:
  • Je peux me connecter sur le site web de l'imprimante de tous les iMac.
  • Mais un seul mac imprime (ou son clone). C'est comme si tous les autres iMac filtraient un port ou un truc comme ça par défaut sur une installation système vierge. C'est ça que je trouve bizarre. Le neuf marche moins bien que le vieux système.
 

peyret

Membre expert
Club MacG
22 Octobre 2001
6 178
2 754
72
43110
Mais un seul mac imprime (ou son clone). C'est comme si tous les autres iMac filtraient un port ou un truc comme ça par défaut sur une installation système vierge. C'est ça que je trouve bizarre. Le neuf marche moins bien que le vieux système.
Un clone imprime donc le problème doit concerner "les autres..."

Sur "les autres" pourrais-tu faire un rapport Etrecheck, peut-être qu'il va trouver un truc...
https://forums.macg.co/threads/memoire-saturee-par-systeme-575-go-sur-1-to.1314779/post-13631395
 

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
Je ne connaissais pas le logiciel, merci. J'ai lancé le logiciel sur 2 iMac et je reviens vers vous.

Vous voulez que je vous ajoute ici les différences entre les 2 iMac ?
 
Dernière édition:
  • J’aime
Réactions: peyret

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
Bon, si vous voulez je le partage mais je n'ai rien trouvé de flagrant.
  • A part le SIP désactivé du côté qui imprime et pas de l'autre. Mais je l'ai désactivé pour voir et ça ne change rien.
  • Des logiciels installés en plus du côté qui fonctionne mais rien de spécial.

  • Petite précision quand ça n'imprime pas, au moment de lancer l'impression il y a dans le gestionnaire d'impression un bref message "connexion à l'imprimante" avant le message "l'imprimante ne répond pas".
  • Au niveau de l'imprimante, il n'y a pas de trace de la demande d'impression. Donc c'est plus le message qui n'arrive pas à l'imprimante que l'imprimante qui répond sans que l'iMac ne voit le retour.
  • Mais au niveau réseau, je ne vois rien comme différence. C'est incompréhensible.
 

JOEL65

Membre actif
18 Février 2007
322
14
Je répète, je ne suis pas spécialiste et peut-être est ce plus compliqué que ce qui suit, mais puisque tu indiques que tu peux imprimer en partage , confirmes tu qu'au niveau de tes périphériques tu vois 2 fois l' imprimante avec logiquement 2 noms légèrement différents, pour choisir lorsque tu fais une impression directe et non pas en partage ,le nom en mode direct . Faute de quoi si tu ne choisis pas celle en mode direct il va d'abord essayer de lancer l'impression ( connexion à l'imprimante ) pour dire ensuite qu'elle ne répond pas.
 

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
J'ai bien les deux imprimantes. Celle en direct et la même mais partagé par l'iMac qui imprime. Les deux sont en vert "inactive". Quand je lance l'impression en direct j'ai le message que j'ai indiqué "impression en cours " puis " impression en cours - l'imprimante ne répond pas" et si je refais une impression, là l'imprimante marche. Si je refais une impression en direct une fois que l'imprimante est sortie de la veille, c'est toujours pareil. Pas de réponse de l'imprimante.
- Au passage le message "l'imprimante ne répond plus" apparait assez rapidement. Disons une seconde ou 2. Donc je pense qu'il y a quelque chose au niveau de la couche réseau (imac) qui bloque. En effet le même mac avec le clone du système qui imprime, là, ça passe.
 

peyret

Membre expert
Club MacG
22 Octobre 2001
6 178
2 754
72
43110
Salut,

Tu pourrais poster le (ou les) rapports Etrecheck pour voir si on découvre quelque chose ?
 

Chrisdfr

Membre confirmé
4 Décembre 2012
83
2
D'accord mais On dirait qu'on ne peut pas partager un fichier texte ici. C'est quoi le meilleur format ? jpeg ? ça risque de ne pas être pratique à lire...
 

peyret

Membre expert
Club MacG
22 Octobre 2001
6 178
2 754
72
43110
  • Pas engagée] VirusScannerHelper (App Store - installé 2021-05-06)
Élément d’ouverture moderne
/Applications/VirusScannerPlus.app/Contents/Library/LoginItems/VirusScannerHelper.app

... un antivirus, sur celui qui imprime pas ?
Essai de le désinstaller....

(anti-virus et antivirus : bizarre anti-virus donne un lien.... allo @Anthony )