Probleme disque dur Mac Plus

Furo

Membre confirmé
4 Avril 2021
55
1
22
Hello, je ressortis ce matin mon Mac Plus avec son disque dur 20sc
Il y a un petit mois, j'ai pris le seul disque dur fonctionnel que j'avais (un 40sc) et j'ai mis un 7.5 dedans, tout allait nickel
Sauf quand je l'ai allumé ce matin: "Erreur system"...bizarre...
Je mets le disque dur sur un LC475 pour voir le problème et je tombe sur ça
Que dois-je faire?
1635158046780.jpg
 

Franz59

Membre expert
Club MacG
20 Août 2005
1 155
236
61
Nord
Normal si c'est un OS du LC 475 (68040 avec copro émulé)
Il faudrait trouver un système 6.07 ou 7.1 plus adapté au SE (j'ai ça au cas ou...)
 

Furo

Membre confirmé
4 Avril 2021
55
1
22
En fait le problème, c’est que j'aimerai mettre un système plus ancien pour le plus (genre 7 voir 6) mais le LC475 ne prend qu'à partir de 7.5, et c'est le seul que j'ai qui utilise les disquettes double face
 

gpbonneau

Membre expert
Club MacG
12 Juillet 2005
1 186
514
65
Normandie
gpbmaccollection.online.fr
Salut Florian, si j'ai bien tout compris suite à nos échanges, ton disque dur externe n'a pas le sélecteur SCSI branché et il est donc sur zéro.
C'est un disque dur interne 40Mo Conner récupérer dans un Mac pour le mettre dans un boitier externe 20SC, c'est ça ?
Ton boitier était prévu pour un 20Mo Miniscribe, le connecteur bleu du sélecteur SCSI est trop gros pour se brancher sur le 40Mo.

Du coup il ne fonctionnait que sur ton Plus qui n'a pas de disque dur interne et pas sur ton SE qui a disque dur interne car il est aussi sur zéro (et donc en conflit).
En le branchant en interne sur le 475 ça marche aussi puisqu'il remplace celui d'origine.

Le 7.1 fonctionne sur le 475 (il était fourni avec) mais avec un System Enabler (065), donc si tu l'installes à partir des disquettes d'origine du 475, ça doit marcher. Ensuite sur le SE comme il n'a pas besoin de System Enabler et il devrait ignorer celui du 475.

Sinon, le plus simple puisque tu retires le disque dur du boitier externe à chaque fois que tu le mets dans le 475, c'est d'en profiter pour mettre un shunt sur la carte électronique du disque pour fixer le numéro SCSI sur 1.
Comme ça il fonctionnera sur tous tes Mac dans le boitier externe. Tu pourras le brancher sur ton SE et récupérer son dossier Système en 7.1 (par recopie).

Tu dois retirer les 3 résistances sur le bus SCSI, il suffit de tirer dessus. En externe il faut mettre un bouchon sur la deuxième prise SCSI du boitier.
Puis tu mets un shunt sur les 2 premiers picots de sélecteur d'adresse SCSI (A1), comme ça le disque sera fixé sur l'adresse n° 1 et ne sera plus en conflit avec les disques durs internes.
IMG_8040D.JPG


Ceci dit, c'est quand même mauvais signe ces erreurs à répétions. C'est généralement lié à des problèmes de fichiers corrompus, donc un disque dur avec des secteurs illisibles...
 

Furo

Membre confirmé
4 Avril 2021
55
1
22
Bon bah...problème résolu ^^'

Ce que j'ai fait:

-Sur mon LC475, j'ai mis (encore) le systeme 7.5, il fonctionne(enfin) nickel
-Puis, j'ai mis mes disquettes 6.0
-J'ai supprimé tout les fichiers system etc... et je les ais remplacer par les fichiers des disquettes 6.0

Résultat: tout fonctionne sur mon Mac Plus