Problème entre Parallels Desktop et partition BootCamp

chris22

Membre enregistré
4 Janvier 2008
2
0
Bonjour et je présente mes meilleurs voeux pour cette année 2008 à tous,

Le problème que je rencontre est le suivant :

1/ Tout d'abord le contexte :

1-1/ MacBook Pro avec OS Léopard
1-2/ Installation de l'utilitaire rEFIt (pour proposer un multi-boot)
1-3/ Installation d'une partition sur le disque interne par bootcamp
(en fait il crée une partition 3, la première étant l'EFI, la seconde celle du mac)
1-4/ Installation de Windows xpsp2 en reformatant en NTFS la partition lors de l'installation (choix lors de l'installation de windows) et en la renommant (avant elle s'appelait "BootCamp").
1-5/ rEFIt voit bien la partition 3 avec Windows et propose bien le dual boot "Mac" (par défaut) et "Windows".
1-6/ Les deux OS bootent normalement et tout est reconnu sous Windows grace aux drivers sur le dvd de Léopard (bien que le son et un autre périphérique doivent être installés manuellement...).

2/ Début des problèmes :

2-1/ Ayant vu partout que Parallels Desktop permettait de reconnaître une partition bootcamp et la rendait accessible directement sur le bureau de l'OS Léopard, je n'ai pas hésité et l'ai acheté.
2-2/ J'installe la version 3.0 acheté en boîte, mais si l'installation se passe bien, le démarrage provoque un "CRASH" de l'application.
2-3/ En regardant sur internet, je constate qu'il faut un 'upgrade' ves la version 5582 pour la faire fonctionner sous Léopard... et effectivement après le lancement de l'appli ne plante plus...
2-4/ Lors de ce premier démarrage, il crée un "My Boot Camp.pvs" automatiquement et en reconnaissant bien la bonne version de windows, sans doute en reconnaissant la partition BootCamp.
2-5/ Puis je souhaite tester cette "virtualisation", en laissant tous les réglages par défaut qu'il propose mais l'écran ou devait apparaître Windows reste NOIR...
2-6/ Je ferme la virtualisation, ne pouvant arrêter windows autrement, ce qui n'est biensûr pas bon pour un os comme windows...
2-7/ Puis je relance le Mac et repart sur la partition Windows, mais là, Parallels à ajouter une entrée à lui "Parallels Configuration" qui se lance en premier et laisse le message bien connu lorsqu'il y a des problèmes de partitionnement "HAL.DLL manquant ou corrompu".
2-6/ Je tente alors de relancer ma configuration précédente de windows, mais elle aussi a été corrompu puique je me retrouve avec un écran noir...
2-7/ Je refais ma configuration windows et je m'aperçois que reviens SYSTEMATIQUEMENT l'option de démarrage de "Parallels Configuration" ???
2-8/ Le fichier boot.ini l'indique alors en :
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Parallels configuration" /fastdetect /NoExecute=OptOut
Alors que la partition 1 de ce disque est l'EFI... ? EST-CE NORMAL ?
2-9/ De toute façon, tenter de booter sur parallels configuration redonne "HAL.DLL manquant" ??
2-10/ La ré-installation de windows sur la partition 3 et mis en lancement par défaut me redonne accès aux deux OS "MAC et WINDOWS"...

CONCLUSION :
-----------------

N'osant plus utiliser Parallels Desktop, comment faire pour ne pas mettre en péril ma configuration actuelle FONCTIONNELLE et en pouvant utiliser AUSSI cet environnement windows DANS PARALLELS DESKTOP ?

Merci de vos conseils précieux.
Chris.​
 

Tarul

Le Modérateur Fou
Club MacG
15 Septembre 2005
4 191
206
35
Bonjour,
Bonne année 2008,

Il n'y a pas (à ma connaissance bien sûr) de méthode pour ne pas mettre en péril ta configuration actuelle. Si ce n'est de cloner ton disque dur avant de faire une nouvelle tentative, mais j'ignore si le clonage de mac os X est suffisant.

La difficulté est que tu possèdes plus de partitions, et si Parallels et VMware sont qualifiés lorsqu'il n'y a que windows et mac os. il n'y a que peu de retour lors de l'utilisation (toujours à ma connaissance) de ces logiciels dans des configurations à la tienne.

Pour le point 2-7, parallels utilise une configuration particulière pour exécuter windows qui est sur une partition bootcamp. Il me semble que c'est normal.
Pour le point 2-8, là, je ne peux pas que ce soit normal (à faire confirmer par un utilisateur de parallels, moi je suis avec vmware). Si c'est bien anormal, le problème vient sans doute de la détection des partitions par parallels.

Je viens de faire un tour sur le forum de parallels. Il y a un how-to pour réaliser une configuration similaire à ce que tu souhaite.

http://forum.parallels.com/showthread.php?t=12683&highlight=refit
 

chris22

Membre enregistré
4 Janvier 2008
2
0
Bonjour et merci pour le lien qui contient pleins d'informations très utile, d'autant que je souhaite mettre Ubuntu 7.10 (pour rEFIt, le MBR acceptant 4 partions primaires, il me reste une de libre pour LINUX...).

Sinon, pour le problème de partition, la ré-installation de windows puis de mettre par défaut le lancement sur la partition 3 (celle de windows) a remis semble t'il les choses en ordre car :

1/ Lancement de Parallels Desktop = Ok il reconnaît de nouveau la partition windows
2/ Je configure en éditant le VM créé par parallels la partie vidéo pour lui dire d'activer un écran avec une résolution de 1920x1200 (par défaut rien n'était activé ?!!!) et je lui augmente la taille mémoire à 1Go.
3/ Et je teste... Miracle : windows se lance dans la fenêtre et installe les drivers VM de parallels

Je teste en basculant entre les deux environnements et c'est le top tout fonctionne même le partage des applications Mac et Windows d'un environnement à l'autre...

4/ Je reboote après pour voir si l'environnement windows a été affecté par Parallels et là = et bien non, par défaut c'est toujours Windows qui se lance et qui fonctionne parfaitement sans avoir été nullement touché par les pilotes de Parallels et même tous les softs qu'a installé parallels sont bien là, comme l'antivirus et autres outils qui sont disponibles et actifs...

TOUT EST DONC REGLE, reste à voir pour une installation sur une quatrième partition de LINUX, je vous tiendrais au courant.

PS : Pour le fichier boot.ini, il est resté le même, donc "partition(1)" pour parallels Configuration semble tout à fait normal.
:up: