iMac Problème Lightroom depuis MacOs sur SSD externe

naglagla

Membre confirmé
24 Juillet 2006
57
3
valence
Bonjour à tous,
Devant la lenteur de mon iMac 27" 2017 (3,4 GHz Intel Core i5 / 8 GB 2400 MHz DDR4 / 1To Fusion Drive), j'ai décidé d'acheter un SSD externe (Crucial CT1000X8SSD9) et de l'utiliser comme disque de démarrage.
J'ai fait une installation (10.14.6) propre. Tout était parfait. Jusqu'à ce que je copie colle mes fichiers correspondants aux presets/préférences de Lightroom et Photoshop de mon ancien disque dur (le fusion drive), sur le nouveau.
A partir de ce moment là, en souhaitant éditer une photo de Lightroom dans Photoshop (pomme+E), le photoshop qui s'ouvrait était le photoshop de mon fusion drive. S'en suivait un freeze complet de 2 min, et un redémarrage automatique de l'ordi.

J'ai désinstallé la suite Adobe. Ai supprimé les fichiers "adobe" des bibliothèques (root et user). J'ai fait de même sur le disque Fusion Drive pour prévenir toute "fausse route". Et ai réinstallé les deux logiciels (PS et LR) sur mon nouveau disque de démarrage (le SSD externe).
C'est désormais le bon Photoshop qui s'ouvre lorsque j' "édite dans Photoshop" depuis Lightroom. Mais il y a toujours un problème aléatoire de freeze total.

J'ai lu sur le site Adobe (ici) qu'il pouvait y avoir un problème de GPU et qu'il fallait le désactiver dans les préférences LR. Ce que j'ai fait. Ça semble fonctionner depuis.
Mais nouveau comportement étrange : hier soir en voulant sortir de veille mon ordi (rq : je ne l'avais pas mis en veille délibérément, je l'avais "abandonné" un long moment), un écran "noir" s'est allumé et... rien d'autre. J'ai du forcer l'extinction de l'ordi.

Bref, mes interrogations sont les suivantes :
  • Est-ce normal d'avoir un comportement de l'ordi un peu hasardeux (notamment lors des mises en veille / sortie de veille) lorsque le disque de démarrage est un SSD externe ?
  • Ai-je fait une bêtise en copiant collant les préférences de LR et PS ? Si oui, me conseilleriez-vous de réinstaller tout le système pour que tout soit super clean ? Ou en ayant réinstaller juste les 2 applications ça suffit ?
  • D'autres utilisateurs de LR ont ils du aussi désactiver le GPU ?

Merci beaucoup pour vos lumières. Pardon si c'est un peu long.
Naglagla
 

naglagla

Membre confirmé
24 Juillet 2006
57
3
valence
EDIT : Pour être sûr que le GPU était la cause du freeze je l'ai réactivé. Tout semble fonctionner parfaitement (niveau Lightroom / Photoshop). Je suis un peu perdu j'avoue.... Enfin tant mieux si ça roule. Je vais continuer comme ça, en espérant ne pas ravoir de comportements bizarres...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 556
10 430
Nancy___
Bonjour,

Est-ce normal d'avoir un comportement de l'ordi un peu hasardeux (notamment lors des mises en veille / sortie de veille) lorsque le disque de démarrage est un SSD externe ?
Non


Ai-je fait une bêtise en copiant collant les préférences de LR et PS ? Si oui, me conseilleriez-vous de réinstaller tout le système pour que tout soit super clean ? Ou en ayant réinstaller juste les 2 applications ça suffit ?
Oui - oui - non

1er oui : dans les préférences que tu as collées, il devait y a voir le chemin d'accès de tes applications Adobe, d'où le démarrage sur le FD

2e oui : arrête le bricolage et repars sur du tout beau - tout nruf

3e non : cf 2e oui ;)
 

cybercap

Membre confirmé
28 Mai 2010
16
0
Juste pour apporter ma pierre à l'édifice, je constate aussi des lenteurs sous LR en traitant des photos de Nikon D850 et surtout des vidéos de drone en 4K sur mon iMac 5K late 2017. J'ai essayé aussi de changer le disque de démarrage en basculant de mon fusion drive (2To dont 128Go de SSD) sur un SSD pur sucre (NVMe même !) de 512Go. J'ai mis un nouveau macOS Big Sur dessus avec la suite Adobe et bien sûr mon catalogue LR aussi. C'est un peu plus réactif mais la différence ne saute pas au yeux par rapport au FD.
Donc en résumé, à mon sens le problème vient des éléments suivants comme ça a déjà été évoqué ici et :
  • i5 trop juste, un i7 irait mieux
  • LR toujours pas assez optimisé, pour tirer davantage parti du GPU notamment (la mienne fait 8go) et la lecture (juste la lecture!) de vidéos 4K se met souvent à saccader
  • Et pour couronner le tout évidemment le superbe écran 5K plein de pixels n'arrange rien.

Pour l'instant, on peut attendre un petit mieux avec macOS Monterey peut être mais c'est surtout Adobe qui doit encore bosser (car en effet photo mechanic est bien plus rapide pour le tri).
Si un nouvel iMac (32"?) sort dans le futur proche et qu'il vaut le coup, faudra sûrement songer à prendre un SSD de base et un gros CPU.