Probleme mise en veille (désolé pour le doublon)

tak

Membre junior
26 Octobre 2008
36
0
Bonjour,
Je possède un macbook pro unibody de 2008, depuis mon passage sous lion j'ai un problème étrange.
le mac ne se met plus en veille lorsque je ferme l'écran. La lumière s'allume mais ne se met jamais à clignoter. le disque semble tourner.
Par contre il se met en veille si je ferme l'écran et qu'il n'est pas sur le secteur. Une fois qu'il bascule en veille lumière clignotante, je peux le retrancher sur le secteur et son état reste le même.

J'ai regardé dans les paramètres et je n'ai rien trouvé.

Auriez-vous une idée?
Merci
Tak
 

tak

Membre junior
26 Octobre 2008
36
0
Je complète mon post afin d'être plus précis.
Mon Mac ne rentre plus en veille prolongé lorsque je ferme l'écran ou si je passe par le menu Pomme.
Ceci ne se produit que lorsqu'il est branché sur le secteur. J'ai l'impression que le disque ne s'arrête pas, l'écran devient noir uniquement.
si quelqu'un a une idée.
merci
 

tak

Membre junior
26 Octobre 2008
36
0
Merci, je ne l'avais pas vu celui-la. Mais ces solutions ne marchent pas.
 
Dernière édition:

tak

Membre junior
26 Octobre 2008
36
0
merci pour ton aide.
J'ai refait la manip pour être sûr mais toujours pareil.
Merci
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 124
624
À côté (de ma plaque)
Après, tu peux regarder ce qui s'affiche dans l'utilitaire Console au moment de la mise en veille,
et comparer les messages secteur/batterie.

Tu peux lancer les deux veilles successivement, et regarder tout de suite,
ou faire une recherche dans Tous les messages avec "sleep" dans Chaînes correspondantes.
 

tak

Membre junior
26 Octobre 2008
36
0
quand je regarde dans la console, j'ai l'impression que rien ne se passe lorsque je ferme l'écran et que je suis sur le secteur.
Au contraire sur batterie, j'ai tout de suite la ligne

24/09/11 21:54:15,000 kernel: hibernate image path: /var/vm/sleepimage

Mais je ne comprends pas vraiment ce que je lis :)
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 124
624
À côté (de ma plaque)
Il doit y avoir deux ou trois autres lignes dans les secondes qui suivent la mise en veille.


La sleepimage, c'est l'enregistrement du contenu de la RAM sur le disque dur,
elle sert à restituer les fenêtres ouvertes quand il y a une coupure d'alimentation inopinée.

C'est normal qu'elle s'active à la mise en veille.
Ce qui serait curieux, c'est qu'elle ne le fasse pas uniquement sur secteur. :hein:
 

tak

Membre junior
26 Octobre 2008
36
0
Merci pour l'explication!

Lorsque je ne suis pas sur le secteur.

25/09/11 19:40:16,000 kernel: hibernate image path: /var/vm/sleepimage
25/09/11 19:40:16,000 kernel: sizeof(IOHibernateImageHeader) == 512
25/09/11 19:40:16,000 kernel: Opened file /var/vm/sleepimage, size 4294967296, partition base 0x0, maxio 400000 ssd 0
25/09/11 19:40:16,000 kernel: hibernate image major 14, minor 0, blocksize 512, pollers 5
25/09/11 19:40:16,000 kernel: hibernate_alloc_pages flags 00000000, gobbling 0 pages
25/09/11 19:40:16,000 kernel: hibernate_setup(0) took 0 ms
25/09/11 19:40:16,000 kernel: /drv/ MacModule.cpp:261 powerStateWillChangeTo: flags=4 stateNumber=2
25/09/11 19:40:16,000 kernel: /drv/ MacModule.cpp:266 powerStateWillChangeTo: found flag=kIOPMSleepCapability (4)
25/09/11 19:40:16,000 kernel: 00000000 00000020 NVEthernet::setLinkStatus - not Active
25/09/11 19:40:16,000 kernel: en1: BSSID changed to 0e:76:6b:29:10:48
25/09/11 19:40:16,000 kernel: wlEvent: en1 en1 Link DOWN
25/09/11 19:40:16,000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).
25/09/11 19:40:16,000 kernel: /drv/ MacModule.cpp:261 powerStateDidChangeTo: flags=4 stateNumber=2
25/09/11 19:40:16,000 kernel: /drv/ MacModule.cpp:266 powerStateDidChangeTo: found flag=kIOPMSleepCapability (4)
25/09/11 19:40:29,000 kernel: hibernate_page_list_setall start 0xffffff806592d000, 0xffffff806594c000
25/09/11 19:40:29,000 kernel: hibernate_page_list_setall time: 215 ms
25/09/11 19:40:29,000 kernel: pages 714205, wire 128437, act 206179, inact 4341, spec 178, zf 128, throt 0, could discard act 84630 inact 40247 purgeable 20772 spec 229293
25/09/11 19:40:29,000 kernel: hibernate_page_list_setall found pageCount 339263
25/09/11 19:40:29,000 kernel: IOHibernatePollerOpen, ml_get_interrupts_enabled 0
25/09/11 19:40:29,000 kernel: IOHibernatePollerOpen(0)
25/09/11 19:40:29,000 kernel: writing 337514 pages
25/09/11 19:40:29,000 kernel: encryptStart 226250
25/09/11 19:40:29,000 kernel: encryptEnd 7148f10
25/09/11 19:40:29,000 kernel: image1Size 205782528, encryptStart1 226250, End1 7148f10
25/09/11 19:40:29,000 kernel: encryptStart c43fe00
25/09/11 19:40:29,000 kernel: encryptEnd 228f58e0
25/09/11 19:40:29,000 kernel: PMStats: Hibernate write took 12102 ms
25/09/11 19:40:29,000 kernel: all time: 12102 ms, comp bytes: 1382752256 time: 1805 ms 730 Mb/s, crypt bytes: 490571680 time: 3155 ms 148 Mb/s,
25/09/11 19:40:29,000 kernel: image 579820032, uncompressed 1382752256 (337586), compressed 574715296 (41%), sum1 34324e17, sum2 37783091
25/09/11 19:40:29,000 kernel: wired_pages_encrypted 71912, wired_pages_clear 54848, dirty_pages_encrypted 210826
25/09/11 19:40:29,000 kernel: hibernate_write_image done(0)
25/09/11 19:40:29,000 kernel: sleep
Et je confirme il ne se passe rien si je suis sur le secteur (ou si je passe par le menu Pomme). Par contre si je débranche la veille s'enclenche

25/09/11 20:59:09,000 kernel: IOPMrootDomain: idle cancel
25/09/11 20:59:09,000 kernel: hibernate image path: /var/vm/sleepimage
25/09/11 20:59:09,000 kernel: sizeof(IOHibernateImageHeader) == 512
25/09/11 20:59:09,000 kernel: Opened file /var/vm/sleepimage, size 4294967296, partition base 0x0, maxio 400000 ssd 0
25/09/11 20:59:09,000 kernel: hibernate image major 14, minor 0, blocksize 512, pollers 5
25/09/11 20:59:09,000 kernel: hibernate_alloc_pages flags 00000000, gobbling 0 pages
25/09/11 20:59:09,000 kernel: hibernate_setup(0) took 0 ms
25/09/11 20:59:10,000 kernel: /drv/ MacModule.cpp:261 powerStateWillChangeTo: flags=4 stateNumber=2
25/09/11 20:59:10,000 kernel: /drv/ MacModule.cpp:266 powerStateWillChangeTo: found flag=kIOPMSleepCapability (4)
25/09/11 20:59:10,000 kernel: 00000000 00000020 NVEthernet::setLinkStatus - not Active
25/09/11 20:59:10,000 kernel: en1: BSSID changed to 0e:76:6b:29:10:48
25/09/11 20:59:10,000 kernel: wlEvent: en1 en1 Link DOWN
25/09/11 20:59:10,000 kernel: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).
25/09/11 20:59:10,000 kernel: /drv/ MacModule.cpp:261 powerStateDidChangeTo: flags=4 stateNumber=2
25/09/11 20:59:10,000 kernel: /drv/ MacModule.cpp:266 powerStateDidChangeTo: found flag=kIOPMSleepCapability (4)
25/09/11 20:59:22,000 kernel: hibernate_page_list_setall start 0xffffff806592d000, 0xffffff806594c000
25/09/11 20:59:22,000 kernel: hibernate_page_list_setall time: 207 ms
25/09/11 20:59:22,000 kernel: pages 722643, wire 128843, act 215088, inact 5077, spec 180, zf 864, throt 0, could discard act 82785 inact 41147 purgeable 20376 spec 228283
25/09/11 20:59:22,000 kernel: hibernate_page_list_setall found pageCount 350052
25/09/11 20:59:22,000 kernel: IOHibernatePollerOpen, ml_get_interrupts_enabled 0
25/09/11 20:59:22,000 kernel: IOHibernatePollerOpen(0)
25/09/11 20:59:22,000 kernel: writing 348304 pages
25/09/11 20:59:22,000 kernel: encryptStart 225240
25/09/11 20:59:22,000 kernel: encryptEnd 7231f10
25/09/11 20:59:22,000 kernel: image1Size 206996480, encryptStart1 225240, End1 7231f10
25/09/11 20:59:22,000 kernel: encryptStart c568400
25/09/11 20:59:22,000 kernel: encryptEnd 23ed4080
25/09/11 20:59:22,000 kernel: PMStats: Hibernate write took 11269 ms
25/09/11 20:59:22,000 kernel: all time: 11269 ms, comp bytes: 1426948096 time: 1882 ms 722 Mb/s, crypt bytes: 513247568 time: 3301 ms 148 Mb/s,
25/09/11 20:59:22,000 kernel: image 602751488, uncompressed 1426948096 (348376), compressed 597564240 (41%), sum1 79596b37, sum2 bb41ae59
25/09/11 20:59:22,000 kernel: wired_pages_encrypted 72263, wired_pages_clear 54904, dirty_pages_encrypted 221209
25/09/11 20:59:22,000 kernel: hibernate_write_image done(0)
25/09/11 20:59:22,000 kernel: sleep
Une question si je réinstalle et je récupère ma sauvegarde TimeMachine, je risque de reproduire le problème?

Encore merci pour l'aide.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 124
624
À côté (de ma plaque)
Les deux rapports de la Console n'apportent rien : tout se passe de la même façon, et la veille se fait dans les deux cas.

La sauvegarde TM contient tous tes paramétrages : la restaurer risque de ramener le problème s'il est logiciel.
Et la restaurer sera inutile si le problème est matériel…


Dans Préférences Système > Économies d'énergie > Secteur, je paramètrerais le délai de mise en veille du disque sur une valeur approchant celle de l'écran : ça pourrait suffire, peut-être.
 

tak

Membre junior
26 Octobre 2008
36
0
Dans Préférences Système > Économies d'énergie > Secteur, je paramètrerais le délai de mise en veille du disque sur une valeur approchant celle de l'écran : ça pourrait suffire, peut-être.
C'est déjà le cas, hélas. Perso je cale, je ne vois pas pourquoi ce serait matériel étant donné que la mise en veille se lance lorsqu'il n'est pas sur le secteur et c'est vraiment depuis le passage sur lyon.

En gros soit je fais une réinstallation, soit je tente éventuellement un passage à l'applestore.
 

FrançoisMacG

Pince-fourmis
Club MacG
17 Août 2006
16 124
624
À côté (de ma plaque)
Je cale aussi, et je ne vois pas non plus comment cela pourrait être matériel. :)

Mais je changerais le paramétrage quand même, quitte à revenir aussitôt à la valeur d'origine
= en modifiant ainsi le plist, on récupère parfois la fonction. :zen:
 

Vegus

Membre junior
5 Août 2011
74
3
Suisse - Neuchâtel
Bien le bonjour...

j'ai le même problème et franchement ça devient chiant ! J'ai beau le laisser tourner toute une matinée, il va mettre en veille l'écran et le clavier mais le DD tourne, les ventilateurs aussi, etc. En gros il se met jamais en veille sauf sous batterie :mouais:

J'ai essayé ceci : http://www.macg.co/news/voir/158181/macbook-pro-des-problemes-avec-la-sortie-de-veille

- Supprimé des plist que j'ai vu sur un autre lien

- Vérifié et réparer les permissions

- Passé un coup d'onyx, mais rien rien rien rien:mad:
 

Vegus

Membre junior
5 Août 2011
74
3
Suisse - Neuchâtel
Ahhhh il se met de-nouveau en veille !

Aujourd'hui, j'ai tenté le tout pour le tout, je l'ai démonté... déconnecté de DD et le re-branché, je remets le capot, l'allume et quand la page d'accueille apparaît je tente la suspension d'activité. MIRACLE ! Il se met en veille, je tente une 2ème, 3ème,4ème,....

Voilà ! Peut-être quelque chose de mal branché, personne ne le saura !

Merci !
 

jeepnet

Nouveau membre
18 Juin 2008
2
0
Tak, j'ai exactement le même problème que toi. T'en es ou au final ? As-tu tout réinstallé ?
Ca fait quelques mois que j'ai detecté le problème j'ai fait tout ce qui est dit plus haut sans succés.