10.15 Catalina Problème pendant la mise en veille ou l'arrêt de mon MacBook

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Bonjour à tous.
J'ai un problème à l'extinction automatique de mon MacBook. Je ne sais pas si ça vient de l'installation de Catalina ou si c'est matériel (je sors d'un gros dysfonctionnement qui m'a obligé à changer la nappe et à réinstaller Mac OS).
Je me demande s'il n'y a pas eu un changement dans le options de la gestion d'alimentation qui ne passerait pas sur ma configuration (un MacBook Pro superdrive / non, Retina de Mi-2012). Disque SSD tiers, 16GO de RAM, touches w et x mortes.
Je dirais que c'est l'auto power off qui fait des siennes étant donné que ça arrive lorsque mon Mac va au bout de sa batterie : dans ce cas, il démarre plusieurs fois et se comporte comme si il avait crashé. Ou alors c'est la mise en veille qui ne se fait pas dans de bonnes conditions
Je vous colle ce que renvoie un pmset -g dans le terminal :


Bloc de code:
standbydelaylow      4200
 standby              1
 womp                 0
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 sms                  1
 networkoversleep     0
 disksleep            10
 standbydelayhigh     4200
 sleep                15 (sleep prevented by UserEventAgent, coreaudiod, sharingd)
 autopoweroffdelay    86400
 hibernatemode        3
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         5
 highstandbythreshold 50
 acwake               0
 lidwake              1

Je note également que mon fichier sleepimage ne fait que 1,07 GO, ce qui me paraît étrange, et qu'il s'est depuis assorti d'un swapfile1 et 2 de la même taille.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Salut doc !

La commande pmset -g retourne la configuration d'économie d'énergie correspondant à l'alimentation actuelle du Mac (sur batterie ou sur secteur). Je ne sais donc pas à quelle alimentation correspond ton tableau > ni si le problème que tu évoques se manifeste uniquement sur batterie ou quelle que soit la source d'alimentation.

- tu n'as qu'à passer la commande :​
Bloc de code:
pmset -g custom
  • qui affiche les préférences d'économie d'énergie pour les 2 sources d'alimentation

Poste le double tableau => qu'on ait une vision complète.

----------

automoweroff (sommeil profond) répond à une norme européenne d'économie d'énergie redondante du standby (hibernation). Il vaut mieux que les 2 options ne soient pas activées en parallèle > mais garder standby et désactiver autopoweroff.

- de ce que je lis : après 5' d'inactivité en session l'écran se met en veille > le disque après 10' > le Système après 15'. Des paramètres mieux conformes à une alimentation sur secteur que sur batterie. Je note que 3 facteurs peuvent empêcher le Mac de passer en sommeil-Système : UserEventAgent > coreaudiod > sharingd s'ils sont actifs.​
- le mode d'hibernation est 3 (le défaut sur des portables) : lors du passage du Mac au sommeil-Système --> le contexte de la RAM se trouve sauvegardé à un fichier sleepimage du disque > mais la RAM reste maintenue sous tension tout le temps du sommeil-Système tant qu'il n'y a pas virage à l'hibernation. Une option dévoreuse de batterie si le sommeil-Système s'éternise.​
- le délai de passage à l'hibernation est de 4200" = 1H' 10' de durée de sommeil-Système - que la charge de batterie soit supérieure ou inférieure à 50% au départ (ne parlons pas de l'autopoweroff dont le délai de 24H de sommeil-Système fait que cette option ne s'active jamais).​

Ne sachant pas si ces paramètres correspondent à l'alimentation sur batterie ou sur secteur --> je ne peux pas te conseiller encore de modifications.
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Bloc de code:
Battery Power:
 lidwake              1
 autopoweroff         1
 standbydelayhigh     4200
 autopoweroffdelay    86400
 standbydelaylow      4200
 standby              1
 ttyskeepawake        1
 hibernatemode        3
 highstandbythreshold 50
 hibernatefile        /var/vm/sleepimage
 displaysleep         5
 sleep                15
 acwake               0
 halfdim              1
 sms                  1
 lessbright           1
 disksleep            10
AC Power:
 lidwake              1
 autopoweroff         1
 standbydelayhigh     4200
 autopoweroffdelay    86400
 standbydelaylow      4200
 standby              1
 ttyskeepawake        1
 hibernatemode        3
 highstandbythreshold 50
 hibernatefile        /var/vm/sleepimage
 displaysleep         5
 womp                 0
 networkoversleep     0
 sleep                15
 acwake               0
 halfdim              1
 sms                  1
 disksleep            10

----------------------------------------------------------

Salut Mac0'.
Vous allez peut-être me revoir traîner un peu dans le secteur si les M1 descendent encore un peu leurs prix et que mon MB tient encore un peu (on tient vaguement le choc du distanciel avec un mid-2012 et mon late 2008 auquel j'ai ajouté un clavier externe).

Au dernières nouvelles, il semblerait que j'aie une excuse pour mon côté "rugueux" et l'autre côté un peu compliqué. Je traînais plus sur des forums de powerlifting que d'informatique, ces derniers temps.
Voilà pour les nouvelles

Déjà, donc, je passe un petit :
Bloc de code:
sudo pmset -a autopoweroff 0
Qui semble bien avoir fait ce qu'il est censé faire. J'ai bien un 0 dans les deux configurations possibles.

Pour ce qui est du mode 3, ça bouffe un peu de batterie, certes, mais j'ai bien connu un poervook 12' qui ne consommait rien en mode 0. Mais avec du Intel, je pourrais peut-être affiner, en effet ;)
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Bon : tu as le même paramétrage d'économie d'énergie pour l'alimentation sur batterie et sur secteur.

- est-ce que tu te sers surtout de ton portable sur batterie ? - ou branché au secteur dès que tu es chez toi ?​
- est-ce que tu peux décrire un peu plus en détail ton problème ? - est-ce qu'il s'agit uniquement du comportement du Mac quand tu le pousses en mode nomade jusqu'à épuisement de la charge de batterie ?​
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Je m'en sers des deux manières. En ce moment je ne suis pas trop en mode nomade, mais apparemment ça arrive quand je laisse la batterie se décharger à fond. Je ne sais pas s'il foirait le réveil depuis l'hibrenation ou si ça ne serait pas le conflit dont tu parlais avec l'autopoweroff. Comme je l'ai désactivé, ça va peut-être changer la donne.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
À supposer le mode nomade (sur batterie) : un délai de 1H 10' de temps de sommeil-Système avant passage à l'hibernation > avec l'option 3 activée du mode d'hibernation --> va maintenir 1H 10' la RAM sous tension et par là consommer de la batterie pour rien.

- il y aurait avantage : soit à réduire énormément le délai de passage à hibernation pour éviter la consommation de batterie par la RAM sous tension > soit à activer le mode 25 d'hibernation qui désactive la RAM dès le passage au sommeil-Système et après sauvegarde à la sleepimage. Avec cette dernière option > le réveil du Mac est un peu plus lent > car il faut le temps d'une reconstruction du contexte de la RAM à partir de la sleepimage.​

En résumé : réduire une consommation inutile de batterie par maintien prolongé de la RAM sous tension --> t'éviterait sans doute des pannes d'alimentation en mode nomade.
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Certes. Je teste ça donc :
Bloc de code:
sudo pmset -c hibernatemode 25
Du coup, je saurai vite aussi si c'est l'hibernation qui fait planter le Mac. ;)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Ta commande avec l'option -c (charger) va concerner l'alimentation sur secteur. Si tu es en usage sédentaire du Mac actuellement --> ça va. Veux-tu rétrécir aussi le délai de sommeil-Système avant l'hibernation ?
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Quel con! Pas étonnant que ça n'a pas hiberné, du coup.
Donc on a :
Bloc de code:
sudo pmset -c hibernatemode 3
sudo pmset -b hibernatemode 25

Tu parles du standbydelay ?
Je me demandais : si le mode d'hibernation est mis sur 3 ça joue, mais pas s'il est sur 25, ou je me trompe ?

J'ai mis stanbydelay à 0 pour le mode batterie.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Tu pourrais éditer ainsi :
Bloc de code:
sudo pmset -b standbydelayhigh 300 standbydelaylow 300
  • si tu veux déduire les délais (batterie +50% ou -50%) à 300 secondes = 5'. Ou toute autre valeur comptée en secondes ici.

Tu peux redémarrer une fois ensuite => pour que les instructions soient prises en charge par le kernel.
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
A priori ça passe aussi ?
sudo pmset -b standbydelay 300

----------------------------------------------------

Bon ! Apparemment c'est le passage en hibernation qui ne se fait pas. On est bien d'accord que dans ce cas on n'a plus de loupiote du tout ?
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
standby est l'instruction d'activation ou désactivation de l'hibernation. Elle ne supporte que 2 valeurs associées : 0 (désactivé) vs 1 (activé). standbydelayhigh & standbydelaylow sont les instructions de délai (de temps de sommeil-Système) avant passage à l'hibernation > selon que la charge de batterie est supérieure ou inférieure à 50%. Elles supportent respectivement toute valeur exprimée en secondes. Elles ne sont valides qu'en association avec un standbydelay 1 (activé).

- je pense que la led d'éclairage sur la tranche de ton Mac doit s'éteindre dès le passage en sommeil-Système (sleep) > avant l'hibernation. Si elle reste éclairée --> c'est que le Mac ne passe pas en sommeil-Système. Ce qui proscrit du même coup la possibilité de l'hibernation > dont la condition préalable est l'état de sommeil-Système. Le délai d'inactivité en session avant passage au sommeil-Système est une valeur exprimée en minutes. 15' actuellement chez toi. Mais si tu rabats le couvercle de ton Mac --> alors tu forces le passage immédiat au sommeil-Système (sleep) en outrepassant le délai de 15' valable en cas de couvercle laissé levé.​
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
J'ai fait une petite édition de mon 1er § précédent > où je parlais de standbydelay. standbydelay est une instruction invalide dans les nouveaux OS (apfs) supportant les spécifications standbydelayhigh & standbydelaylow (comme le tien). Elle n'est valide que dans les anciens OS qui ignoraient cette dualité d'options fonction de la charge de la batterie.

- donc : tu as standby 1 ou 0 > et si standby 1 (hibernation activée) --> tu as standbydelayhigh & standbydelaylow avec telle ou telle valeur en secondes.​
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Tout est bon.
Je ne vois que trois solutions :
1 - La nouvelle nappe (j'ai changé une ancienne nappe du SSD avec une autre, de la même marque, la première ayant visiblement rendu l'âme).
2. Le passage à l'APFS. Il me semble que j'avais déjà ce problème après une première installation de Catalina. Ca pourrait être ou un bug dû à Catalina ou le fait que je sois en APFS (j'avais un Mojave sous HFS+ jusqu'ici, l'APFS m'occasionnant des problèmes de démarrage lent, problèmes que je n'ai plus, mais j'ai celui-là à la place).
3. Le disque qui rend l'âme

On pourrait imaginer aussi une sleepimage corrompue.
 
Dernière édition par un modérateur:

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
C'est fait. Et toujours pas d'hibernation. Hier l'ordi est allé au bout et ça a donné ce que ça donne d'habitude maintenant : l'ordinateur démarre, se coupe, puis redémarre.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Fais le test suivant (sur batterie) -->

- ce soir > batterie à 100% > tu rabats le couvercle du portable pour forcer le sommeil-Système direct. Tu le rallumes demain matin > et tu passes la commande :​
Bloc de code:
pmset -g log | grep "due"
  • qui va extraire des logs d'événements touchant la gestion de l'énergie --> tout ce qui touche aux réveils (ou crypto-réveils) du Mac de l'état de sommeil > en indiquant leurs causes

Poste le tableau obtenu (ou du moins un extrait significatif si c'est trop long). On saura ce qui s'est passé entre le rabattement du couvercle et son relèvement. Par ailleurs : indique quel est le % de batterie une fois le Mac réveillé le lendemain.
 

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Bloc de code:
2021-08-08 01:38:00 +0200 Sleep                   Entering Sleep state due to 'Clamshell Sleep': Using Batt (Charge:100%) 26522 secs
2021-08-08 09:00:02 +0200 Wake                    Wake from Standby [CDNVA] : due to RTC/Alarm Using BATT (Charge:100%) 14 secs   
2021-08-08 09:00:16 +0200 Sleep                   Entering Sleep state due to 'Clamshell Sleep': Using Batt (Charge:94%) 9056 secs
2021-08-08 11:31:12 +0200 Wake                    Wake from Standby [CDNVA] : due to EC.LidOpen/Lid Open Using BATT (Charge:94%)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 742
26 358
Forêt de Fontainebleau
Ton Mac manifestement est bien passé en sommeil-Système au rabattement du couvercle (à 1H 38' aujourd'hui) pour une durée de plus de 7H 30'.

- à 9H il y a eu un réveil de l'hibernation (bien attestée par l'expression : wake from standby) pendant 14 secondes > dû à un obscur RTC/Alarm Using BATT que je n'interprète pas. Ces 14" te coûtent 6% de charge de batterie qui passe de 100% => 94% !​
- il y a une nouvelle période de sommeil hibernatif pendant 2H 51' de 9H à 11H 31' - heure à laquelle tu réveilles ton Mac par relèvement du couvercle. Aucun perte de batterie ici.​

On apprend en bref : que tu es un couche tard => lève tard quand tu es en vacances que ton Mac passe bien en sommeil-Système (sleep) viré à l'hibernation (standby) suite au rabat du couvercle. Et que la batterie ne subit aucune perte sauf pour le cas du RTC/Alarm que je n'interprète pas.
 
  • Haha
Réactions: Sly54

Le docteur

Membre expert
Club MacG
8 Février 2008
6 126
727
53
Tu ne penses pas que les 6% sont perdus plutôt pendant la nuit (ce qui serait cohérent pour un Macintel, malheureusement)et que le RTC/alarm Using BATT aurait coïncidé plutôt avec une mise à jour de la batterie.
J'ai eu le clignotement toute la nuit, de mémoire. J'aurais tendance à penser qu'il ne s'est pas mis en hibernation.