Problème (ré)installation imprimante Canon PIXMA MG2550

elisep

Membre confirmé
7 Octobre 2014
13
0
Bonjour !
J'ai acheté fin août une imprimante Canon PIXMA MG2550 (connectée par USB) pour mon MacBook Pro. Dans la boîte un CD était fourni avec un driver pour Windows seulement. J'avais donc téléchargé les pilotes nécessaires sur le site de Canon comme c'était indiqué dans le manuel et mon imprimante était installée sans problème, imprimait et scannait.
Il y a peu de temps (fin septembre il me semble), Apple a sorti une MAJ pour les logiciels d'imprimantes dont mon modèle Canon. Problème : depuis que j'ai installé cette MAJ, mon imprimante n'est plus installée sur mon ordinateur et impossible de la réinstaller. Le modèle se trouve bien dans la liste sortie par Apple récemment (http://support.apple.com/kb/HT3669?viewlocale=fr_FR) mais quand j'essaie de passer par Préférences Système pour l'installer, soit le système ne trouve pas de gestionnaire et me dit d'en sélectionner un (sauf que je n'en ai pas dans mon ordi), soit il trouve le gestionnaire "MG2500 series" mais au moment de le télécharger il me dit qu'il n'est pas disponible depuis le serveur Apple. J'ai lu beaucoup de choses et j'ai tout fait comme il faut (je fais bien "MAJ de logiciels" avant de connecter l'imprimante et d'essayer de l'installer etc) mais ça ne marche toujours pas. Si je télécharge les pilotes sur le site de Canon directement ça ne fonctionne pas non plus, l'app Canon IJ Printer Utility me dit "Aucune imprimante disponible" quand je l'ouvre alors que l'imprimante est bien connectée, chargée en papier et en encre ...
Ça fait beaucoup d'informations mais je suis un peu dépassée, je n'ai pas d'imprimante depuis plusieurs semaines et je n'en ai pas payée une pour avoir une simple photocopieuse. Si je ne trouve pas de solution à mon problème je songe à la revendre vu qu'elle est quasi-neuve pour m'en acheter une qui ait une meilleure comptabilité avec Mac. Ce forum est un peu mon dernier espoir. :(
Merci d'avance !
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 705
5 211
Là-haut

elisep

Membre confirmé
7 Octobre 2014
13
0
Comment dire ... J'ai l'impression qu'on est proche mais c'est pas encore ça non plus ! Je m'explique : j'ai installé le fichier qui venait du site Apple, puis j'ai installé (j'avais déjà essayé avant) le pilote CUPS qui vient de chez Canon. L'app IJ Printer Utility me dit toujours qu'aucune imprimante n'est disponible et si j'essaie d'ajouter l'imprimante via PréfSytème, il ne trouve pas de gestionnaire pour l'imprimante. Le problème ne vient sûrement pas du câble puisque l'ordi reconnait l'imprimante.
Là où je dis qu'on s'approche, c'est que via PréfSystème, j'ai essayé d'ajouter moi-même un gestionnaire pour l'imprimante en allant un peu fouiller dans ce que les pilotes ont installé. J'ai donc cliqué sur mon disque, puis Bibliothèque > Printers > PPDs > Contents > Ressources > CanonIJMG2500series.ppd.gz . Le fichier a une apparence de fichier zip du coup je l'ai "décompressé", ça nous donne un fichier .ppd et j'ai choisi ça dans le champ "Choisissez un gestionnaire" de PréfSystème. Il s'affiche bien dans le champ (alors que d'autres fichiers ne s'affichaient pas" et il correspond bien aux modèles MG2550 donc jusque là tout va bien. Par contre, ça me dit que le logiciel ne provient pas du fabricant et que je ne pourrait peut-être pas utiliser toutes les fonctionnalités de l'imprimante. Je clique quand même sur "Ajouter", là la configuration commence puis s'arrête et un message d'erreur apparaît disant qu'il y a eu une erreur dans la configuration et le message "bad file descriptor".
Ça fait encore beaucoup d'infos, je ne sais pas si on progresse ou pas du tout ...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 597
5 596
Comment dire ... J'ai l'impression qu'on est proche mais c'est pas encore ça non plus ! Je m'explique : j'ai installé le fichier qui venait du site Apple, puis j'ai installé (j'avais déjà essayé avant) le pilote CUPS qui vient de chez Canon.

L'app IJ Printer Utility me dit toujours qu'aucune imprimante n'est disponible et si j'essaie d'ajouter l'imprimante via PréfSytème, il ne trouve pas de gestionnaire pour l'imprimante. Le problème ne vient sûrement pas du câble puisque l'ordi reconnait l'imprimante.

Là où je dis qu'on s'approche, c'est que via PréfSystème, j'ai essayé d'ajouter moi-même un gestionnaire pour l'imprimante en allant un peu fouiller dans ce que les pilotes ont installé.

J'ai donc cliqué sur mon disque, puis Bibliothèque > Printers > PPDs > Contents > Ressources > CanonIJMG2500series.ppd.gz . Le fichier a une apparence de fichier zip du coup je l'ai "décompressé", ça nous donne un fichier .ppd et j'ai choisi ça dans le champ "Choisissez un gestionnaire" de PréfSystème.

Il s'affiche bien dans le champ (alors que d'autres fichiers ne s'affichaient pas" et il correspond bien aux modèles MG2550 donc jusque là tout va bien. Par contre, ça me dit que le logiciel ne provient pas du fabricant et que je ne pourrait peut-être pas utiliser toutes les fonctionnalités de l'imprimante.

Je clique quand même sur "Ajouter", là la configuration commence puis s'arrête et un message d'erreur apparaît disant qu'il y a eu une erreur dans la configuration et le message "bad file descriptor".

Ça fait encore beaucoup d'infos, je ne sais pas si on progresse ou pas du tout ...
Il va falloir apprendre à structurer tes textes, car franchement c'est imbuvable pour suivre. :siffle:

Ensuite, Moonwalker te demande de télécharger/tester un fichier qui vient de chez Apple, et toi tu fais complètement autre chose.

Pourquoi aller fouiller là ou il ne faut pas ? Ce genre de fichier .gz est bien un fichier compressé, mais c'est l'installateur qui s'occupe de tout. De plus, tu ne sais même pas ce que tu fais.

Désolé, de te reprendre, mais franchement si tu veux aggraver encore le problème, tu vas finir pas mettre le souk. Contente toi de faire ce qui est demandé en mentionnant ce qu'il se sera passé. A prendre au second degré et avec le sourire. :zen:
 

elisep

Membre confirmé
7 Octobre 2014
13
0
Je sais bien, désolée ...
J'ai fait ce qu'il a dit, le souci c'est qu'une fois les fichiers installés il ne se passe strictement rien. Le programme d'installation me dit que l'installation est terminée mais il ne se passe rien d'autre. C'est pour ça que je suis partie chercher, parce que j'aimerais comprendre ce que font ces installations, à part prendre de la place sur mon disque. Donc si tu as une solution/explication je suis preneuse.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 705
5 211
Là-haut
Réinitialise le système d’impression (dans les Préférences Système>Imprimante et scanners, clic droit sur la colonne de gauche).

Télécharge et installe le «*combo*» des gestionnaires d’impression Canon (le lien support.apple.com).

Redémarre ton Mac. Fais une réparation des autorisations (via l’utilitaire de disque).

Branche ton imprimante et essaye de nouveau via les Préférences Système.

---------- Nouveau message ajouté à 19h49 ---------- Le message précédent a été envoyé à 19h45 ----------

Je soupçonne le nouveau driver CUPS (11.7.1.0) d’être responsable des problèmes.

A noter qu’il y a aussi sur le site de Canon l’ancien driver CUPS (10.84.1.0) soit une version en deçà de ce que propose Apple dans son «*combo*» (10.89.1.0).

Peut-être virer à la main le 11.7.1.0 : /Library/Printers/Canon à la corbeille.

Et réinstaller la version précédente.
 
Dernière édition:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 597
5 596
Edit : flute je me suis trompé de lien.
 
Dernière édition:

elisep

Membre confirmé
7 Octobre 2014
13
0
Je viens de faire tout ce que tu as dit, ça ne marche toujours pas. PréfSystème ne propose toujours aucun gestionnaire.

Pour le pilote dispo sur le site de Canon ça ne marche pas non plus, j'ai déjà essayé tous les pilotes qu'ils proposent sur la page, en ayant déjà réinitialisé plusieurs fois le système d'impression et réparé les autorisations.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 597
5 596
A

Anonyme

Invité

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 597
5 596
Je crois bien que c'est celui-là qui coince justement ?
 

elisep

Membre confirmé
7 Octobre 2014
13
0

Impossible de l'installer parce qu'il est pour OS X 10.6.

---------- Nouveau message ajouté à 17h22 ---------- Le message précédent a été envoyé à 17h20 ----------

Essaye avec ce driver > Canon PIXMA MG2550 : http://www.canon.fr/Support/Consume...ilid=tcm:79-1090978&os=OS X v10.9&language=FR

En plus du driver, il y a tous les logiciels pour piloter ta machine

Le problème viendrait de celui-ci justement, et je l'ai aussi déjà essayé. :(
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 705
5 211
Là-haut
Puisque cela a fonctionné, cela doit encore fonctionner.

La mise à jour a cassé quelques chose. Quoi ? et surtout où ?

La solution radicale => réinstallation de l’OS. En clean, c’est-à-dire effacement du volume système et pas de réimport automatique. Tout à la main.

Variante douce => récupération Time Machine d’une sauvegarde avant la mise à jour fatale (si disponible).

Autre option (la plus délicate mais c’est celle que je choisirais si c’était ma machine) : suppression à la main des éléments Canon.

Cela suppose de savoir ce qui a été installé et où.

Pour cela il faut explorer les pkg d’installation. Par exemple à l’aide de Suspicious Package.

Faire le ménage dans ~/Bibliothèque/Preferences mais aussi dans /private/var/db/receipts

A noter que les fichiers .bom de ce dossier receipts agissent comme des pkg et permettent via Quicklook et Suspicious Package de savoir quoi a été installé où.

A toi de voir.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 705
5 211
Là-haut

elisep

Membre confirmé
7 Octobre 2014
13
0
J'avoue que la réinstallation de l'OS me fait un peu peur ... Je vais essayer le coup de la sauvegarde TimeMachine, normalement je dois en avoir une.

Si jamais je décidais de supprimer les éléments Canon à la main, qu'est-ce qu'il faudrait faire ensuite ?

---------- Nouveau message ajouté à 17h44 ---------- Le message précédent a été envoyé à 17h27 ----------

Petite question : Apple parle de la version 10.89.1.0, or sur le site de Canon on ne trouve que la version 10.84.1.0. Est-ce que le problème ne pourrait pas venir de là ?

---------- Nouveau message ajouté à 17h55 ---------- Le message précédent a été envoyé à 17h44 ----------

Bon le coup de restaurer une sauvegarde précédente ne fonctionne pas, l'installation via PréfSystème progressait un peu plus qu'actuellement mais juste à la fin ça me disait qu'aucun logiciel adapté n'avait été trouvé.
J'ai supprimé manuellement les éléments Canon après je ne maîtrise pas suffisamment OSX pour savoir si j'ai fait ça correctement.
 
A

Anonyme

Invité
Petite question : Apple parle de la version 10.89.1.0, or sur le site de Canon on ne trouve que la version 10.84.1.0. Est-ce que le problème ne pourrait pas venir de là ?

Pilote d'imprimante CUPS MG2500 series v. 10.84.1.0 c'est le nom de la version ... tout comme le Pilote d'imprimante CUPS MG2500 series v. 11.7.1.0

Si tu est passé(e) par la suppression de tout ce qui touche à ton imprimante, il faudra débrancher ton imprimante du port USB, éteindre l'imprimante, ensuite réparer les permissions. Une fois fait, je remettrais l'imprimante en relation (re-connectée au port USB) avec ta machine, rallumer l'imprimante et attendre un peu, normalement ton OS devrait aller chercher lui-même le bon driver sur le net, parfois il faut passer par la fonction mise à jour de logiciels.

Je dis bien normalement :confused:

PS : ton imprimante devrait apparaître dans les préférences système, Imprimantes et Scanners
 
Dernière édition par un modérateur:

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 705
5 211
Là-haut
J'avoue que la réinstallation de l'OS me fait un peu peur ... Je vais essayer le coup de la sauvegarde TimeMachine, normalement je dois en avoir une.

Si jamais je décidais de supprimer les éléments Canon à la main, qu'est-ce qu'il faudrait faire ensuite ?

---------- Nouveau message ajouté à 17h44 ---------- Le message précédent a été envoyé à 17h27 ----------

Petite question : Apple parle de la version 10.89.1.0, or sur le site de Canon on ne trouve que la version 10.84.1.0. Est-ce que le problème ne pourrait pas venir de là ?

---------- Nouveau message ajouté à 17h55 ---------- Le message précédent a été envoyé à 17h44 ----------

Bon le coup de restaurer une sauvegarde précédente ne fonctionne pas, l'installation via PréfSystème progressait un peu plus qu'actuellement mais juste à la fin ça me disait qu'aucun logiciel adapté n'avait été trouvé.
J'ai supprimé manuellement les éléments Canon après je ne maîtrise pas suffisamment OSX pour savoir si j'ai fait ça correctement.

Pour la différence de version, il suffit de regarder la date. octobre 2013 pour le 10.84.1.0, mai 2014 pour le 10.89.1.0.

Si je suis ton récit, c’est du moment où tu as appliqué la mise à jour de Apple, donc 10.89.1.0, que tes ennuis ont commencé.

Le nouveau driver CUPS, 11.7.1.0, compatible Yosemite, n’a rien arrangé.


L’idée serait donc, une fois le ménage fait des éléments Canon installés, de recommencer comme aux premiers jours en prenant le driver cups 10.84.1.0 plutôt que les éléments distribués par Apple.

[Là, je diffère de ce que propose Albert qui à mon sens, et de ce que j’ai compris de ton récit, te re-conduira dans tes problèmes.]

Mais il s’agit de chirurgie de haute précision, car il y a des choses qui appartiennent à l’OS qu’il ne faut pas toucher. La clean install c’est plus long mais moins difficile. A toi de voir.
 
Dernière édition:

elisep

Membre confirmé
7 Octobre 2014
13
0
Pilote d'imprimante CUPS MG2500 series v. 10.84.1.0 c'est le nom de la version ... tout comme le Pilote d'imprimante CUPS MG2500 series v. 11.7.1.0

Si tu est passé(e) par la suppression de tout ce qui touche à ton imprimante, il faudra débrancher ton imprimante du port USB, éteindre l'imprimante, ensuite réparer les permissions. Une fois fait, je remettrais l'imprimante en relation (re-connectée au port USB) avec ta machine, rallumer l'imprimante et attendre un peu, normalement ton OS devrait aller chercher lui-même le bon driver sur le net, parfois il faut passer par la fonction mise à jour de logiciels.

Je dis bien normalement :confused:

PS : ton imprimante devrait apparaître dans les préférences système, Imprimantes et Scanners

Ça avait marché, juste après avoir reconnecté l'imprimante, OS X m'a proposé d'installer le logiciel, il l'a fait mais après rien ne s'était passé et l'imprimante n'apparaissait toujours pas dans PréfSystème.

Je vais renettoyer puis essayer de réinstaller la version 10.84.1.0
 
A

Anonyme

Invité
Dernière édition par un modérateur: