Problème récurrant : démarrage sans extension - maj inversée

greekette

Nouveau membre
29 Août 2012
5
0
Bonjour

j'ai fait le tour des forums et je me suis rendue compte que le problème rencontré et plus que récurrent. Sauf que j'hésite encore : est-ce un court circuit ou un simple problème technique.

Donc pour résumé j'ai un macbook 13'' qui démarre sans cesse sans extension. Lors de la visualisation du clavier je me suis rendue compte que les touches majuscules sont en permanence enfoncées.

Avant de prendre rdv au Genius Bar et donner le reste de mon argent à Apple je veux être sûre d'avoir fait mon maximum.

Merci encore.
 

esimport

Membre émérite
Club MacG
28 Mars 2012
828
18
Sélestat
www.esimport.fr
si cela ne fonctionne pas, il faudra changer le clavier (pas nécessairement tout le topcase, juste le clavier):


6-DECOLLER-CLAVIER-MACBOOK-1024x682.jpg


clavier-macbook-unibody-13-a1278.jpg
 
Dernière édition:

greekette

Nouveau membre
29 Août 2012
5
0
Merci pour toutes ces donnée. J'ai nettoyé les touches ( j'en ai pété une d'ailleurs) rien n'y fait.
Plus de virgule Safari qui s'invente des nouvelles fonctions ••• (je viens de découvrir que je n'ai plus de point de suspensions mais points en gras ^^) Je ne peux plus sélectionner qu'un élément mais plusieurs.

Avez d'autres idées à me préconiser ?

Merci encore avoir une réponse même négative dans ces moments me témoigne de votre considération !
 

otgl

Membre émérite
20 Février 2012
879
18
J'ai nettoyé les touches ( j'en ai pété une d'ailleurs) rien n'y fait.

Ce n'est pas aussi facile de péter une touche. Si ça se trouve, c'est juste les petits supports sous la touche qui sont mal emboîtés. Essaie de les emboîter l'un dans l'autre.

Plus de virgule Safari qui s'invente des nouvelles fonctions ••• (je viens de découvrir que je n'ai plus de point de suspensions mais points en gras ^^) Je ne peux plus sélectionner qu'un élément mais plusieurs.

Tous les problèmes que tu décris sont liés aux touches Maj. C'est les touches Maj qui permettent de sélectionner plusieurs éléments plutôt qu'un seul. C'est elles aussi qui transforment les signes de ponctuation en caractères spéciaux.

Avez d'autres idées à me préconiser ?

Si tu as nettoyé les touches Maj, alors le problème vient du clavier lui-même. Je ne vois que deux solutions.

La première : tu fais remplacer ton clavier dans un magasin spécialisé.

La deuxième : tu branches un clavier externe à ton MacBook. (Un clavier USB, donc. Même un clavier pour Windows fait l'affaire.) Et une fois branché, tu désactives le clavier interne. Pour désactiver le clavier interne, lancer Applications > Utilitaires > Terminal, et taper:

Bloc de code:
sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/

Pour réactiver, redémarrer l'ordinateur, ou taper:

Bloc de code:
sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTCKeyboard.kext/
 

greekette

Nouveau membre
29 Août 2012
5
0
Merci à vous deux. Pour la touche j'ai cassé la petite encoche en plastique pas trop grave j'en achèterai une autre.

Je vais aller au genius bar pour qu'il s'en occupe j'ai hâte d'entendre le prix ...

Je suppose que je mettre cette discussion en résolue ?

Une dernière avant tout : ce serait donc dû à un court circuit ??? Mais comment j'ai renversé dessus enfin c'est peut-être dû à la condensation ?

Merci encore les amis !
 

greekette

Nouveau membre
29 Août 2012
5
0
Merci pour toutes vos réponses, du jour au lendemain (enfin en 1mois et demi) tout semble être redevenu normal.

Ca me l'avait déjà fait auparavant, mais pas très longtemps avant de rebuguer. J'attends peut-être que le bug réapparaîtra.

Je me demande si ce n'est pas dû à mes minis enceintes aimantées que j'ai déposé par mégarde sur le clavier pendant un certain temps.

Enfin bon je n'en sais strictement rien. Dans tous les cas si cela reprend je ferais changer mon clavier. Merci pour ton site Esimport je pense me fournir chez toi.

Merci encore
 

ltpv

Nouveau membre
15 Août 2014
1
0
58
Bonjour et merci pour ces explications. J'ai tenté de désactiver le clavier en suivant la procédure indiquée. Une fois que j'ai tapé la ligne de codes, j'ai fait "entrer" et là il m'a demandé de confirmer par un mot de passe. Or, d'une part, je n'ai pas de mot de passé et d'autre part, je ne peux entrer aucun caractère, ni avec le clavier principal, ni avec le clavier USB.
Une idée ?
 

vox90

Membre junior
16 Juin 2005
30
1
53
BOnjour
j'ai le meme problème suite a un thé tombé sur le clavier...

Il n reconnaît pas le mot de passe et je ne peux donc pas accéder a la session, je ne pourrais donc pas rentrer la ligne de commande pour un clavier usb.

Et pour info la caps lock est eteinte et ne s'allume plus; du coup je me demande si ce n'est pas elle qui a vrillé...

Un idée pour contourner tout ça?

Merci