Problème restauration suite instal foireuse

DealM

Membre junior
11 Février 2009
88
7
Périgueux
Bonjour à tous.

Avant toute chose, meilleurs vœux !

Je commence l'année sur un petit couac.
J'ai jailbreaké mon iPhone 5 juste après Noël suite à la sortie surprise d'Evasion.
J'ai d'abord installé quelques applications sans problème (barrel, zeppelin, bitesms) et j'ai voulu m'attaquer à la personnalisation en installant winterboard.
J'ai voulu tenter 01s-7PRIME qui semblait ne fonctionner que partiellement, mais j'ai pensé que c'était peut-être pas encore compatible avec iOS 7. J'ai quand même essayer 01s-7PRIME iWidget et là ça a commencé à déconner.
À chaque respring ou reboot, l'iPhone switchait à chaque fois en mode sans échec (message me l'indiquant quand je tentais de faire descendre le panneaux des notifications, fond d'écran gris, plus de logo zeppelin).
J'ai désinstallé les tweaks et winterboard, même problème.
Ayant déjà du des soucis de jailbreak par le passé, j'ai fait une sauvegarde iCloud et une sauvegarde iTunes dans la foulée, et un réinit des réglages et contenu pour pouvoir faire une restauration.
Malheureusement, à la restauration iCloud, à la fin du chargement, j'ai eu l'erreur suivante : "Restauration de la sauvegarde impossible". Ni une ni deux, je fais la restauration iTunes, et idem, à la fin du chargement de la restauration, message suivant : "iTunes n'a pas pu restaurer l'iPhone « DealPhone » car une erreur s'est produite.".
J'ai alors tenté de configurer mon iPhone comme un nouvel iPhone, rejailbreaké, réinstallé les tweaks fautifs et supprimés aussitôt pensant qu'un fichier foireux serait peut-être resté quelque part, mais même problème.
J'ai essayé un tweaks de nettoyage (icleaner je crois), même problème.
J'ai essayé, de restaurer depuis une sauvegarde de la veille, avant le problème, même problème.
Je vous avouerais que "repartir à zéro" m'enchante franchement qu'à moitié, alors si vous avez une idée, je suis preneur.

Merci d'avance.

DealM
 

DealM

Membre junior
11 Février 2009
88
7
Périgueux
En continuant à chercher, j'ai vu que j'avais une autre sauvegarde iTunes mais qui date de février 2013...
Bon, j'ai quand même essayé et là ça fonctionne ! Du coup j'en viens à me dire que les sauvegardes faites une fois l'iPhone jailbreaké sont corrompues.
Vous auriez connaissance de cas similaires ? J'ai essayé de fouillé un peu sur divers forums, mais je n'ai pas trouvé de problème identique. Pour le coup je pense que le seul moyen de m'en sortir serait de "réparer" ma sauvegarde iTunes... Reste à savoir comment faire ^^
 

DealM

Membre junior
11 Février 2009
88
7
Périgueux
En fouillant sur le support d'Apple j'ai vu une manipulation qui consistait à vider le dossier lockdown, mais toujours le même soucis.
Sur un autre forum, ils parlent de iPhone Backup Extractor. J'ai récupéré l'ensemble des rep sur mon mac depuis la sauvegarde iTunes que j'avais faite juste avant le drame.
Est-ce que vous pensez qu'en les reposant en vrac en ssh ça pourrait fonctionner ?
 

DealM

Membre junior
11 Février 2009
88
7
Périgueux
Arf oui, mais les problèmes que j'avais eu datent de l'iPhone 1, à l'époque où cydia était la seule alternative pour avoir des applications supplémentaires. Après ça je n'avais plus eu aucun soucis. Jusqu'à ce que...
 

DealM

Membre junior
11 Février 2009
88
7
Périgueux
Bon, j'ai réussi a récupérer les sms via ssh, ainsi que les photos les déposant directement dans /private/var/mobile/Media/DCIM.
L'iPhone a mis du temps à recréer les miniatures mais elles sont toutes là.
Par contre je ne peux plus prendre de nouvelles photos, du moins elles ne s'enregistrent pas.
Ce qui est surprenant, c'est que je les vois pourtant bien dans /private/var/mobile/Media/DCIM/.MISC/Incoming avec des noms à rallonges, mais elles ne se mettent pas dans la pellicule.
Je peux récupérer tout le reste autrement (contacts, calendriers etc par iCloud, et je reprendrai les appli une par une), il ne me reste plus que cette étape, alors si une bonne âme passe dans les parages, je suis preneur ;)

---------- Nouveau message ajouté à 21h23 ---------- Le message précédent a été envoyé à 19h58 ----------

Le problème venait des autorisations, tout bêtement ! J'ai tilté quand un ami m'a envoyé un mms et que l'image ne se récupérait pas.
J'ait tout passé en 777 et tout fonctionne.
Mon iPhone reste complètement vierge du coup, mais j'ai au moins pu récupérer les infos essentielles, le reste sera récupérable.
Merci à vous.