Publication impossible iweb 09 et FTP OVH

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
Bonjour,

Je souhaite mettre en ligne un site internet créé avec iweb 09 via un FTP mais je n'y arrive pas.
Je suis chez OVH. J'avais un ancien site internet. J'ai d'abord essayé de "publier" le nouveau, en ayant oublié qu'il y avait l'ancien. Ca n'a pas marché. J'ai donc été sur Filezilla, et supprimé tous les fichiers présents sur le FTP (mon ancien site ne fonctionne donc plus). J'ai ensuite essayé de "publier" le site créé avec iweb via ce même FTP, mais ça ne marche toujours pas, ça upload pendant un bout de temps (site avec vidéos) et quand c'est publié, je tape mon adresse type :
www.lenomdemonsite.com, et ça ne marche pas, je tombe sur une page blanche, avec un message d'erreur.
J'ai même essayé de faire glisser/déposer dans le FTP via Filezilla mais ça ne marche toujours pas.
Comment faire ?

Quand je "publie" via un dossier sur mon mac, j'arrive à naviguer sur mon site via mon ordinateur. J'aimerai voir si la publication marche sur internet, afin d'obtenir de l'aide pour la création du site (pour montrer aux internautes mes problèmes) mais je tombe sur un message d'erreur et une page blanche... Help pleaaaaase !!!
 

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
J'aimerai vous montrer une capture d'écran mais je ne sais pas comment uploader une image sur le forum...
 

twinworld

Vétéran
Club MacG
4 Janvier 2007
7 818
409
49
Lausanne et Paris
j'ai essayé une fois de publier directement depuis iWeb sur OVH. J'avais des problèmes de droit d'accès. Finalement, je sauve dans un dossier. iWeb génère un fichier index.html et un dossier dans lequel il met toutes les pages. Je glisse le fichier et le dossier dans le dossier public_html de mon hebergeur, et ça marche.

---------- Nouveau message ajouté à 18h24 ---------- Le message précédent a été envoyé à 18h22 ----------

J'aimerai vous montrer une capture d'écran mais je ne sais pas comment uploader une image sur le forum...
vous sauvez votre image sur un espace d'hébergement du genre Casimage. Vous recopier le lien avec la balise qui donne quelque chose du type
dans le corps du texte de MacG.
 

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
100505063617846211.png
[/URL][/IMG]

100505063847389859.png
[/URL][/IMG]

Merci infiniment pour ces conseils précieux.
Voici ce que ça donne (voir photo)
 

twinworld

Vétéran
Club MacG
4 Janvier 2007
7 818
409
49
Lausanne et Paris
vous avez essayé de mettre le chemin d'accès pour éditer dans public_html ?
 

twinworld

Vétéran
Club MacG
4 Janvier 2007
7 818
409
49
Lausanne et Paris
mais avant, avec votre ancien site, vous mettiez où vos fichiers dans OVH ? à la racine de l'espace ?
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
trouvé totalement par hasard sur Google en cherchant carrément autre chose

Ils sont bien chez OVH, ils font même des tutos pour les mecs et les filles qui utilisent iWeb

http://guides.ovh.com/iWeb

y'a même un truc où c'est marqué "(ceci est très important)" qu'il serait bien de lire.

PS : Il faut toujours le mode d'emploi sinon on risque de passer à côté de détails intéressants.
 

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
trouvé totalement par hasard sur Google en cherchant carrément autre chose

Ils sont bien chez OVH, ils font même des tutos pour les mecs et les filles qui utilisent iWeb

http://guides.ovh.com/iWeb

y'a même un truc où c'est marqué "(ceci est très important)" qu'il serait bien de lire.

PS : Il faut toujours le mode d'emploi sinon on risque de passer à côté de détails intéressants.

Merci, je pense que ça va m'aider, mais comment créer le chemin "www" dans filezilla ?
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
Oubliez FileZilla pour l'instant. Ce tuto concerne la publication directe d'iWeb sur un serveur d'OVH et uniquement iWeb (en aucun cas FileZilla).
Ajouter www à chemin/repertoire dans les réglages de publication d'iWeb et publiez votre site

---------- Nouveau message ajouté à 19h32 ---------- Le message précédent a été envoyé à 19h01 ----------

Je viens de remarquer sur votre capture que votre nom de site n'est pas valable (jamais /).
Veuillez donnez un nom de site correcte dans les réglages de publication
/ n'est pas valable. Par défaut ça s'appelle Site donner un nom simple sans espace et sans accents
il faut bien le choisir ce nom apparait sur les adresses de vos pages.
 

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
Super merci infiniment pour tous ces précieux conseils, j'arrive à publier.
Dès que c'est terminé, je vous mets le lien.
Par contre, savez-vous pourquoi je n'arrive plus à accéder à mon serveur ?
 

Abbaruzi

Membre junior
11 Novembre 2009
39
0
35
Hello, voici ENFIN une premièr ébauche du site grâce à votre aide :

www.ugovenel.com

sur certains navigateurs, il y a 2x l'adresse web du site vers le bas. Comment l'enlever ?
C'est bizarre:mouais: