• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

[QXP] Indice de débordement

Antiphon

Membre d’élite
Club MacG
25 Mars 2001
1 532
17
Région parisienne
Les spécialistes de QuarkXPress pourraient-ils me venir en aide ? Je suis en train de finaliser la mise en page d'un livre de 272 pages dont les différents articles ont été importés de Word. Pour l'un d'entre eux, malgré de nombreux essais, celui-ci est suivi de ce que l'on appelle dans leur jargon un "indice de débordement", autrement dit un carré rouge marqué d'une croix qui indique que le texte déborde le bloc où il a été placé. Mon problème est le suivant. À la fin du texte concerné, il maintient toujours une page blanche, que je ne parviens pas à supprimer, même en allant dans Page>Supprimer..., avec en bas à gauche le fameux carré... Comment se fait-il qu'il puisse y avoir débordement dans un bloc de texte continu ? Je veux dire que, si j'étais en train de composer une affiche et qu'il marque cet indice, je comprendrais. Mais là, il devrait créer automatiquement après le nombre de pages nécessaire pour que cela tienne ? En plus, j'ai bien vérifié, tout l'article est passé, il n'y a semble-t-il rien de perdu... Comment puis-je supprimer cette page avec son indice de débordement ?... Merci d'avance !
 

jeep2nine

Membre d’élite
7 Mai 2003
1 003
125
54
Brest
Tu peux toujours te placer à la fin de ton texte "visible", sélectionner ensuite tout le texte qui déborde en tapant "pom+option+shift+flèche vers le bas" et supprimer cette sélection.... tu devrais ensuite pouvoir virer la page en trop.
Si ça marche, ça résoudra ton problème mais pas ça ne t'avancera pas beaucoup sur la cause de ce problème, mais bon, il arrive un moment où on se contente largement de résoudre uniquement le problème ;)
 

Antiphon

Membre d’élite
Club MacG
25 Mars 2001
1 532
17
Région parisienne
Génial ! Il m'a fallu quelques instants pour traduire, donc c'est Pomme/Commande+Alt/Casserole+Shift/Majuscule+Flèche vers le bas, mais effectivement ça sélectionne le carré et pas le texte après, que l'on peut supprimer avec la touche de retrait, et ensuite on supprime la page normalement... Merci beaucoup !
 

jeep2nine

Membre d’élite
7 Mai 2003
1 003
125
54
Brest
Antiphon a dit:
Génial ! Il m'a fallu quelques instants pour traduire, donc c'est Pomme/Commande+Alt/Casserole+Shift/Majuscule+Flèche vers le bas,
Tu peux le dire comme ça aussi ;)
 

Antiphon

Membre d’élite
Club MacG
25 Mars 2001
1 532
17
Région parisienne
Au cas où l'on ne s'en serait pas rendu compte, je suis débutant avec QuarkXPress, même si je commence à bien m'en sortir. J'ai un autre problème. J'ai une page de livre dans laquelle j'ai créé un bloc d'image qui est un fichier .tiff présent sur mon Bureau. Lorsque j'imprime cette page, mon imprimante (HP LaserJet 1320) devient folle, elle débit une page à la seconde, avec parfois une ligne de signes incohérents. Je suis obligé de l'éteindre en force pour l'arrêter, d'enlever le tuner pour retirer les feuilles bloquées, etc. Alors je me suis penché sur le mode d'emploi, enfin un livre que j'ai acheté sur Quark, pour voir ce qui clochait. Il doit falloir lui indiquer que l'on veut imprimer et du texte et des images, non ? Donc dans Fichier>Imprimer, je me suis plutôt penché sur l'onglet OPI, mais "OPI active" y est coché, ainsi que "TIFF : Inclure images" et "EPS : Inclure images". Je me suis donc tourné vers l'onglet Options où, quoique je fasse, le menu déroulant OPI reste grisé... Déjà, est-ce que je regarde du bon côté ? Pourquoi est-il continuellement grisé ? Est-ce de là que vient mon problème ? Merci d'avance.
 

jeep2nine

Membre d’élite
7 Mai 2003
1 003
125
54
Brest
Antiphon a dit:
Au cas où l'on ne s'en serait pas rendu compte, je suis débutant avec QuarkXPress, même si je commence à bien m'en sortir. J'ai un autre problème. J'ai une page de livre dans laquelle j'ai créé un bloc d'image qui est un fichier .tiff présent sur mon Bureau. Lorsque j'imprime cette page, mon imprimante (HP LaserJet 1320) devient folle, elle débit une page à la seconde, avec parfois une ligne de signes incohérents. Je suis obligé de l'éteindre en force pour l'arrêter, d'enlever le tuner pour retirer les feuilles bloquées, etc. Alors je me suis penché sur le mode d'emploi, enfin un livre que j'ai acheté sur Quark, pour voir ce qui clochait. Il doit falloir lui indiquer que l'on veut imprimer et du texte et des images, non ? Donc dans Fichier>Imprimer, je me suis plutôt penché sur l'onglet OPI, mais "OPI active" y est coché, ainsi que "TIFF : Inclure images" et "EPS : Inclure images". Je me suis donc tourné vers l'onglet Options où, quoique je fasse, le menu déroulant OPI reste grisé... Déjà, est-ce que je regarde du bon côté ? Pourquoi est-il continuellement grisé ? Est-ce de là que vient mon problème ? Merci d'avance.
Par défaut, XPress imprime le texte ET les images... La fonction OPI est utilisée surtout dans de grosses structures où les quadris haute déf sont stockées sur un serveur et où le maquettiste a à sa disposition des version basses définition pour faire sa mise en page. Le changement se fait au moment de l'impression : XPress subtilise les versions basse définition au profit des hautes déf stockées sur le serveur OPI.
Dans ton cas, je ne pense pas que la "folie" de ton imprimante vienne de là... Maintenant, à savoir d'où elle vient, là je sèche un peu :confused:
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?
Antiphon a dit:
Génial ! Il m'a fallu quelques instants pour traduire, donc c'est Pomme/Commande+Alt/Casserole+Shift/Majuscule+Flèche vers le bas, mais effectivement ça sélectionne le carré et pas le texte après
Si, si ! c'est le texte qui déborde du bloc qui est ainsi sélectionné. Donc, ce n'est pas une solution des plus judicieuses dans le sens où tu as peut-être viré du texte qu'il ne fallait pas... :mouais:

Antiphon a dit:
que l'on peut supprimer avec la touche de retrait, et ensuite on supprime la page normalement... Merci beaucoup !
Bon, j'avoue qu'il y a un truc qui m'a échappé dans ton post à la base, mais surtout fais gaffe de ne pas avoir eu du texte supprimé par ta procédure.
Conseil important : toujours coché la case sauvegarde auto dans les prefs, ça peut toujours servir en pareil cas en allant rechercher une version antérieure au cas où tu aurais fait une fausse manip.
Ensuite, avant de faire ce que tu as fait, crée simplement un bloc texte sur le marbre (= la table de montage, ou en marge) et chaîne le bloc à carré rouge au nouveau bloc afin de voir exactement ce qui déborde ; parfois, ce n'est que des retours paragraphes à la con que certains utilisateurs de Word foutent à tout bout de champs (ça me fait penser au sketch de Chevalier et Laspalès « Le train pour Pau » quand il s'excite sur son tampon... :D ). Dans ce cas, tu peux évidemment virer le débordement sans souci en supprimant ces retours et aussi le bloc de vérif que tu as créé (!). Mais dans le cas où tu aurais encore du texte, il te faudrait ou bien rajouter une page ou plus pour contenir ce texte, ou bien jouer sur la force de corps, l'échelle horizontale ou tout autre artifice pour faire tenir le texte dans son bloc.

A noter aussi que les prefs par défaut d'X-Press sont très mal foutues !!! Il faut corriger (sans aucun doc ouvert) les C&J en mettant des tolérances d'espace beaucoup plus serrées : 80-100-120, p. ex.

Bon, ceci dit vite fait. :up:
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?
Antiphon a dit:
J'ai une page de livre dans laquelle j'ai créé un bloc d'image qui est un fichier .tiff présent sur mon Bureau. Lorsque j'imprime cette page, mon imprimante (HP LaserJet 1320) devient folle, elle débit une page à la seconde, avec parfois une ligne de signes incohérents.
Attention que les tiff doivent *toujours* être sur fond non transparent ! :up:
Je ne sais pas si c'est le problème que tu as eu. Vérifie toujours... Si tu as la version 6, il y a dans le menu script un script qui permet de modifier tous les fonds d'images en y appliquant une couleur (donc identique pour tous les blocs d'images, c'est-à-dire à n'utiliser que quand on est sûr qu'il n'y a aucune image qui doit avoir un fond de couleur ou un eps qui doit avoir un fond transparent !!!).
 

monoeil

Membre d’élite
Club MacG
4 Septembre 2004
1 236
217
dans la Lune, code postal infini
CMYK a dit:
A noter aussi que les prefs par défaut d'X-Press sont très mal foutues !!! Il faut corriger (sans aucun doc ouvert) les C&J en mettant des tolérances d'espace beaucoup plus serrées : 80-100-120, p. ex.
Bien joué ! Eh oui, on peut se demander pourquoi 80-120-250, indices fixés par défaut ; le résultat est parfois très moche.
 

monoeil

Membre d’élite
Club MacG
4 Septembre 2004
1 236
217
dans la Lune, code postal infini
Antiphon a dit:
...autrement dit un carré rouge marqué d'une croix qui indique que le texte déborde le bloc où il a été placé. Mon problème est le suivant. À la fin du texte concerné, il maintient toujours une page blanche, que je ne parviens pas à supprimer...

A tout hasard, est-ce qu'il ne s'agirait pas d"un "saut de page", représenté (en affichant les caractères invisibles) par une flèche tournée vers le bas ?
Ceci s'obtient avec pomme+touche validation (la plus à droite et en bas du pavé numérique, à côté de virgule et sous le signe +).
Cette manip permet donc de faire chasser tout le texte qui lui succède vers le prochain bloc, en cas de blocs chaînés. S'ils ne le sont pas, eh bien on tombe dans ton cas, le texte paraît occulté !

Une solution de vérif a été proposée par CMJN : chaîner vers un autre bloc.
La définitive : surligner ce saut de page et le supprimer ;), enfin si il s'agit effectivement de cela !
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?
monoeil a dit:
By the way, t'es équipé d'une fonction intégrée de traduction ? C'est pas CMJN mais CMYK mon petit nom. Et en fait, c'est une faute de frappe au moment de mon enregistrement parce que le K doit être remplacé par S (initiale de mon nom qui veut dire noir en allemand :up: ). C'est donc au choix CMYK (celui qui est repris en défintive dans mes posts), CMJS (en français :) ) ou CMYS (en anglais ; c'est en fait le pseudo que j'utilise sur un forum amerloque :cool: ).
Enfin, il fallait le savoir !
 

monoeil

Membre d’élite
Club MacG
4 Septembre 2004
1 236
217
dans la Lune, code postal infini
CMYK a dit:
By the way, t'es équipé d'une fonction intégrée de traduction ? C'est pas CMJN mais CMYK mon petit nom. Et en fait, c'est une faute de frappe au moment de mon enregistrement parce que le K doit être remplacé par S (initiale de mon nom qui veut dire noir en allemand :up: ). C'est donc au choix CMYK (celui qui est repris en défintive dans mes posts), CMJS (en français :) ) ou CMYS (en anglais ; c'est en fait le pseudo que j'utilise sur un forum amerloque :cool: ).
Enfin, il fallait le savoir !
Oh désolé, te voici donc écorché vif :D
Promis CMJS, à l'avenir et pour être en repérage, je veillerai à faire K du Schwartz auquel tu tiens ;)
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 605
258
59
Antiphon a dit:
À la fin du texte concerné, il maintient toujours une page blanche, que je ne parviens pas à supprimer, même en allant dans Page>Supprimer..., avec en bas à gauche le fameux carré...
Tu peux aussi désactiver l'insertion automatique de pages à la fin du document (ça fait aussi partie des préférences mal réglées par défaut dans XPress), ça t'évitera cette page blanche qui ne veut pas être supprimée (mais ça n'empêchera pas le texte en trop et l'indicateur de dépassement)

J'ai un copain qui n'arrête pas de me répéter que la première chose à faire avec un logiciel c'est régler les préférences... et surtout avec XPress ou rien n'est réglé correctement par défaut... : je vais finir par le croire !!!
(il affirme que c'est aussi indispensable que de régler le siège et les rétroviseurs quand tu t'installes dans une voiture...)
 

teo

Vénérable sage
Club MacG
14 Novembre 2000
10 524
3 089
Paris XXe
www.last.fm
La première chose à faire: régler les préfs, quitter XPress, faire une copie des préfs quelque part et puis voilà, là on peut commencer à bosser. Si un jour les préfs se corrompent, virer le fichier, le remplacer par le backup et on recommence direct.
Enfin, c'est ce que je fais en général sur mon poste de travail; si c'est pas le mien, je backupe celle du poste et je remplace en partant. A moins qu'on me dise explicitement de ne pas changer les préfs.
J'aime pas trop les blocs auto et les retraits dans les blocs textes, les repères derrière, l'habillage auto, les couleurs RVB, etc. :D Je sais pas vous...
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 605
258
59
teo a dit:
J'aime pas trop les blocs auto et les retraits dans les blocs textes, les repères derrière, l'habillage auto, les couleurs RVB, etc. :D Je sais pas vous...
... et les césures avec 2 lettres après, les réglages d'espaces fait n'importe comment, les marges à 1/2 pouce, les blocs texte avec un fond blanc, le "blanc variable" à 50%, le plan de montage à 100%, les exposants à 100% qui décalent toute la ligne, etc. : après l'install, je perds 1/4 d'heure à le régler avant de pouvoir commencer à l'utiliser.
À noter quand même que les repères derrières ont disparu avec la version 4, les retraits sont à 0pt dans la 6... : ça s'améliore, lentement...

Chez Adobe, c'est quand-même moins pire !!! :)
 

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?

CMYK

Membre d’élite
Club MacG
25 Novembre 2004
1 551
39
Ici, pourquoi ?

teo

Vénérable sage
Club MacG
14 Novembre 2000
10 524
3 089
Paris XXe
www.last.fm
claude72 a dit:
... et les césures avec 2 lettres après, les réglages d'espaces fait n'importe comment, les marges à 1/2 pouce, les blocs texte avec un fond blanc, le "blanc variable" à 50%, le plan de montage à 100%, les exposants à 100% qui décalent toute la ligne, etc. : après l'install, je perds 1/4 d'heure à le régler avant de pouvoir commencer à l'utiliser.
À noter quand même que les repères derrières ont disparu avec la version 4, les retraits sont à 0pt dans la 6... : ça s'améliore, lentement...

Chez Adobe, c'est quand-même moins pire !!! :)
Oui, j'en ai omis ou oublié un paquet de ces préfs, quand je donnais des cours Xpress, c'était quasiment 3-4 h uniquement dessus pourtant :D C'est cool, les élèves après une heure un peu perdus, finissaient par se prendre au jeu et les cours suivants, c'était nettement plus agréable, ils avaient compris, ils allaient chercher l'info et n'attendaient pas qu'on la leur donne. Ils avaient déjà une bonne vu d'ensemble sur les possibilités du logiciel. Que ce soit iTunes ou Xpress, les Préfs sont si importantes.
 

Lucio

Membre junior
17 Mars 2004
46
0
Paris
Antiphon a dit:
Les spécialistes de QuarkXPress pourraient-ils me venir en aide ? Je suis en train de finaliser la mise en page d'un livre de 272 pages dont les différents articles ont été importés de Word. Pour l'un d'entre eux, malgré de nombreux essais, celui-ci est suivi de ce que l'on appelle dans leur jargon un "indice de débordement", autrement dit un carré rouge marqué d'une croix qui indique que le texte déborde le bloc où il a été placé. Mon problème est le suivant. À la fin du texte concerné, il maintient toujours une page blanche, que je ne parviens pas à supprimer, même en allant dans Page>Supprimer..., avec en bas à gauche le fameux carré... Comment se fait-il qu'il puisse y avoir débordement dans un bloc de texte continu ? Je veux dire que, si j'étais en train de composer une affiche et qu'il marque cet indice, je comprendrais. Mais là, il devrait créer automatiquement après le nombre de pages nécessaire pour que cela tienne ? En plus, j'ai bien vérifié, tout l'article est passé, il n'y a semble-t-il rien de perdu... Comment puis-je supprimer cette page avec son indice de débordement ?... Merci d'avance !
S'il y une page qui se recrée en permanence il y presque sûrement un débordement de texte. Tu n'aurais pas 2 blocs texte superposés ? Mais pour comprendre il faudrait m'envoyer ton doc, autrement c'est difficile.