iMac Ralentissement au démarrage de mon iMac.

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
Bonjour à tous,
je possède un iMac 27' acheté au début de l'année 2014, avec une fusion drive de 1To. Il a toujours très bien fonctionné, n'a jamais été très rempli.
Mais un problème de lenteur est apparu depuis juillet 2019. Je vous refais l'historique en vous précisant que je ne suis pas du tout un expert, notamment dans tout ce qui est langage informatique lié aux termes techniques...

- en juillet 2019 : la lenteur se constatait à l'utilisation du mac, la roue multicolore apparaissaient régulièrement, puis au fur et à mesure c'était le démarrage du mac qui devenait lui aussi lent, pour finalement un jour rester bloqué sur la pomme.
J'ai donc contacté l'assistance Apple qui m'a fait faire un tas de manipulations qui n'ont servi à rien. Aussi, je n'avais pas pris l'habitude de sauvegarder mes données et j'en avais de très importantes (photos et vidéos de mariage par exemple...).
Suite à un 2nd appel, je tombe sur un superviseur qui finalement s'est occupé de mon cas et m'a suivi tout du long. Il m'a fait installé macOS sur un disque dur externe pour que je puisse aller récupérer mes données sur le disque dur du mac. Ce que j'ai pu faire. Puis, il m'a fait réinstaller masOC sur mon appareil après l'avoir formaté. Tout marchait bien par la suite, jusqu'à la mise à jour Catalina vers octobre/novembre.

- en novembre 2019, ça recommence, a priori à cause de la mise à jour Catalina, mais sans réelle certitude. Cette fois-ci, je pouvais quand même atteindre ma session. Et je constatais que si je m'identifiais sur une autre session, il n'y avait aucun problème de lenteur. Donc, était-ce peut-être une problème de session ?
L'assistance Apple me fait faire toujours les mêmes manipulations qui ne changent rien... Finalement, puisque ça fonctionnait très bien sur l'autre session, ils m'ont fait migrer mes données sur cette seconde session et écraser l'autre pour en faire de la deuxième ma nouvelle session. Ce n'était pas propre, mais ça avait le mérite de fonctionner et me dépanner, car je ne voulais pas formater à nouveau. Cela n'a pas duré très longtemps...

- en décembre 2019 : ça recommence, encore sans raison. Je rappelle l'assistance, pour rien encore... Mais finalement, ils me conseillent de formater et de réinstaller proprement Catalina ou une version antérieure. J'ai choisi de retenter avec Catalina. Tout fonctionnait à nouveau très bien, jusqu'à la semaine dernière, donc presque 6 mois.

- fin mai 2020 : encore lenteur, au démarrage, puis à l'ouverture de session, puis en utilisant le mac, avec quelques fois des redémarrages car problème rencontré... En revanche, cette fois-ci, en ouvrant une autre session, le problème est encore là. Pour info, la veille tout allait bien et j'avais utilisé iMovie, vlc et Photos, donc rien d'extraordinaire...

Je ne sais plus quoi en penser, il faudrait que je dépose mon mac dans un magasin, mais je n'ai pas envie de risquer de payer un bras pour une réparation... Un ami me parle d'un problème avec le fusion drive, je lis plein de trucs sur cela ou sur le processeur... je ne comprends pas tout et je n'arrive plus à savoir ce qu'il faut réellement faire. Par ailleurs, mes données sauvegardées sont toujours stockées dans le disque dur externe sur lequel j'avais installé macOS et que j'avais utilisé la première fois pour récupérer les données. Dès que je démarre sur ce disque, tous fonctionne normalement.

Aussi pour que vous sachiez, j'utilise surtout mon mac pour de la bureautique, quelques fois visionner de photos ou vidéos, mais rien de très lourd. J'ai arrêté les téléchargements depuis juillet, car on m'avait dit que c'était peut-être un virus chopé sur un site...

Je vous remercie infiniment par avance pour l'aide que vous pourrez m'apporter. A bientôt.
Rudy
 

peyret

Vétéran
Club MacG
22 Octobre 2001
5 392
2 075
71
43110
www.editionsduroure.com
Bonjour à tous,
je possède un iMac 27' acheté au début de l'année 2014, avec une fusion drive de 1To. Il a toujours très bien fonctionné, n'a jamais été très rempli.
Mais un problème de lenteur est apparu depuis juillet 2019. Je vous refais l'historique en vous précisant que je ne suis pas du tout un expert, notamment dans tout ce qui est langage informatique lié aux termes techniques...

- en juillet 2019 : la lenteur se constatait à l'utilisation du mac, la roue multicolore apparaissaient régulièrement, puis au fur et à mesure c'était le démarrage du mac qui devenait lui aussi lent, pour finalement un jour rester bloqué sur la pomme.
J'ai donc contacté l'assistance Apple qui m'a fait faire un tas de manipulations qui n'ont servi à rien. Aussi, je n'avais pas pris l'habitude de sauvegarder mes données et j'en avais de très importantes (photos et vidéos de mariage par exemple...).
Suite à un 2nd appel, je tombe sur un superviseur qui finalement s'est occupé de mon cas et m'a suivi tout du long. Il m'a fait installé macOS sur un disque dur externe pour que je puisse aller récupérer mes données sur le disque dur du mac. Ce que j'ai pu faire. Puis, il m'a fait réinstaller masOC sur mon appareil après l'avoir formaté. Tout marchait bien par la suite, jusqu'à la mise à jour Catalina vers octobre/novembre.

- en novembre 2019, ça recommence, a priori à cause de la mise à jour Catalina, mais sans réelle certitude. Cette fois-ci, je pouvais quand même atteindre ma session. Et je constatais que si je m'identifiais sur une autre session, il n'y avait aucun problème de lenteur. Donc, était-ce peut-être une problème de session ?
L'assistance Apple me fait faire toujours les mêmes manipulations qui ne changent rien... Finalement, puisque ça fonctionnait très bien sur l'autre session, ils m'ont fait migrer mes données sur cette seconde session et écraser l'autre pour en faire de la deuxième ma nouvelle session. Ce n'était pas propre, mais ça avait le mérite de fonctionner et me dépanner, car je ne voulais pas formater à nouveau. Cela n'a pas duré très longtemps...

- en décembre 2019 : ça recommence, encore sans raison. Je rappelle l'assistance, pour rien encore... Mais finalement, ils me conseillent de formater et de réinstaller proprement Catalina ou une version antérieure. J'ai choisi de retenter avec Catalina. Tout fonctionnait à nouveau très bien, jusqu'à la semaine dernière, donc presque 6 mois.

- fin mai 2020 : encore lenteur, au démarrage, puis à l'ouverture de session, puis en utilisant le mac, avec quelques fois des redémarrages car problème rencontré... En revanche, cette fois-ci, en ouvrant une autre session, le problème est encore là. Pour info, la veille tout allait bien et j'avais utilisé iMovie, vlc et Photos, donc rien d'extraordinaire...

Je ne sais plus quoi en penser, il faudrait que je dépose mon mac dans un magasin, mais je n'ai pas envie de risquer de payer un bras pour une réparation... Un ami me parle d'un problème avec le fusion drive, je lis plein de trucs sur cela ou sur le processeur... je ne comprends pas tout et je n'arrive plus à savoir ce qu'il faut réellement faire. Par ailleurs, mes données sauvegardées sont toujours stockées dans le disque dur externe sur lequel j'avais installé macOS et que j'avais utilisé la première fois pour récupérer les données. Dès que je démarre sur ce disque, tous fonctionne normalement.

Aussi pour que vous sachiez, j'utilise surtout mon mac pour de la bureautique, quelques fois visionner de photos ou vidéos, mais rien de très lourd. J'ai arrêté les téléchargements depuis juillet, car on m'avait dit que c'était peut-être un virus chopé sur un site...

Je vous remercie infiniment par avance pour l'aide que vous pourrez m'apporter. A bientôt.
Rudy

Salut,

Pour en savoir peut-être plus ? peux-tu faire un rapport Etrecheck
tuto pour poster un rapport
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
46 123
8 012
Nancy___
Il y a bien quelques soucis même si pour l'instant, c'est vague…
Bloc de code:
Problèmes graves :
  Les choses qui figurent ici ont besoin de correction immédiate.
  Paniques du noyau - Cet ordinateur signale des paniques du noyau. C’est peut-être à cause d’échec de matériel.
  Logiciel semble causer de problèmes avec la performance - Le logiciel semble causer de problèmes avec la performance.



Tu dois activer le Trim :
Bloc de code:
Informations des disques :
  disk0 - APPLE SSD SD0128F 121.33 Go (SSD - TRIM : Non)



Tu peux ajouter de la RAM :
Bloc de code:
 8 RAM - Possible de l’augmenter
    BANK 0/DIMM0 - 4 Go DDR3 1600 
    BANK 1/DIMM0 - 4 Go DDR3 1600 
    BANK 0/DIMM1 - Vide 
    BANK 1/DIMM1 - Vide



Débits corrects pour ton FusionDrive :
Bloc de code:
Performance :
  Charge du système : 1.57 (1 min) 1.46 (5 min) 1.30 (15 min)
  Vitesse nominale d’E / S : 0.30 Mo/s
  Système de fichiers : 112.74 seconds
  Vitesse écrire : 296 Mo/s
  Vitesse lire : 715 Mo/s



Les soucis :
Bloc de code:
Événements du diagnostic (7-30 dernier jours) :
  2020-06-02 12:06:58 cloudd Plantage (39 fois)
    Exécutable : /System/Library/PrivateFrameworks/CloudKitDaemon.framework/Support/cloudd
    Détails :
      dyld3 mode
      *** Terminating app due to uncaught exception 'NSGenericException', re
      ason: 'Error executing SQL: "pragma journal_mode = WAL" (266) - errcod
      e:010a, msg:"disk I/O error", size: 122880, path:/Users/***/Library/Ca
      ches/*/CloudKitMetadata, fs:913140928512/1121118199808'
      terminating with uncaught exception of type NSException
      abort() called
 
  2020-06-02 08:23:49 photolibraryd Plantage (2 fois)
    Exécutable : /System/Library/PrivateFrameworks/PhotoLibraryServices.framework/Versions/A/Support/photolibraryd
    Détails :
      dyld3 mode
 
  2020-06-01 22:37:47 Panique du noyau (10 fois)
 
  2020-06-01 13:55:34 WindowServer Plantage (4 fois)
    Exécutable : /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer
    Détails :
      StartTime:2020-05-28 16:34:20
      GPU:NV
      MetalDevice for accelerator(0x322b): 0x7fbbd7f06028 (MTLDevice: 0x113e
      da000)
      IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P2@1/IOPP/GFX
      0@0/NVDA,Display-A@0/NVDA
 
  2020-05-29 10:38:00 OtherUsersStorageExtension Usage du processeur élevé (2 fois)
    Exécutable : /System/Library/PrivateFrameworks/StorageManagement.framework/PlugIns/OtherUsersStorageExtension.appex/Contents/MacOS/OtherUsersStorageExtension


Je pense que ton OS est bancal, parce que je n'ai rien vu de bizarre par ailleurs (OK, Flash que tu peux virer).

Fais une bonne sauvegarde de tes données, puis installe la combo 10.15.5.
Si la situration ne s'est pas améliorée, pour moi tu es bon pour une clean install.
 

peyret

Vétéran
Club MacG
22 Octobre 2001
5 392
2 075
71
43110
www.editionsduroure.com
Paniques du noyau - Cet ordinateur signale des paniques du noyau. C’est peut-être à cause d’échec de matériel.
  • 2020-05-29 10:38:00 OtherUsersStorageExtension Usage du processeur élevé (2 fois)
Exécutable : /System/Library/PrivateFrameworks/StorageManagement.framework/PlugIns/OtherUsersStorageExtension.appex/Contents/MacOS/OtherUsersStorageExtension
 
Dernière édition:

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
Merci beaucoup ! Je ne comprends pas tous les termes... du coup, j'ai quelques questions... :)

Tu dois activer le Trim :
C'est quoi la Trim ? Et à quoi ça sert ?

Je pense que ton OS est bancal, parce que je n'ai rien vu de bizarre par ailleurs (OK, Flash que tu peux virer).
Je pense déjà avoir viré Flash, mais il apparait encore...

Et du coup, il n'apparait pas de problème matériel ?
Aussi, apparemment il faut que j'active certaines sécurités Apple, je fais comment ?
Merci !!
 

peyret

Vétéran
Club MacG
22 Octobre 2001
5 392
2 075
71
43110
www.editionsduroure.com
Aussi, apparemment il faut que j'active certaines sécurités Apple, je fais comment ?

Prefs system / securité confidentialité / ... cocher la case "coupe feu activé" Capture d’écran 2020-06-02 à 16.26.21.png

et pour activer le trim : https://www.skymac.org/Univers-Appl...r-booster-la-vitesse-de-vos-SSD-non-Apple.htm

et pour "flash" , je laisserai de peur qu'une application "Adobe" l'utilise.....
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
46 123
8 012
Nancy___
C'est quoi la Trim ? Et à quoi ça sert ?
Ouvre l'application qui s'appelle Terminal.

Tu copies colles la commande suivante :

Bloc de code:
sudo trimforce enable

Tu valies par Enter.
S'il y a un message d'erreur, copie le et poste le ici.



Je pense déjà avoir viré Flash, mais il apparait encore...
Va sur le site d'Adobe, il y a un désinstallateur.



Et du coup, il n'apparait pas de problème matériel ?
C'est à voir…
 
  • J’aime
Réactions: peyret

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
D'accord, je fais tout ça et reviens vers vous après alors ! Merci.

Et sinon, on m'avait aussi conseillé de changer mon disque dur en un simple SSD de 128 Go et d'ajouter un HDD externe pour y stocker mes fichiers en y mettant la "petite maison", mon dossier utilisateur quoi... On m'a dit que mes problèmes pouvaient être liés à un dysfonctionnement du FD...
Du coup, j'ai lu quelques forums et donc pensé à "casser" le FD pour utiliser uniquement le SSD pour le système et un HDD externe pour les données, afin d'éviter de dépenser trop...
Mais peut-être que ça na rien à voir avec mes problèmes...
Qu'en pensez-vous ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
46 123
8 012
Nancy___
Ton FD a l'air assez rapide, je trouverai dommage de le casser.

Par contre, une clean install (tout effacer, formater le disque, tout réinstaller à la main…) devrait permettre de voir si les problèmes sont toujours là (dans quel cas on peut penser à un souci hardware), ou pas.

Mais l'inconvénient de la clean install, c'est que ça prend du temps…
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 754
4 315
je possède un iMac 27' acheté au début de l'année 2014
Il y a des interrogations, du moins moi, j'en ai...
iMac (27 pouces, fin 2013)
...c'est un iMac 27" de 2013 acheté avec l'option FusionDrive. Oui mais pourquoi...
disk0 - APPLE SSD SD0128F 121.33 Go (SSD - TRIM : Non)
...le Trim a été désactivé ? Quelle que soit le type de mise à jour, ça ne peut en aucun cas se désactiver, tu as dû forcément faire une mauvaise manipulation.
disk2s1 - Macintosh HD
1.12 To (Partagé - 11.01 Go utilisés, 914.17 Go disponsible, 912.94 Go libre)
Ce n'est en aucun cas un manque de capacité qui provoque cette lenteur.
Pas engagée] OneDrive Launcher (Microsoft Corporation - installé 2020-05-20)
Élément d’ouverture moderne
/Applications/OneDrive.app/Contents/Library/LoginItems/OneDrive Launcher.app
Ce n'est pas non plus One Drive de Microsoft qui provoquerait un ralentissement en synchronisation vu le peu de données !
Time Machine :
Time Machine pas configuré !
De même que Time Machine qui n'est pas activé.

Les taux d'écritures/lectures sont corrects. Il n'y a pas grand chose à dire sur la gestion de la mémoire, mais, il y a quand même une petite occupation anormale que l'on retrouve en fin de rapport. Eh oui, Adobe Flash Player est une purge, donc poubelle, de toutes façons il disparaît complètement en fin d'année.
Logiciels du système :
macOS Catalina 10.15.4 (19E287)
Tu n'es pas à jour, la dernière version en cours est la 10.15.5 en sachant quelle inclut une mise à jour de sécurité. Ton problème est bien en fin de rapport...
Événements du diagnostic (7-30 dernier jours) :
2020-06-02 12:06:58 cloudd Plantage (39 fois)
Exécutable : /System/Library/PrivateFrameworks/CloudKitDaemon.framework/Support/cloudd
Détails :
dyld3 mode
*** Terminating app due to uncaught exception 'NSGenericException', re
ason: 'Error executing SQL: "pragma journal_mode = WAL" (266) - errcod
e:010a, msg:"disk I/O error", size: 122880, path:/Users/***/Library/Ca
ches/*/CloudKitMetadata, fs:913140928512/1121118199808'
terminating with uncaught exception of type NSException
abort() called

2020-06-02 08:23:49 photolibraryd Plantage (2 fois)
Exécutable : /System/Library/PrivateFrameworks/PhotoLibraryServices.framework/Versions/A/Support/photolibraryd
Détails :
dyld3 mode

2020-06-01 22:37:47 Panique du noyau (10 fois)

2020-06-01 13:55:34 WindowServer Plantage (4 fois)
Exécutable : /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer
Détails :
StartTime:2020-05-28 16:34:20
GPU:NV
MetalDevice for accelerator(0x322b): 0x7fbbd7f06028 (MTLDevice: 0x113e
da000)
IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P2@1/IOPP/GFX
0@0/NVDA,Display-A@0/NVDA

2020-05-29 10:38:00 OtherUsersStorageExtension Usage du processeur élevé (2 fois)
Exécutable : /System/Library/PrivateFrameworks/StorageManagement.framework/PlugIns/OtherUsersStorageExtension.appex/Contents/MacOS/OtherUsersStorageExtension
...il y a des fichiers dyld3 qui sont des fichiers système et qui sont corrompus. Malheureusement, il y en a aussi concernant les pilotes de la carte graphique Nvidia !

Dans un premier temps, active le Trim, tu as la commande dans le Terminal en réponse #10. Tu supprimes Adobe Flash Player. Ensuite ne fais pas tout de suite la mise à jour de macOS Catalina 10.15.5, non tu redémarres en maintenant les touches cmd+R jusqu'à voir une fenêtre avec 4 outils. Tu sélectionneras Réinstaller macOS, tu sélectionneras Macintosh HD et tu suis les étapes d'installation.

Ça remettra d'aplomb les fichiers système corrompus sans toucher à tes fichiers, dossiers, données personnelles, logiciels et réglages. Vois ce qu'il se passe une fois que c'est fait. Si tout redevient à la normale, alors fais dans la foulée la mise à jour de macOS Catalina 10.15.5. Si ton système continue à générer le même problème, il te faudra sauvegarder tes données personnelles dans un autre disque dur USB et faire une installation propre incluant obligatoirement un formatage du disque dur interne (FusionDrive).
 

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
Merci pour vos réponses !

Quand je clique sur "informations système", il est indiqué que le trim est activé... Pourtant je n'ai encore rien fait... Bizarre non ?

IMG_2960.JPG
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 754
4 315
Quand je clique sur "informations système", il est indiqué que le trim est activé... Pourtant je n'ai encore rien fait... Bizarre non ?
Tu lances le Terminal et tu fais un Copier/Coller de cette commande...
Bloc de code:
system_profiler SPSerialATADataType | grep 'TRIM'
...en validant avec la touche Entrée. Normalement tu dois avoir ce résultat...

Capture-001.jpg
...est-ce bien le cas ?
 

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
Alors, je ne peux pas faire cette manip pour l'instant car je suis en train de réinstaller l'OS. C'est un peu long... :rolleyes:
En revanche, avant de le faire, j'avais relancé un rapport d'erreurs, et cette fois-ci il était indiqué que le trim était activé.

Informations des disques :
disk0 - APPLE SSD SD0128F 121.33 Go (SSD - TRIM : Oui)
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 754
4 315
Alors, je ne peux pas faire cette manip pour l'instant car je suis en train de réinstaller l'OS. C'est un peu long... :rolleyes:
C'est normal, car si la commande cmd+R donne accès à la partition de récupération, cette dernière doit télécharger plus de 5 Go pour le fichier d'installation et donc c'est tributaire de la qualité de ta connexion internet.
En revanche, avant de le faire, j'avais relancé un rapport d'erreurs, et cette fois-ci il était indiqué que le trim était activé.

Informations des disques :
disk0 - APPLE SSD SD0128F 121.33 Go (SSD - TRIM : Oui)
Un bug d'EtreCheck ? Peut-être, mais c'est bien la première fois que l'on lit ça et crois-moi des rapports on en a lu une pelletée.
 

Rudjiuf

Membre junior
2 Juin 2020
28
0
39
Un bug, je ne sais pas, mais vraiment la seule manip que j'avais fait avant de relancé EtreCheck, c'est activer le coupe-feu dans sécurité.