10.11 El Capitan Recherche finder et mail inactive sur SSD

maena

Membre émérite
23 Août 2007
606
9
Bonjour à toute la communauté MacGé :)

Alors j'ai monté mon MBP mi-2012 sans problème en 16Go + SSD 525 Go.
Tout c'est parfaitement bien passe mais je remarque que depuis, la recherche dans Mail et dans le Finder ne fonctionnent plus.

Y-a t'il un lien, peut-être pas ... mais clairement la recherche, que je n'ai jamais trouvé très bonne sur mac os comparé à windows (c'est là mon seul reproche), ne ramène jamais aucune occurence alors que les données correspondantes sont bel et bien là ... C'est quand-même un poil ennuyeux.

@ +
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 722
5 675
Nancy___
Bonjour,

Vérifie déjà que tu n'as pas exclu ton SSD de Spotlight :D (Préférences Système / Spotlight / Confidentialité).

Autrement : https://support.apple.com/fr-fr/HT201716

Et perso, je n'ai jamais vu une recherche si bien faite que sous mac OS (incluant Mail).
 

maena

Membre émérite
23 Août 2007
606
9
Pas de problème du côté des paramètres de confidentialité spotlight.

Je pense plutôt à une probème d'index .....
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 573
21 468
Forêt de Fontainebleau
Bonjour maena

Tu peux aller à : Applications > Utilitaires > pour lancer le «Terminal». Dans la fenêtre ouverte > saisis la commande :
Bloc de code:
sudo mdutil -E /
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande) --> une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe de session admin à l'aveugle - aucun caractère ne s'affichant à la frappe - et ↩︎ de nouveau.

  • Cette commande appelle avec sudo (qui fait emprunter l'identité de root, le System Administrator) > l'utilitaire mdutil (metadata_utility : utilitaire de méta-données de Spotlight) > avec l'option -E (Erase : effacer) > et la cible / (le point de montage du volume-Système démarré)
  • Les bases de métadonnées de Spotlight vont être effacées > et le processus de leur reconstitution par indexation engagé dans la foulée
  • Ouvre dans le même sous-dossier des Utilitaires le «Moniteur d'activité». Va à la lettre m --> tu vas voir affichés les agents de la ré-indexation (dont les intitulés commencent par md comme metadata : mds, md-worker etc.) en train de consommer du CPU. Tant qu'un % positif leur est associé > laisse-les œuvrer. Il est normal que les ventilateurs s'activent > car le processeur a du grain à moudre.

Quand tout est retombé au calme plat et qu'un 0,0 est associé au % des agents de la ré-indexaction > c'est que l'opération est terminée. Tu peux re-démarrer une fois et re-tester une recherche.
 

maena

Membre émérite
23 Août 2007
606
9
ok je test ça demain et je vous dis.
Par contre du côté des paramètres de confidentialité Spotlight, mon Macintosh HD est présent dans la liste.
Je l'ai retiré mais il semble qu'il y soit remis à chaque reboot.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 722
5 675
Nancy___
Pas de problème du côté des paramètres de confidentialité spotlight.
Par contre du côté des paramètres de confidentialité Spotlight, mon Macintosh HD est présent dans la liste.
hum hum hum… :cool:

Forcément que si ton dd est dans les paramètres de confidentialité de Spotlight, Spotlight ne va pas l'indexer donc la recherche ne trouvera rien.


Maintenant si tu l'enlèves et qu'au prochain redémarrage ton disque s'y trouve de nouveau présent, il y a un problème… Peut être un fichier .plist vérolé (celui là : com.apple.systempreferences.plist ?)
 

maena

Membre émérite
23 Août 2007
606
9
Donc en effet à chaque redémarrage le SSD se retrouve dans les paramètres de confidentialité. Mais même après l'avoir supprimé la recherche ne fonctionne pas.

Je supprime le fichier com.apple.systempreferences.plist et je reboote ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 722
5 675
Nancy___
Ne le supprime pas, mais déplace le sur le bureau puis tu redémarres (peut être que fermer la session et la relancer suffit, mais dans le doute redémarre).
 

maena

Membre émérite
23 Août 2007
606
9
J'ai déplacé le fichier com.apple.systempreferences.plist sur le bureau et j'ai rebooté.
Toujours pareil Macintosh HD apparait dans la liste de confidentialité.
C'est relou ...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
40 722
5 675
Nancy___
Essaye avec ce fichier (que j'aurais dû t'indiquer en premier) :

com.apple.Spotlight.plist
 

maena

Membre émérite
23 Août 2007
606
9
C'est pareil. Après avoir supprimé le Macintosh Hd de la liste de confidentialité puis déplacé le fichier com.apple.Spotlight.plist sur le bureau et rebooté, le SSD est de nouveau dans la liste de confidentialité ... Ca a l'air d'être compulsif ...
 

maena

Membre émérite
23 Août 2007
606
9
oui, je n'ai qu'un seul disque qui est mon nouveau SSD que j'ai nommé "Macintosh HD" ... J'aurai pu le nommer "Macintosh SSD" mais bon ...
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 573
21 468
Forêt de Fontainebleau
Alors voici ce que je te propose (hardi petit !) -->

Lance le «Terminal» (comme tu t'en doutais déjà) et passe l'une après l'autre les 2 commandes (copier-coller) :
Bloc de code:
sudo rm -rf /.Spotlight-V100
sudo mdutil -i on /
(après avoir validé la 1ère > une demande de password va s'afficher - commande sudo --> tape ton mot-de-passe de session admin à l'aveugle - aucun caractère ne se montrant à la frappe - et valide de nouveau. Pour le 2è sudo > aucun mot-de-passe ne te sera demandé : tu as un délai de grâce de 5')

  • la 1ère supprime le dossier invisible .Spotlight-V100 qui recèle le fichier de configuration VolumeConfiguration .plist recelant l'instruction d'exclusion. Ne t'inquiète pas : ce dossier sera recréé (sans l'instruction) au re-démarrage.

  • la 2è active sur le volume démarré (désigné par / = le point de montage) l'option d'indexation. Ne t'inquiète pas si tu as un retour qui paraît dire le contraire : c'est un simple effet d'inertie de la part du kernel.

=> Re-démarre impérativement et vérifie l'état des lieux dans ton panneau des Préférences Système.
 

maena

Membre émérite
23 Août 2007
606
9
Salut salut !

J'ai passé les 2 commandes et ça a réglé le problème de recherche pour le finder et dans Mail !

Merci beaucoup macomaniac et bon week-end !!
 
  • J’aime
Réactions: macomaniac