Réglage Encodages texte dans Mail

tjm

Membre junior
26 Novembre 2000
41
1
Visiter le site
Comment faut-il régler Encodages texte dans le menu Format?
En laissant sur Défaut, j'obtiens de droles de caractères sur les messages recus.
Que choisir donc entre :
- Occidental (ISO latin 1)
- Occidental (Windows Latin 1)
- Occidental (Mac mail)
pour être sur que tout le monde mac et PC recoive bien mes accents?
Merci.
 

-anonyme-

Légende
26 Février 2001
66 286
2 670
Dans OmniWeb le réglage par défaut est : Occidental (Windows Latin 1), mais je ne sais pas s'il faut appliquer le même réglage dans Mail.app
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
Quand on sait quel encodage choisir (ISO Latin 1 par exemple), comment faire pour que Mail le choisisse automatiquement à chaque lancement (plutôt qu'utiliser 'Par Défaut' à chaque fois) ?
 

-anonyme-

Légende
26 Février 2001
66 286
2 670
J'ai jeté un coup d'oeil car le sujet m'intéresse. Chez moi, le menu n'est pas accessible en rédaction de message, seulement en lecture. J'en conclus, peut-être à tort, que Mail sait quel encodage choisir, en fonction de la police que tu utilises. Normalement pour le français ça devrait être ISO Latin 1. A la lecture, l'option "défaut" doit marcher dans la plupart des cas, mais si ton message a une drôle de tête tu dois pouvoir sélectionner le bon encodage manuellement.

Ceci n'est qu'une théorie, je ne peux pas la tester car Mail refuse d'envoyer mes messages. Par contre j'ai pu constater que dans PowerMail, ça marche comme ça. Si j'envoie un message en français, il est encodé automatiquement en ISO-8859-1. Si je l'envoie en japonais, il est encodé en ISO-2022-JP. Simple, non ? Pour vérifier ça, envoies-toi un message. Quand tu l'auras reçu, fait pomme-maj-H pour afficher tous les codes, et trouve Content-type. Je crois qu'il vaut mieux envoyer ton message en mode texte simple pour voir ça.
 

Bilbo

Vétéran
Club MacG
17 Octobre 2001
7 084
727
Strasbourg
Une petite remontée à la surface de ce sujet manifestement récurent dans les forums. Je n'ai pas trouvé la solution.


Le problème en réception ne m'intéresse pas vraiment, c'est l'envoi qui pose problème. En réception, on s'en sort toujours en prenant le bon encodage dans le menu.

Un de mes correspondants utilise Apple Mail et ses caractères accentués ne sont pas lisibles sur Windows (ne me demandez pas avec quel logiciel client, je n'ai pas l'info ; il y a fort à parier qu'il s'agit d'Outlook Express). Par exemple : le mot "étape" et lu "étape".

Comment fait-on pour changer le mode d'encodage par défaut ?

En résumé, j'en suis là :
  1. Mon correspondant a dans ses en-têtes : Content-Type: text/plain; charset=UTF-8; format=flowed.
  2. J'utilise aussi Apple Mail et j'ai dans mes en-têtes : Content-Type: text/plain; charset=ISO-8859-1; format=flowed.
  3. Mes en-têtes restent en ISO-8859-1 lorsque je change la langue du compte.
  4. Si on peut choisir l'encodage pour les messages reçus, il n'en est rien pour ceux qu'on envoie.
  5. Un coup d'oeil sur les suggestions de cette page ne permet pas d'entrevoir une solution. On peut y voir la proposition : "Ability to choose character encoding for outgoing email".
  6. Une recherche avec Google est fastidieuse : les recherches du type "apple mail encoding choose" ne sont pas assez discriminantes.

Bref, je nage dans la semoule. Une idée ?
 

alfred

Membre d’élite
Club MacG
31 Janvier 2003
2 425
60
bxl
bilbo a dit:
Une petite remontée à la surface de ce sujet manifestement récurent dans les forums. Je n'ai pas trouvé la solution.


Le problème en réception ne m'intéresse pas vraiment, c'est l'envoi qui pose problème. En réception, on s'en sort toujours en prenant le bon encodage dans le menu.

Un de mes correspondants utilise Apple Mail et ses caractères accentués ne sont pas lisibles sur Windows (ne me demandez pas avec quel logiciel client, je n'ai pas l'info ; il y a fort à parier qu'il s'agit d'Outlook Express). Par exemple : le mot "étape" et lu "étape".

Comment fait-on pour changer le mode d'encodage par défaut ?

En résumé, j'en suis là :<ul type="square">[*]Mon correspondant a dans ses en-têtes : Content-Type: text/plain; charset=UTF-8; format=flowed.[*]J'utilise aussi Apple Mail et j'ai dans mes en-têtes : Content-Type: text/plain; charset=ISO-8859-1; format=flowed.[*]Mes en-têtes restent en ISO-8859-1 lorsque je change la langue du compte.[*]Si on peut choisir l'encodage pour les messages reçus, il n'en est rien pour ceux qu'on envoie.[*]Un coup d'oeil sur les suggestions de cette page ne permet pas d'entrevoir une solution. On peut y voir la proposition : "Ability to choose character encoding for outgoing email".[*]Une recherche avec Google est fastidieuse : les recherches du type "apple mail encoding choose" ne sont pas assez discriminantes.[/list]

Bref, je nage dans la semoule. Une idée ?
à priori, la seule solution que je vois pour l'instant, c'est de convertir au format "texte" et pas rtf pour les messages sortants. il est universel et ne devrait pas poser de problèmes quel que soit le logiciel sur pc. les deux options peuvent être ajouter dans la barre d'outils des messages sortants.
 

Bilbo

Vétéran
Club MacG
17 Octobre 2001
7 084
727
Strasbourg
alfred a dit:
à priori, la seule solution que je vois pour l'instant, c'est de convertir au format "texte" et pas rtf pour les messages sortants.
Tous les macs que j'installe ont Apple Mail qui fait du "Format texte". Je pensais qu'Apple délirait en proposant le RTF comme format. En fait, dans Mail, ça correspond au "MIME". Ça ne change rien à l'encodage par défaut.


Merci Alfred.


Une autre idée ?
Au point où j'en suis, tout est bon ! Il me faut des pistes.

En résumé :
  1. Mon correspondant a dans ses en-têtes : Content-Type: text/plain; charset=UTF-8; format=flowed.
  2. J'utilise aussi Apple Mail et j'ai dans mes en-têtes : Content-Type: text/plain; charset=ISO-8859-1; format=flowed.
  3. Mes en-têtes restent en ISO-8859-1 lorsque je change la langue du compte.
  4. Si on peut choisir l'encodage pour les messages reçus, il n'en est rien pour ceux qu'on envoie.
  5. Un coup d'oeil sur les suggestions de cette page ne permet pas d'entrevoir une solution. On peut y voir la proposition : "Ability to choose character encoding for outgoing email".
  6. Une recherche avec Google est fastidieuse : les recherches du type "apple mail encoding choose" ne sont pas assez discriminantes.
  7. C'est pareil en "Format texte" et en "RTF".
  8. Les en-têtes restent en ISO-8859-1 lorsque je change la langue du compte "root".
  9. Idem si je change de fuseau horaire.

Comment fait-on pour changer le mode d'encodage par défaut ?


À+
 

Bilbo

Vétéran
Club MacG
17 Octobre 2001
7 084
727
Strasbourg
Hé ben, je pouvais toujours chercher !


En fait Apple Mail encode le message en fonction de son contenu. Tout simplement.




Quelques exemples :

=============
azerty
=============
Encodage : charset=US-ASCII


=============
àÀô
=============
Encodage : charset=ISO-8859-1


=============
€ çà&amp;é
=============
Encodage : charset=WINDOWS-1252


Etc.



Je vais affiner les comportements en fonction des clients de messagerie et faire une page Web sur le sujet. Je vous tiendrai au courant ici même.

À+
 

JoMac

Membre confirmé
8 Novembre 2004
175
3
36
Désolé de revenir sur un vieux sujet mais j'ai trouvé que ça en faisant des recherches sur l'encodage des mails.

J'ai eu en effet le même problème, depuis que j'ai un mac, mail choisi automatiquement l'encodage à utiliser, mais ça fait plusieurs fois ou des personnes (sur pécé) recoivent des mails de ma part illisible, avec des lettres voir des mots remplacés par de la calligraphie chinoise ! Alors c'est pas tout le monde d'accord mais c'est embêttant surtout quand c'est un employeur qui reçoit ce type de mail alors que je postulais pour un emploi dans... l'informatique :hein:

Please, je veux tout en encodage latin mais il n'y a rien pour imposer cet encodage dans les préférences :rolleyes:
 

Taho!

Membre d’élite
Club MacG
9 Octobre 2001
4 404
558
39
Grenoble
www.pomme-grenette.org
Du coup, c'est pas mal que le sujet remonte car j'ai un GROS soucis avec Mail en ce moment ! mes encodages merdent plein bu ! en automatique mes collègues reçoivent n'importe quoi, en ISO Latin 1, pas de contenu du tout !

je pense aux préfs bien entendu, mais vu le nombre de règles que j'ai fait, ça me fait un peu chier quand même

un détail : je suis sous Tiger !
 

Lastrada

Membre d’élite
Club MacG
20 Décembre 2004
2 525
1 289
osaris a dit:
Je déterre un peu le topic car on a le même problème ici (entreprise) et voici la parade que j'utilise sur les postes :



Avec ceci d'ajouté, plus de problèmes ;)

Osaris

Hmmm. comment utiliser ceci ? dans une fenêtre terminal ? faut il éteindre et relancer mail ? faut il le copier dans le fichier de préférence ? comment ?

Merci ...
 

Goulven

Membre d’élite
Club MacG
2 Février 2004
2 398
378
47
Suisse
osaris a dit:
Je déterre un peu le topic car on a le même problème ici (entreprise) et voici la parade que j'utilise sur les postes :

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"
Avec ceci d'ajouté, plus de problèmes ;)

Osaris
Je remonte le sujet... A priori cela devrait résoudre mon soucis indiqué dans ce post. Mais comment fait-on pour, éventuellement, revenir en arrière?
 

Inor

Membre d’élite
Club MacG

polo

Nouveau membre
20 Février 2004
2
0
Bonjour,
même pb sur mon poste (tiger et Mail2).

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

Mais comment fait-on pour, éventuellement, revenir en arrière?

Comment fait-on pour envoyer une demande à Aplle ? Il faut absolument qu'ils modifient ça !
 

Inor

Membre d’élite
Club MacG
polo a dit:
Bonjour,
même pb sur mon poste (tiger et Mail2).

defaults write com.apple.mail NSPreferredMailCharset "UTF-8"

Mais comment fait-on pour, éventuellement, revenir en arrière?

Comment fait-on pour envoyer une demande à Aplle ? Il faut absolument qu'ils modifient ça !
Bonjour.

Moi, il m'a suffit de choisir dans Mail :
Message / Encodage du texte / Occidental ( iso latin 1 )
pour que les PC reçoivent-de nouveau-des mails lisibles.
Y aurait-il des exceptions à ça ? :confused: