Safari 11.1.2 polices illisibles sur certaines pages web.

OldschoolPoitiers

Membre confirmé
28 Mars 2021
14
2
46
Bonjour à tous,

J'ai depuis hier un problème d'affichage du texte sur certaines pages web (pas tous les sites) sur Safari. Vider le cache, vérifier les polices avec le Livre des polices, ne change rien.

La page web est correctement affichée si je bascule sur Chrome ou si je choisi Google Chrome- mac os dans le menu développement/ Agent d'utilisateur dans Safari. Si je bascule à nouveau vers Agent d'utilisateur/ Par défaut (automatiquement choisi) les caractères sont de nouveau illisibles.

Deux captures pour mieux comprendre sur un site sur lequel je commande des compléments alimentaires :

Avec Développement/Agent d'utilisateur/Par défaut (automatiquement choisi) :
Par défaut.jpg

Avec Développement/Agent d'utilisateur/Google Chrome- macOS :
Chrome Agent.jpg

J'arrive au bout des manips et vérifications auxquelles j'ai pensé. Si vous avez une piste ou une solution, je suis preneur.
 
Dernière édition par un modérateur:

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 706
5 213
Là-haut
La page web est correctement affichée si je bascule sur Chrome ou si je choisi Google Chrome- mac os dans le menu développement/ Agent d'utilisateur dans Safari.
Si je bascule à nouveau vers Agent d'utilisateur/ Par défaut (automatiquement choisi) les caractères sont de nouveau illisibles.
Le problème est donc sur le site qui a choisi de n’être compatible qu’avec Google Chrome ou certaines versions de Safari.

IE6 Revival… :rolleyes:

« Agent d’utilisateur » ne fait qu’indiquer au site un autre identifiant de navigateur, il ne change pas la façon dont Safari traite la page.

À noter qu’avec un Safari plus évolué (14.1.2 / Catalina) le site s’affiche parfaitement.

Safari 11.1.2 c’est vieux, trop vieux, comme El Capitan. J’utilise Firefox ESR sur ce système.
 
Dernière édition:

OldschoolPoitiers

Membre confirmé
28 Mars 2021
14
2
46
Merci pour cette réponse. Il faut dire que je travaille encore sur un MacBook Pro (13 pouces, mi-2009). À part y mettre un SSD, je n'y ai jamais touché en douze ans. Les Mac étaient visiblement construits pour durer! ;-) Pour l'usage que j'ai sur ce poste, il est encore tout à fait suffisant.

Je vois pas a priori de problème à changer d' "agent utilisateur" en fonction de la navigation, il est donc parti pour durer encore.
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 208
1 038
Toulouse.cong
faq.office.macintosh.free.fr
Je viens de faire un test avec Safari 5.1.10 (Snow Leopard) et il n'y a pas ce problème d'affichage (il y en a d'autres, dûs à l'ancienneté de cette version, bien entendu) :
Capture d’écran 2021-08-05 aϰ 00.36.30.png
Au vu du type de problème (affichage de certains des caractères seulement, les E, H, L et T), je penche plus vers un problème de corruption de caches de polices. Essaye de redémarrer une fois ton Mac en tenant la touche "Majuscules" enfoncée (démarrage en mode sans échec), ce qui déclenche (entre autres) un vidage des caches de polices. Avec un peu de chance...
 

OldschoolPoitiers

Membre confirmé
28 Mars 2021
14
2
46
Essaye de redémarrer une fois ton Mac en tenant la touche "Majuscules" enfoncée (démarrage en mode sans échec), ce qui déclenche (entre autres) un vidage des caches de polices. Avec un peu de chance...
Merci. La vidange du cache des polices au démarrage en mode sans échec a complètement solutionné le problème. :up: Grâce à toi, je vais pouvoir continuer d'utiliser Safari sans devoir basculer sur Chrome une fois sur dix.

Je pensais bien que le problème était de mon côté car certains des sites visités devenus illisibles n'avaient pas été modifiés depuis parfois des mois. Une nouvelle fois merci !
 
Dernière édition par un modérateur: